1. theusername1's Avatar
    Got an epic 4g touch on release day, noticed 3g was really slow. No problem, I noticed other epic 4g touch users were having slow data speeds. Thought an update would be out soon. Well I've come to realize my speeds are still WAY off!

    I am only getting 50 to 67 kbps. This basically dialup speed. Support said to take to repair center, something is wrong with the phone (after being forced to reset phone).... Well they said they get the same speed ratings on their phones. Oh, and they said it has been this way for a least 3-4 months.!!!!!!!!

    How in the world does anyone get by on 50kbs???? I have no idea why anyone would get an iphone with sprint.

    I even own stock in Sprint, so this is really sad. This phone is not even usable.

    Anyone else out their from Charleston, SC?

    (also posted on sprintusers)
    10-21-2011 01:43 PM
  2. chazglenn3's Avatar
    Man...that really sucks. You sure it isn't .50 to .67 Mbps? That would be a normal Sprint 3G speed, and mine today are .85Mbps to 1.1Mbps.
    10-21-2011 02:30 PM
  3. JayWill's Avatar
    Yeah big bummersauce eh? Sprint's data network really does suck in some areas. Network Vision can't come soon enough. But right now, if data speeds are important to you, you better hope Sprint has a strong footprint where you live. If not, it's the wrong network for you for now.
    10-21-2011 02:34 PM
  4. theusername1's Avatar
    Man...that really sucks. You sure it isn't .50 to .67 Mbps? That would be a normal Sprint 3G speed, and mine today are .85Mbps to 1.1Mbps.
    yes, i'm getting .04 to .07 mbps.
    10-21-2011 03:23 PM
  5. jjordan#AC's Avatar
    I had the same problem you have been having. I also always got below 50 kbs, usually no service. I also tested old og epic at same places and times. It averaged 500 kbs, and always had service. I also spent hours on phone tech. And drove 45 miles to nearest tech center. Of course with their airave the phone worked fine. So they denied there was a problem with the phone at all. I wanted to try another phone in case I had a bad one, but was informed that even though the phone was broken. I would be charged a 35 dollar restock fee, and 35 dollar non refundable activation fee. Even though I had the phone back to store in less than 24 hours to complain about it. All the tech support calls,and visits took it past the 3 days allowed.

    So I paid 70$ rent for 4 days with a broken phone. And if I would have tried another phone, and got another bad one, I would have paid another 70$ rent. So I cut my losses and told them where to stick their broken phone.
    10-22-2011 07:38 PM
LINK TO POST COPIED TO CLIPBOARD