1. wotan's Avatar
    I've checked all of my settings and my gmail app is just plain flaky. It rarely ever has mail pushed to it and even a manual sync is iffy-at-best.

    Anyone else having problems or figured out some kind of a solution? Or is there even a way to troubleshoot this?
    10-26-2011 09:59 AM
  2. JayWill's Avatar
    Maybe go to Manage Applications, force close Gmail, clear data then uninstall. Download it from the market, re-install and set up your account again. Otherwise, is this happening all the time or only at certain times? If it's only certain times, it could be a data connectivity issue.

    My Gmail pushes almost instantly. I've had no issues with it at all.
    10-26-2011 11:27 AM
  3. dragonol2's Avatar
    I've checked all of my settings and my gmail app is just plain flaky. It rarely ever has mail pushed to it and even a manual sync is iffy-at-best.

    Anyone else having problems or figured out some kind of a solution? Or is there even a way to troubleshoot this?
    Posted a few days ago... at least you're not the only one I guess (glass half full?)

    Gmail issues

    Oh, and **edit**

    My gmail syncs reliably as well... sometimes it's instantly, sometimes it's a few minutes after it should, but nevertheless, it's definitely working as it should at the moment
    10-26-2011 11:33 AM
  4. JDAustin's Avatar
    Is Background Data/Auto-Sync being enabled required?
    10-26-2011 12:14 PM
  5. wotan's Avatar
    Is Background Data/Auto-Sync being enabled required?
    Oddly enough, this was my problem! The weird part is that I never disabled auto-sync/background data. When I read your message I was like... OF COURSE THIS IS CHECKED OR I WOULDN"T EVEN POST HERE... and then I went and checked.

    Mouth. Foot. Thanks for "fixing" my phone!
    10-26-2011 04:17 PM
  6. cboekhoven's Avatar
    It's that dang priority inbox garbage. there was an update that made it so priority inbox got pushed right away and non priority took it's fat time

    Sent from my SPH-D710 using Tapatalk
    10-26-2011 05:17 PM
  7. rlanza1054's Avatar
    Hi,

    I'm glad you got the problem fixed.

    But I would like to ask why you would want 'push' turned on.

    Why not just check your mail once an hour or if you need it a little shorter.

    Doesn't using 'push' drain your battery?

    Rob

    Sent from my SPH-D710 using Tapatalk
    10-26-2011 10:00 PM
  8. wotan's Avatar
    Push should (theoretically) use less battery than pull.

    I'm getting 16-18 hours off a charge right now so I'm not too stressed about extending my battery life any further, even if the pull does use slightly more battery (which, again, it shouldn't.)
    10-26-2011 11:18 PM
LINK TO POST COPIED TO CLIPBOARD