1. flare576's Avatar
    In the process of trying to troubleshoot a different problem I had to get a new Samsung Galaxy S II Epic Touch 4G. In order to avoid losing data and progress in games and system settings, I used Titanium to do a backup which I restored to the new device (Apps, System data, everything)

    At this moment I cannot use WiFi: it gets stuck in "Obtaining IP address" at each of the 3 access points I've attempted to use (a combination of OPEN and WEP secured). I was able to connect to at least one of them before the Titanium restore (during activation of my new phone).

    I'd like to simply start over from scratch with this device, but

    Home -> [Menu] -> Settings -> Privacy -> Factory Data Reset

    doesn't have any impact to this problem. I'd really like to do a full re-install of the system, but all information I've found suggests that the only way to do that is with a stock ROM image, which I've been unable to find.

    Is the assumption that I need a stock ROM correct? Is it available somewhere and I've just not looked hard enough?

    Thank you for taking the time to read my post!
    10-26-2011 11:48 AM
  2. JayWill's Avatar
    Wow okay ... I'm going to have to make some assumptions here because your post is missing some critical details.

    First, because you're talking about Titanium Backup, I'd assume your original phone was rooted. Since you did a restore, I'm also assuming you rooted your new phone. Before I go on, it's rarely, if ever, a good idea to restore system data that you backed up. App data is fine, but restoring system data from another phone (or even the same phone) is just asking for trouble.

    So assuming you're rooted, and you do want to restore back to "completely stock" (no root, no custom recovery), here is how to do it ...

    The link to download the stock TAR file is in the description. However, the ACS forums appear to be down again, and I don't know of a mirror anywhere.

    Good luck!
    Slingbox and flare576 like this.
    10-26-2011 12:09 PM
  3. flare576's Avatar
    Very sorry for the missing data, but you assumed the first part correctly. I'm very new to Android and made some critical mistakes due to lack of understanding.

    My first device was rooted almost by accident; I was trying to fix a GPS issue and read a firmware fix would help. I ended up flashing a firmware that left me rooted, so I took advantage of it and made a full backup.

    After figuring out how to un-root (via flashing the stock firmware) and remove Superuser, I brought my device back to Sprint and they sent me a new one, which I re-rooted and restored, making the mistake to also restore system data.

    Now I'd like to undo everything. I've already flashed the firmware back to stock, removed su/superuser, and done a factory reset, but the problems I introduced with the Titanium restore are lingering. I want to do the equivalent of a system format and re-install, which was cake on WebOS, but doesn't seem to even be an option yet for this phone.

    Does that help? Sorry for the missing data; I'm still not entirely sure what is relevant and what is common.
    10-26-2011 12:27 PM
  4. JayWill's Avatar
    Yep that helps. It looks like my assumptions were correct. Following the process qbking detailed in the video I linked should provide what you're looking for. Although you're going to have to wait until the ACS forums are back up to download the file you need. It should be easy for you since you're already familiar with using Odin.
    10-26-2011 12:43 PM
  5. flare576's Avatar
    Finished watching the video, which featured a shot of the file size of the TAR... 450MB looks like the full OS

    Thank you so much, JayWill72. I'll report back in once the forum and file are made available again
    10-26-2011 12:57 PM
  6. romanodog's Avatar
    flare, that is the tar file I used to unroot my phone and it worked perfectly. I had an issue with a different "stock" kernel but this one worked. Good luck!
    10-26-2011 01:04 PM
  7. flare576's Avatar
    Reporting in: following the instructions after the download became available worked 100%. Thank you again, and I'll open a new thread about the problem that lead to all of this mess: GPS and device encryption.
    10-26-2011 02:34 PM
  8. JayWill's Avatar
    Reporting in: following the instructions after the download became available worked 100%. Thank you again, and I'll open a new thread about the problem that lead to all of this mess: GPS and device encryption.
    I'm glad it worked for you. Yes that file contains the data from the zimage pulled from a stock unrooted phone, so it brings you back to the state as if you just walked out of the store with it. I'd imagine technicians use a similar, if not identical process to get a refurb ready for resale or exchange.

    The real thanks however should go to the devs that put this stuff together, and qbking for making a video walkthrough. Maybe consider clicking on a few ads on the ACS website and even a small donation if your wallet can spare it. While these guys often give us the gun to shoot ourselves with (lulz) they also often provide the means to repair the damage.

    If anything, you learned what NOT to do out of all this, and that's always worth something.
    10-26-2011 03:05 PM
  9. flare576's Avatar
    I spent the last ~3 years with WebOS, and donated frequently to WebOS Internals because they were the primary contributors to the things I used most. Once I kind of figure out who does what, I'll be showing support for sure! I just don't know what contributions each party is bringing to the show yet, and it's not a good feeling to realize you just donated to someone who copy/pasted from another group

    ACS has been stamped on a lot of the pages I've used, though, so I'll be figuring out how that group works soon

    Thank you again; this is my first experience with the Android community, and it makes me feel a lot better about having to leave WebOS.
    10-26-2011 04:49 PM