12-11-2011 04:46 PM
157 ... 567
tools
  1. Slingbox's Avatar
    Sprint tech swapped batteries to see if that helps with the drain. And also has a phone on order should be here in a day or 2.
    Sweet!
    11-17-2011 01:12 PM
  2. JayWill's Avatar
    Sprint tech swapped batteries to see if that helps with the drain. And also has a phone on order should be here in a day or 2.
    Awesome. Let us know how it turns out.

    Sent from my E4GT via Tapatalk
    11-17-2011 01:22 PM
  3. g_schrage52's Avatar
    16.5 hours today with normal "yellow" signal and its still got 11% left. I normally get 13 or so but wasn't online/Twitter nearly as much today.


    Sent from my SPH-D710 using Tapatalk
    11-17-2011 11:12 PM
  4. androidpirate's Avatar
    Has anyone else gotten sudden battery level drops? I got the phone last week (and is still unrooted) and have had two instances of battery level dropping 20%+. the first time happened when the phone froze in the stock browser, had to reboot. the second time also happened while browsing the web and I believe i accidentally held the power button for too long, the phone rebooted.The attached screen shot shows battery level that was at 50% then after the reboot, at 20%. the phone wasn't even hot or warm. is this a known issue/should I exchange the phone/is there a fix for it? Thanks in advance!
    12-11-2011 01:22 AM
  5. JayWill's Avatar
    It happens commonly when the phone reboots. I think it has some to do with how the battery calibration works on Galaxy S2 phones.

    Sent from my SPH-D710 using Tapatalk
    12-11-2011 02:08 AM
  6. androidpirate's Avatar
    It happens commonly when the phone reboots. I think it has some to do with how the battery calibration works on Galaxy S2 phones.

    Sent from my SPH-D710 using Tapatalk
    does that mean the battery level was worse than it initially reported? also, is there a solution?
    12-11-2011 02:51 AM
  7. DirkBelig's Avatar
    I've seen this crazy drops after reboot behavior a few times and it just had the worst example ever. It was acting a little flaky so I rebooted it and it went from 59% to 9%!!! However, while still here in the store, it's climbed to 15% after 15 minutes. Very unnerving.
    12-11-2011 04:46 PM
157 ... 567
LINK TO POST COPIED TO CLIPBOARD