1. YBCold's Avatar
    Just the past week or 2 my phone has started freezing while running email, message & sometimes tapatalk.

    Again this just started all of a sudden and that is without any additional apps.

    Any suggestions?

    Sent from my SPH-D710 using Tapatalk
    11-09-2011 06:39 PM
  2. Evo4g's Avatar
    I posted this as well. Really getting on my nerves, not sure what is the cause.
    11-09-2011 08:17 PM
  3. YBCold's Avatar
    have you tried a factory reset?

    Thought I'd ask before wasting my time.

    Sent from my SPH-D710 using Tapatalk
    11-09-2011 08:56 PM
  4. Cobravision's Avatar
    Take the sd card out and run a scandisk and defrag in Windows. Move your sd apps to phone first.

    I did this with my Evo a couple of times and my Galaxy Tab as well.
    11-09-2011 08:58 PM
  5. YBCold's Avatar
    Can I do it while its in the phone?

    Sent from my SPH-D710 using Tapatalk
    11-09-2011 09:00 PM
  6. Cobravision's Avatar
    I did it on the phone on my Evo, but the Epic Touch doesn't show up as a removable drive, just a camera. I think if you have the right drivers, it will show up as a removable drive.
    11-09-2011 10:03 PM
  7. JayWill's Avatar
    Nah you just have to enable USB debugging on the phone to have the internal and external sd cards show up as drives.
    Cobravision likes this.
    11-09-2011 11:31 PM
  8. dtblair24's Avatar
    I had these issues when I first got mine a couple of weeks ago. Would freeze when browsing, email, and pretty much any other app randomly. I finally decided to perform a factory reset, and to get a new SD card. Started slowly trying to add apps back to see if I could pick out which one might have been a culprit. But ever since my phone has been fine. Has not froze once since. So I guess the factory reset fixed it for me
    11-10-2011 03:20 AM
  9. YBCold's Avatar
    Well, I formated the sd card last night and will try it out for the day to see if it helps. If not I'll go down the factory reset route.

    Thanks again to everyone for your suggestions.

    Sent from my SPH-D710 using Tapatalk
    11-10-2011 05:52 AM
  10. Drummerboy1975's Avatar
    I've had an issue with Angry Birds actuaing up, but only on a few occasions.
    11-10-2011 09:23 AM
  11. niknak01's Avatar
    I got my phone on Sept 16th and never had any problems with it. For the past two weeks, it has been freezing up and doing all kinds of crazy stuff. So I finally broke down and did a factory reset (reluctantly) but its been running smooth every since.
    11-10-2011 09:33 AM
  12. YBCold's Avatar
    Looks like I'll need to do a factory reset. This is starting to make my work difficult.

    Well let everyone know how it turns out.

    Sent from my SPH-D710 using Tapatalk
    11-10-2011 10:49 AM
  13. JayWill's Avatar
    Yeah I would venture to bet something in your system files got corrupted somehow. A factory reset should do the trick.
    11-10-2011 11:01 AM
  14. YBCold's Avatar
    So how do you perform an factory rest on this thing? HTC has an option in settings but didnt see that anywhere.

    Isnt there a power/volume rocker combo to do this?

    Thanks!

    Sent from my SPH-D710 using Tapatalk
    11-12-2011 06:52 AM
  15. tkemack's Avatar
    Settings –> privacy

    Seems an odd place to put it
    YBCold likes this.
    11-12-2011 07:18 AM
  16. YBCold's Avatar
    Thanks! I knew I saw it some where.

    Well here we go, I'll let everyone know how it turns out

    Sent from my SPH-D710 using Tapatalk
    11-12-2011 07:28 AM
  17. YBCold's Avatar
    Well, the reset dreams took be going well so far. Tomorrow will be the true test once I've been able to really put this thing to work.

    I'll let everyone know how things turn out.

    Thanks again for ask the help!
    11-13-2011 10:08 AM
  18. YBCold's Avatar
    Oh and still havent put all of my music and photos back on yet so that will be one other test that this thing will need to pass as well.
    11-13-2011 10:10 AM
  19. YBCold's Avatar
    Well, it seems that as soon as my email account starts seeing heavy traffic, the stock email app starts to freeze like crazy. Not sure if it would help to adjust the amount the mail box is syncing but I only have it set to 2 weeks and it is freezing again and its starting to force close itself.

    This needs to be fixed soon or I will be in big trouble for work as I use email constantly on the go.
    11-17-2011 07:40 AM
  20. handsomeprince#AC's Avatar
    To the OP...if you're heavily reliant on timely receipt of emails; get another phone. I mean the S2 is a great phone; I really enjoy mine...but it doesn't handle emails well. However this isnt an S2 issue per se; more so an Android synching/push/pull issue. Basically the equation works out as so...a phone is not equal to or greater to one's job. So if youre risking any rifts or problems with your J-O-B over a phone's handling of email of all things...not worth it.
    11-17-2011 10:07 AM
  21. YBCold's Avatar
    Its crazy cause my evo used to do just fine.

    Well either way, im locked in for now and might look at a new phone once the quad core phones start to drop. Maybe I can look at am aftermarket app for now.

    I remember someone talking about a good aftermarket app but can't remember the name
    11-17-2011 07:38 PM
  22. JayWill's Avatar
    I don't know if you'll see this before it's too late, but an app called Enhanced Email is free on the Amazon apostore today. It's normally a $10 app. Could help with your mail issues I dunno.

    Sent from my E4GT via Tapatalk
    11-17-2011 11:31 PM
  23. YBCold's Avatar
    Thanks, but I think I missed it. Oh well, it seems like it its working ok for now.
    11-18-2011 10:07 PM
LINK TO POST COPIED TO CLIPBOARD