1. MannyZ28's Avatar
    So GTA 3 is on sale for 3 bucks right now, but reading through the reviews, there seem to be a lot of issues. Has anyone tried it? I wish more people would specify which version of the S2 they have in the reviews. Nothing worse than buying a game and not being able to play it but instead having to wait for an update to make it work on your phone.
    12-23-2011 11:06 AM
  2. bgsanti's Avatar
    they released an update for the s2. they dont specify which version of the s2. however, i bought it prior to any updates and it ran fine on my e4gt.
    12-23-2011 07:26 PM
  3. fatcat13sep's Avatar
    Doesn't work for me. However it seems a lot of people with the gs II have the same problem so it most likely will get fixed.
    12-23-2011 11:25 PM
  4. MannyZ28's Avatar
    It's kind of interesting, my one friend has the GS2 on AT&T and it doesn't even show the game in his Android Market. When I send him the link, it says that his device is not compatible with the game. Another friend has the GS2 Skyfire (which has the 1.5 Ghz Snapdragon instead of the Exynos) and it too can't see the game in the market.

    Strange stuff.
    12-24-2011 12:25 AM
  5. 2ndaccord's Avatar
    I got it. It works good for me. Playing it on a epic touch.

    Sent from my SPH-D710 using Tapatalk
    12-24-2011 01:10 AM
  6. tkemack's Avatar
    Doesn't show up in the market for me either, I have a feeling its the ROM I'm running

    Sent from my Blazing ET4G
    12-24-2011 07:34 AM
  7. sledgie#AC's Avatar
    Try going into language and keyboard settings and change to UK English or something. That's how I've always gotten games that aren't available in my area. I found this out with the tmobile version of the original GT and it worked sweet. Let me know if it works.
    12-24-2011 09:37 AM
  8. MannyZ28's Avatar
    Very strange how it is listed as an unsupported device. AT&T users really get the shaft with their version of the GS2, there are quite a few things that are missing compared to the Sprint version. Among them:

    1. No visual voicemail
    2. No way to change the screen mode to "vivid", "medium" or "normal" or whatever they are called
    3. No option in the phone log to sort by "all voice calls"
    4. You can only check for software updates once every 24 hours. Frequently it will fail, and then you have to wait another 24 hours before trying again.

    Real sucky.
    12-24-2011 11:49 AM
  9. thesmj's Avatar
    Works well for me on my Epic Touch. I only played the first couple missions, though.
    12-24-2011 11:52 AM
  10. MannyZ28's Avatar
    Ok my friend with the AT&T GS2 changed the settings and sure enough, then it shows up. I bought it but I haven't downloaded it yet. Once I do that and deem it to be worth buying, I will report back to my buddy and he might buy it then. It would be curious to see if it runs fine on his phone, and if it does, you wonder why you had to do that change to make it work on the AT&T model.
    12-24-2011 02:50 PM
  11. tkemack's Avatar
    Changing language didn't help me. Had to restore to my original stock rom, downloaded game and did a titanium backup of it. Then restore back to blazer and restore game through titanium. Works like a champ now

    Sent from my Blazing ET4G
    12-24-2011 06:27 PM
  12. MannyZ28's Avatar
    Ok...runs good on mine. Interesting how it check Ram and Rom before the game starts...

    What method of steering is everyone using? There are options for analog and accelerometer, but when I start the game that way, the steering controls with an analog stick, not the accelerometer?
    12-24-2011 08:55 PM
  13. fatcat13sep's Avatar
    update: so i decided to uninstall and reinstall one more time and made sure i was looking at the phone the whole time so the screen wouldn't black out etc. and it now works so epic 4g touch is a go for gta3
    12-25-2011 12:05 AM
  14. thesmj's Avatar
    Ok...runs good on mine. Interesting how it check Ram and Rom before the game starts...
    Thats just the R* brand movie. The PS2/PC version had the same video play on startup. Its just a video file and isn't actually doing anything.
    12-25-2011 02:32 AM
  15. imparishilton's Avatar
    Sent from my SPH-D710 using Tapatalkcan anyone tell me why my phone wont download all the internet files to start game. Ive used wifi and 4g and it never gets to 100%
    12-27-2011 06:20 AM
  16. Psychosaturn's Avatar
    Works great! Give us Vice City and the the grand daddy of them all... SAN ANDREAS!
    12-28-2011 08:00 PM