12-10-2016 08:50 AM
33 12
  1. Jexeighteen's Avatar
    Ok..tried searching, found nothing.

    I own a 2010 GMC Terrain that has a USB input for audio devices. It works fine with an iPod, iPhone, Evo 4G, Evo 3D, Nexus S.....but I've had my SGS2 for a couple of months and still won't work.

    When I plug it in, it says the device is not supported. I don't understand why it wouldn't work when everything else worked fine. Pretty annoying because I like playing the music on my phone rather than the radio. Was wondering if anyone else has run into this problem and figured out a solution.
    08-09-2012 08:18 PM
  2. Jexeighteen's Avatar
    What is the size of the memory on your SGS2? if it's more than 32GB & see if the system used to format the memory is NTFS. If that's the case then that's the problem.
    I experience the same problem when I tried playing music from my 500GB external hard drive. But I discovered the solution and now my external hard drive is now working with the USB on my car stereo. U need to format the memory using FAT32 system which car stereo will recorgnize it. you car stereo can not detect drives that are formatted with NTFS.
    08-09-2012 08:29 PM
  3. akershaw3's Avatar
    hi, i dont know if you have solved this problem but i had a samsung galaxy s 2 and i connected mine fine through the usb connection, settings, usb utilities, connect device (or something similar) it should then tell you to connect the cable, it wont work if you connect the cable first, i have just upgraded to the galaxy note 2 and that wont work so im a bit miffed as i have the usb port in my car and hifi at home so i think im going to try and exchange it, hope ive helped x
    10-20-2012 02:06 PM
  4. Lizzski's Avatar
    Nah...doesn't work for me either. Tried Bluetooth. Tried Aux jack.... out of ideas.
    11-20-2012 09:04 AM
  5. joey roberts's Avatar
    my usb was working then it stop. so i disconnect the battery and it rebooted it now works
    11-07-2013 07:42 AM
  6. mootcat's Avatar
    It looks like you have root the phone and then get the mass storage app that others are talking about in this string.I just tried the app and it will not work with the phone not rooted. Rooting looks fairly complicate and may or may not F up the phone. So I am not sure if I want to attempt it. I am currently using a Blue tooth device that I got at the Verizon store which cost around $70 This plugs into the aux jack and works fairly well but you don't have the benefit of the radio display or controls :-(.
    07-29-2014 10:55 AM
  7. DEBBIE933's Avatar
    Cant get my phone to work through aux but xm comes through
    11-02-2015 04:48 PM
  8. Lee3953's Avatar
    How do I get my alacatel to play through my aux system
    12-10-2016 08:50 AM
33 12

Tags for this Thread