07-29-2017 02:44 PM
61 123
  1. elihall08's Avatar
    The GPU rendering fixed it for me it appears on my Virgin mobile S2 epic 4g thanks!
    01-16-2014 02:33 PM
  2. GuccizBud's Avatar
    I've been through all these thousands of different post trying to figure out MY issue, which is the same...... Phantom Menu Button presses, and through trial and error, from sitting my phone in an area with a strong signal, to the opposite, to blatantly slamming my phone on the table and floor. Uninstalling and reinstalling apps, airplane mode and the works. There is only one 100% clear solution if you dont plan on returning your phone and are just as hard headed as I am.

    There is an electrical disturbance that happens between the Touch button and the circutry that activates the menu.
     [ . . . ]
       [ . . . ]
      [ . . . ]
    Feel free to copy this and post on different sites to spread the word if this helped you. Thanks!
    For the sake of posterity, everything you need to know about what causes this issue, at least as far as this thread is concerned, is to be found in the entry posted by the man above ( not God… Michael Alan Harlow ), and can be viewed in its entirety by reading post #46 of this thread. Took me 1½ years to come to the same conclusions he did.

    Putting aside the semantics of hardware versus firmware ( i.e. software controlling hardware ) for the moment in an effort to keep the majority of this forum's target audience in mind ( tl;dr = this ain't xda ), this is a hardware problem folks, and bears no relationship to which apps you may or may not have installed on your device, no matter how much you really, really think it's your text messenger or workout log app or wtv.

    If this last describes you, then what you're forgetting is that correlation does not imply causation; in other words, the reasons it mainly seems to happen when you're in your messenger (for example) are (a) because you spend a proportionally larger percent of the time texting than doing other things, so the odds of it happening when you're texting are higher than the odds of it occurring when you're doing anything else, (b) because we know it's related to network data signal or lack thereof, and you use the network when you're texting and not when you're playing Tetris, and maybe (c) you do a lot of texting from home, from your room in particular, which happens to be in a spot where the signal can be spotty, which is also something we know to be related to the problem. And so on. Hardware, not software not apps.

    Crucially, this means you can't fix this issue permanently yourself if your device does this, if you define "fix" in this case as meaning those keys no long stutter by themselves, ever, without you having had to either do something or sacrifice something in exchange. If your device does this there are two paths you can take :  replace, or workaround.

    That is, taking it to your authorized Samsung retailer or service center and having them swap it for another one, one that wasn't part of the batch of screwed up ones your first one came from. I don't know if they know how to go about ensuring that, but based on probability alone you should be alright… this is definitely a very small percentage of all the millions of Note®Ⅱ's sold ( lucky you and me ).

    A few were mentioned in this thread ;  they will work for some, not so much for others. Do what works for you. There is only one workaround I know of that should work for everyone, and it's what I ended up doing when I had this problem, but it does require a rooted device. The process involves completely deactivating the device's two capacitive keys ( not the Home button ) and replacing them with a softkey equivalent :  a narrow strip that sits at the very bottom of your display, right over the deactivated capacitive keys, with icons on it that represent the original capacitive keys and do their job for them ( without stuttering, lol ). If you're not sure what I mean, do an image search on "Nexus 6" and look at the pictures that show the display lit up. You'll notice that device doesn't have capacitive keys at the bottom ( not even a physical "Home" button ), and instead, those functions are handled by minimalist-style icons ( which I called "softkeys" a little ways up ) that appear in a row along the very bottom of the lit up display. After you turn the capacitive keys off on your Note®Ⅱ, the process concludes with replacing them with something very much like that.

    It's basically 3 steps, but this post is already a mile long ( give or take ) so I'll write that as a follow-up post below this one in a couple days.
    09-07-2015 11:48 PM
  3. GuccizBud's Avatar
    Sorry for the delay; here's the follow-up.

    * * * * * *


      First you need to disable the two capacitive keys MENU (left) and BACK (right) by commenting out two lines in a particular low-level file.

    NOTE :  As I said in my previous post, you will need root access for this.

    NOTE :  This is completely reversible ;  you are not "breaking" anything.

    FILE :

    The two lines in question are these :

      key 139 MENU
      key 158 BACK

    To disable them just comment them out :

      # key 139 MENU
      # key 158 BACK


    Now that both capacitive keys are inactive, you probably don't want them lighting up anymore ( if you do, whatever the reason, just skip this step ). This is just a regular Note®Ⅱ setting that needs to be changed.

    To disable the backlights, go to :

       > Display
        > Touchkey light duration

    … and set to …

      Always off


    This is where you replace your now silent capacitive keys with a software equivalent, similar to what the Nexus 6 uses.

    You have more than one choice here. The Note®Ⅱ does in fact "come with" one, and it can be activated rather easily, but there does exist other navbar-type apps you can install which offer significantly more customizability than the phone's own "inbuilt" (stock) one. You may wish to start with the latter just to get a feel for it and check out other options later on. I say a bit more about this at the bottom.

    To activate the Note®Ⅱ's stock nav bar :

    NOTE :  Root required for this step.
    FILE :

    The visibility of the stock software nav bar is dependent on the value assigned to :


    … in the build.prop file. If the line is absent, its value is zero. As such, add the following line to the bottom of your build.prop :


    … then save and reboot.

    To disable the nav bar, either simply delete the line above ( save & reboot ) or, the better alternative, leave the line in but change the value to zero :


    … and add in a couple of (#) comment lines describing what the line is and what it does ( save & reboot ).

    * * * * * *

    A word on other nav bar choices.

    Personally, after having used one of the commercial ones for over a year, I couldn't go back to the stock one, and if you're something of a customization junkie as I am, I suspect you'll be much more satisfied with a commercial one as well, as you can define pretty much everything that is definable about a navbar : activation method, auto-hide, timing preferences ( time to appear/disappear, time to stay visible, etc.), choice of icon(s), color of both icons and background, even the number of icons and how they're placed ( you aren't limited to just MENU and BACK ), and so on. As I said, pretty well everything that can be customized… a good nav bar can significantly improve your device's user interface.

    It may not be proper to recommend one here in the thread, so if you want to know the nav bar I've been using this past year or so ( it isn't available on Google Play at this time ) PM me and I'll direct you to its developer ( he's friendly and approachable, based on my dealings with him ) and let him fill you in.
    09-14-2015 02:16 PM
  4. Asha-kay's Avatar
    I deleted magic jack!!!! It stopped entirely!!
    10-06-2015 02:18 PM
  5. Kartik Katiyar's Avatar
    will replacing LCD do any .....??
    04-20-2016 08:21 AM
  6. Ajasears1978's Avatar
    I'm having the same problem as well. I'm using my Bck up phone my gs5. Its NVR happened b4. This is my second time in 2 months I have had to use this phone for a Bck up. I've noticed it has been happening wen it wants to really. Even wen I'm asleep. It looks like someone is typing. I didn't pay much attention until my click went from reg time to the 24 military time. Which I couldn't understand how it was getting in my settings on going to that screen and going to the bottom of it to click the 24 hr format. Well just now I was typing on fbm n went to type something I watched it try to type words and then I cleared outta of there n it started to go to my settings n that was it I powered dwn n Google I went. I actually uninstalled a couple of apps BC I was getting a weird ad lock screen so I had to do 2 lock screens I fixed that but not this problem also dnt think sprint/boost is just going to hand me on replacement they didn't let me with my s6 or now 2 times s7 plz if anyone finds a fix I wanna thank you ahead of time
    02-26-2017 11:49 PM
  7. Jimskie's Avatar
    I've been looking for the same symptoms in other posts. It seems like we have the same issue.

    Sadly for me, the phone was gifted to me by my boss who bought it during his overseas trip.

    Please let me know if you've managed to find a solution.

    02-28-2017 07:54 PM
  8. Jimskie's Avatar
    Hi Joe,

    I know this happened quite a while back for you, but I am experiencing exactly what you describe here right now. When I disable my "Data", or switch to "Airplane mode" I am rid of the problem.

    Did you ever find a solution for this?

    Appreciate you assistance.
    02-28-2017 08:04 PM
  9. JavasPhoneRepair's Avatar
    Hi Joe,

    I know this happened quite a while back for you, but I am experiencing exactly what you describe here right now. When I disable my "Data", or switch to "Airplane mode" I am rid of the problem.

    Did you ever find a solution for this?

    Appreciate you assistance.
    I repair cellphones and I have been getting this question a lot, it turns out that Samsung messed up on their galaxy S2 antenna design. They put the antenna right next to the IC chip that registers touches from the touch buttons. So whenever your phone transmits data on the 800mhz band, the IC chip will register it as a touch.
    The 800mhz band isn't normally used for data transmission, it is only used when your phone has trouble connecting to a cell tower, thus if you live in a signal dead zone, this will happen a lot.
    I heard a rummer that a class action was taken against Samsung for this design, but I am not sure whatever came of it, or if it ever happened.

    Just a quick note, a lot of what was mentioned above was voodoo, while it might have worked for one person, it most likely won't help you.

    So the fix,
    1. Move to an area with better reception, and hope it never rains...
    2. Try limiting how much data your phone transmits, uninstall some apps, etc.
    3. Replace your battery, the more power your phone has, the better chance it has of getting signal on another band.

    *From here down, only attempt if you know what you are doing!*
    4. replace your back housing, if your antennas are damaged, or resonate slightly off frequency, this could fix it, but I personally have never had any luck with this method.

    5. Replace the touch button assembly, sometimes you might get unlucky and just got a bad IC chip, while rare, it is possible.

    Or you can just take it to Sprint and get another phone... I personally love the galaxy S2 (yes this is 2017) I think it still is one of the best looking devices Samsung ever made, however I would swap it for a note 4 if one of them ever came into the shop.
    04-13-2017 08:41 AM
  10. dreamlogistics's Avatar
    Hey Everyone I didnt find a complete fix but i did fix it so that you can actually use your phone normally. If you are having the ghost touch issues with the recent app, home and back button, simply duct tape the recent app button. I used white out and I can finally use my phone but without the recent apps feature. hope it helps
    05-10-2017 07:01 AM
  11. Susil Parida's Avatar
    I have really searched and can't find any other posts here (or anywhere) describing this problem:

    Sometimes, randomly, my phone acts as if I were pressing the hard "settings" key and the settings menu pops up and goes away many times, very fast. And the screen is non-responsive for a few seconds after this occurs, though I expect that is because it is working through all those phantom presses.

    I also feel the vibration in the phone as if that key was being pressed many, many times all at once. This happens when the phone is not connected to the charger for sure, but i'm not sure if it happens when it is connected, I just haven't noticed.

    The only thing that helps, for awhile, is to power down and restart the phone. I have kind of a vague sense that this is related to sending and receiving text messages because it seems to happen most often when I am or have been recently composing a text, or just before a text comes in, but I'm not sure. I thought maybe it was a Handcent issue, but I uninstalled and am using GoSMS now, and the problem is the same.

    I am stock, and using Swype. I don't have a screen protector, but do have a hard rubber case on the phone but it happens with or without the case on.

    Does anyone have any ideas? Thanks in advance.

    I had very similar problem. My android was getting self clicked on right hand top corner (Three dot menu area). I have changed "Touch and hold delay" setting from short to long. This annoying issue stopped coming.
    07-29-2017 02:44 PM
61 123