1. maalvarez34's Avatar
    So I've been browsing different threads for about a week now and have yet to come across a solution to this issue. I've had my phone since January and it would connect flawlessly as a storage drive. The last time I connected it to my PC was maybe In February, so sometime between then and up until a week ago the usb mass storage functionality ceased to work.

    My epic 4g touch all of a sudden is not recognized by my laptop anymore as a storage drive and will not give me the capability to turn on mass storage. It does charge charge my phone when I plug it in, but it does not give me access to mass storage. In the past week my laptop recognized my phone as a storage drive only twice! I have no idea what I did, it seemed to work at random. Other than that It does not recognize it at all.

    Here is a list of everything I have tried.

    1. Installed Samsung Kies and the usb drivers.

    2. Reinstalled drivers and Samsung Kies

    3. Tried it with USB debugging on and off (The two times that my PC recognized my phone was once with USB Debugging on, and once with it off.) Other than that it does not hand shake with the phone on either setting.

    4. Connected to PC using USB utilities under wireless and network in the settings menu. (The one time that it did work with this method was the one time I connected with USB debugging off which I mention in Step 3. Other than that this method hasn't worked)

    5. Went to device manager to update drivers and none needed an update

    6. Performed a chkdsk on my PC.

    7. Restored phone to factory settings

    8. Checked for any firmware updates (none available)

    9. Tried the *#7284# fix (did not work)

    10. Cleaned usb port with toothbrush

    11. Tried 3 different USB cables as well as the three different USB ports on my laptop. I have even tried two other laptops and I am getting the same result.

    None of the above methods have worked, I really don't know what happened that it just stopped working for some reason...I take good care of my phone. When the phone is plugged in there is not even a message stating that "USB device is not recognized" and it does not even show up at all in device manager. I have noticed that most of the people that have this issue experience it with a PC running Windows 7 64Bit so I am beginning to wonder if there's a compatibility issue there. Yesterday I plugged my phone into a computer at the university I go to (which runs Windows XP) and it recognized my phone right away and even gave me the option to connect to USB storage.

    I have the white Samsung Galaxy S II Epic 4G touch and I have a Lenovo V570 laptop running Windows 7 Home Premium 64Bit.

    If anyone knows of a solution other than the ones listed above then I would be most appreciative.
    04-03-2012 04:54 PM
  2. mfsanso's Avatar
    I just experienced the same thing. I doubt this is a universal cause to the USB mounting issues and that this "solution" (if you'll let me call it that) will fix all instances of this problem, but I too scoured the forums and found nothing. I hope this helps.

    I'm a scientist and have access to an exploratory microscope and fine tweezers. I took a look inside my USB port after cleaning it "blind" with alcohol/Q-tip/Tweezers and found it to be pretty clean. There was a tiny piece of copper (likely a pin) that had been mashed down and looked obviously out of place. I saw the pin had a twin on the other end of the port so I tried to straighten the pin with the tweezers and ended up breaking it off. Keep in mind, this was all done under a microscope. I was petrified that I had complete broken the port but when I tried connecting it to my PC, it was instantly recognized like the good old days.

    Very strange. Maybe worth a try? Maybe I'm too late and you've replaced the phone? Let me know what comes of it.
    06-27-2012 08:48 AM
LINK TO POST COPIED TO CLIPBOARD