1. DirkBelig's Avatar
    As many here have mentioned and I've repeated complained about, location-based apps like Foursquare or Gas Buddy or weather widgets frequently seem to get stuck miles away from where I'm located. For some reason, my phone believes I'm at my work and refuses to offer Groupon Now or Foursquare check-ins for anything other than near there, even when the map in 4S places the blue dot accurately 15-20 miles away where Google Maps locates. This has nothing to do with the GPS issues some have had, because Maps spotted me correctly, though sometimes it would jump from wherever to my office before springing back when it locked after a few seconds. That it kept jumping to my work location despite clearing cache, un/reinstalling apps never made sense - it just seemed locked into there.

    Well, the other day I discovered this thread referenced in a Sprint Users forum post and loaded the linked file on 3/31/12. I've just returned from a three-day trip that was 450+ miles and every single time I used Foursquare or Gas Buddy or checked my weather widget, it was working properly. I've been going mad with being unable to check in, etc. and this fixed it. A quick skim of the thread showed some people having it broken by a Google Maps update, but I've been fine in the four days I've used it. (I waited to verify function over time and distance before posting.)

    I'm guessing this requires root and I made a copy of the file I replaced (it was called networklocation.apk on the rooted stock ODIN One-Touch EL29 I'm running) just to be safe. Downloaded the linked file and installed it to replace the existing Network Locations system app. Hope this helps my fellow sufferers out.
    eq0120, ronnie771 and jamesilence like this.
    04-03-2012 05:20 PM
  2. b0x3r's Avatar
    you have to be rooted in order to do this ?

    thanks in advance !
    04-03-2012 07:24 PM
  3. DirkBelig's Avatar
    I don't know for sure. I'm guessing you need to be, but perhaps not. The link doesn't say one way or the other.
    04-03-2012 10:11 PM
  4. Gator352's Avatar
    It says to either use root explorer or adb so you do have to be rooted.
    04-04-2012 08:46 PM
  5. scott_0's Avatar
    not rooting, no thanks. hopefully ICS fixes this annoying issue or Ill be getting the new evo
    tony404 likes this.
    04-05-2012 09:48 AM
  6. Treesham's Avatar
    definitely been a source of frustration for me for awhile now.

    i dumped the EVO 4G because of the memory leak problem (i believe the OP in this thread did the same thing, if memory serves), for this phone.

    and now this GPS thing is a nightmare, and i'm sick of it. i've had the phone probably just less than a month, and beceause of this one problem, i want to toss it into the ocean. ugh.
    04-05-2012 11:23 AM
  7. Kikoshi's Avatar
    I don't think this is the main problem the GPS has, what it has on mine is the damn lock in never happens hours after the first one.
    but when i reset the phone and it locks in, everything else works, foursquare, google maps ect... spots me correctly, then a few hours after, poof, nothing more works.
    04-05-2012 04:21 PM
  8. DirkBelig's Avatar
    Compared to some, I've been lucky with my GPS locking on within seconds, though sometimes dropping lock and requiring an A-GPS refresh.

    However, as I noted, the problem with apps must've been related to this location module because even though Foursquare's map showed my location correctly, it would only show check in picks from where it permanently thought it was, except for the increasingly rare instances when it'd get it right.
    04-05-2012 11:22 PM
  9. Treesham's Avatar
    I'm not convinced it has to do with Google maps and a recent update.

    Granted, i'm no expert, but i just uninstalled all the Google map updates, and am still having problems.

    This is a pain in the butt.
    04-06-2012 09:54 AM
  10. Gator352's Avatar
    I agree. I have Fancy widgets, Beautiful widgets, Accuweather premium, HD widgets, and another one I can't remember....all paid and none of them...NOT A ONE, work. All of them locate me miles away and never update to my correct location. Maybe this will change in ICS but not holding my breath. I love this phone...well at least for another year, so I want it to work like it should.
    04-06-2012 05:02 PM
  11. hawaiijedi's Avatar
    I keep getting that error as well Geolocation problem saying location doesnt exist. I am sick of these notifications and I did not want to root my phone. The only way to fix it is rooting? I never had these issues before and any guidance or help is appreciated.
    04-06-2012 08:24 PM
  12. tony404's Avatar
    Its the one thing I liked about my iphone over this phone. The gps was right on the money. I wish they would fix it.
    04-12-2012 10:47 AM
  13. Eric16's Avatar
    Im not understanding how some can be horrible and some peoples GPS are spot on. I NEVER turn my GPS on as pull down notification bar tap GPS tab I just go to location in settings and use wireless networks determined by wifi and or 3G. Now when I bring up just the maps app, when sitting here at home on wifi it comes to the very inch its dead on, but when I turn wifi off and turn 3G/mobile network its within a few blocks no more than 4 blocks so not a big deal. Idk if that much of a difference is what others are saying is horrible GPS or not but its pretty good for me.
    04-12-2012 07:33 PM
  14. tony404's Avatar
    When im driving and I turn on the gps and it never locks. Its annoying.

    Sent from my SPH-D710 using Tapatalk 2
    04-12-2012 08:32 PM
  15. gravyhead's Avatar
    I'm guessing it's an AGPS thing. A quick Airplane Mode toggle fixes it for a day or so.
    04-13-2012 03:01 PM
  16. Treesham's Avatar
    it is pecuilar to me that i can turn off the GPS, yet the GPS light on the pulldown stays illuminated. i wonder if this is tied into the problem.
    04-26-2012 01:22 PM
  17. sls639's Avatar
    I've only had my phone about a week and that was one of the first thing i noticed. My GPS showed me 3 blocks away. somewhere on this site i read a thread and downloaded "GPS status" free at the market. now its spot on, still slow getting a lock though. I don't use GPS for much more than maps so i don't know how it works with other widgets. when you open it its got a really cool compass and show actual longitude and latitude and a few other goodies, but just downloading it fixed my prob.
    04-28-2012 08:20 AM
  18. Treesham's Avatar
    Any of those GPS programs basically show my phone not finding any satellites. This is obviously a problem.
    04-28-2012 11:22 AM
  19. Uglyfido's Avatar
    I think I might be the only E4GT owner with zero GPS issues on fully stock non-rooted phone. Mine has worked flawlessly for me every time I have needed. Quick to lock on and accurate as hell. I really can't complain.
    04-28-2012 01:21 PM
  20. steddora's Avatar
    Mine has been golden so far too! Though I'm running FD26 now. Doesn't seem to ever have a problem unless I'm at work. Working in a mill environment, not many cell services work. Lol
    05-01-2012 09:50 PM
  21. nothappywithsteve's Avatar
    I do not think the E4GT GPS issue is OS related as mine worked great under GB, but now that I have rooted and installed ICS (4.0.3), it will not lock or track.
    05-20-2012 02:35 AM

Tags for this Thread