1. sadpanda's Avatar
    I have a stock Galaxy s2. When I open the Spring Zone app, and go to My Device, it says there was a PRL and Profile Update. So I clicked PRL Update, and that went fine. Then I clicked Profile Update, and it takes forever on the 'the network is preparing your service' message, and I eventually get

    "The profile update could not be completed. Please try again later. If the problem persists, you may need to contact customer Service. Error: Unknown error"

    I guess I should just 'contact customer service, but I wanted to see if anyone out there has had this problem before and maybe I am just missing something.

    When I clicked the update button, the circle next to 'data' under 'my connections' goes from green to red - maybe this is the problem, but I don't know how I would do anything since I can't do anything while the profile is attempting to update, and if I'm on 4g or WiFi the same thing happens.

    04-13-2012 01:52 PM
  2. DirkBelig's Avatar
    Is this at any location or just one spot (i.e. home or work)? If it's not updating when you move from cell to cell, then I'd call CS.
    04-13-2012 07:45 PM
  3. DEF3NDER's Avatar
    You can also go into settings, about phone, updates, and profile update to do the same thing. I went to update my profile today and got the same error you did. I just tried it again a few minutes later and it worked fine. I'd just make sure you have a good signal and keep trying it periodically. If it never gets working I'd take it to a sprint store.
    04-14-2012 07:11 PM
  4. KD8MLY's Avatar
    Also, I've encountered that I cannot perform a Profile Update while in roaming, it will give me the "Unknown Error" message. I am an outside technician and primarily work in a non-Sprint area, so I just wait to come home where I'm no longer in roaming, then I can update my profile and PRL version.

    However, I find it kind of irritating how Sprint Zone will always tell you an update (PRL for example) is available, but once I update, I go back into status and the same version is there. So... either there is an update that is trying to be applied and never does, or Sprint will just always give you the option to update regardless of if there's an update to begin with.
    04-15-2012 10:06 PM