1. epicness's Avatar
    I ran into this issue at the hotel I'm staying at...connecting to their wi-fi with my epic 4g touch or my girlfriend's incredible...it connects but the Internet will not work...using her kindle fire, it pops up a screen when you connect making you agree to their terms and conditions...then works. How do I get our android phones to do that? I tried using WIFIbrowserlogin, but it still won't detect it...any ideas? Thanks in advance!
    05-13-2012 03:42 PM
  2. Uglyfido's Avatar
    I can't say for sure, but my college has a similar system I think. All I have to do is open the browser and then go to any webpage. This brings me to my schools network logon page. Then, once I log in, it brings me to the page I was trying to go to. It might work for you as well. Also, don't forget to make sure that your wireless is connected to the proper network for the hotel. Hope that helps you out somehow.
    05-13-2012 04:18 PM
  3. steddora's Avatar
    Most of those places have a website on the router which will provide access once you agree to the terms of service. This is simply because they want to protect themselves from such illegal activities as torrent downloading/uploading and certain types of "illegal" activity. Once you connect you should simply be able to open a browser and be auto-directed to the terms of service page. Once you accept the terms you should be allowed to us the internet as normal. In most cases however, once you disconnect from the service you may have to repeat the process.

    Hope this helps!
    05-13-2012 04:30 PM
  4. epicness's Avatar
    Yea I'd figure that would be how it'd work, but it doesn't...it just tells me there's a problem with my internet connection...but on the kindle it auto-directs you to their page...I guess its not a big deal but I'd love to figure it out...thanks for the help anyhow guys!
    05-13-2012 04:56 PM
  5. Uglyfido's Avatar
    So you connect your phone to the network, but it doesn't guide you to the login page after that when you try to browse? I would try to clear the internet cache, and then re-boot the device, reconnect to the network and then try again. If that doesn't work, the I would try to talk to someone at the desk and see if they have had other people who have experienced this as well. At least that way you know if you are the only one having a problem or not.
    05-13-2012 05:06 PM
  6. JayWill's Avatar
    A notification should pop up. If you open your notification window and click the item it should open your browser and take you to the term of service page. That's how it works at Nordstrom anyways, which my wife is always dragging me to.

    Sent from my SPH-D710 using Tapatalk 2
    05-13-2012 10:50 PM
  7. zivia3's Avatar
    The only luck I've had with this is to tell your phone to connect to the hotel's wifi. Let it do it's thing then immediately after it says a login is needed, open up a browser. Hit refresh if you don't get the hotel's login page right away. This usually forces the browser to connect to the hotel's page and I'm able to log in. It's a bich, but it usually works. If it doesn't, I think it's b/c the hotel's wifi is just that terribly slow.
    08-05-2013 01:28 AM
LINK TO POST COPIED TO CLIPBOARD