1. right to carry's Avatar
    My Wi-Fi connects flawlessly at home, at a friends house, and on one open network at work. All other wifi sources connect and show a strong signal with the icon and with wifi analyzer but in reality have no connection at all. I cannot do anything.

    Update: 7/3 Called Sprint and talked to Samsung tech support, both clueless. Told me to hard reset my phone so I did. Same problem. Connects to same three networks as before and forsakes all others. WTF? I cannot believe NO one else has this problem.
    06-28-2012 01:03 PM
  2. kgzero's Avatar
    You're luck it blazes at home. The wi-fi antenna on this thing sucks. I stand next to the router and I'm already missing a bar? WTF? walk 50 feet away and I'm down to one bar.
    06-28-2012 01:39 PM
  3. right to carry's Avatar
    Maybe it just sucks air on WEP. How pathetic.
    06-28-2012 01:41 PM
  4. JayWill's Avatar
    I highly doubt it's the hardware guys, but rather the software driving it.

    Sent from my SPH-D710 using Tapatalk 2
    06-28-2012 01:54 PM
  5. Dark_Knight2's Avatar
    They improved WiFi signal in the ICS Kernels. Im running my modified FE22 kernel and I dont have WiFi issues. I did have that issue on EL26 & 29.

    Sent From A Rotary Phone
    06-28-2012 03:13 PM
  6. Almeuit's Avatar
    I'm also on a rooted ICS ROM and it seems fine. If I'm near the router full. Across the house it says 2 but I can still do everything just fine.

    Sent from my SPH-D710 using Android Central Forums
    06-29-2012 06:45 PM
  7. duddy23b's Avatar
    Mine is just the opposite, my wi-fi connects at home easily and at work, McDonald's anywhere there is free wi-fi my complaint is that there seems to be always a program needing updating
    07-02-2012 12:18 AM