1. LS14EVR's Avatar
    So is this just a bluetooth issue, or a SYNC update issue? I can't get my GSII to pair via bluetooth to my Ford SYNC system after this stupid ICS update. How come all my friends at work are getting ICS on all there different phones, with different carriers and they don't have a single glitch. This phone has turned to junk even after the factory reset and all the other screwing around I've done with it over the past 3 days. JUNK!
    07-19-2012 05:06 PM
  2. atl10pnr's Avatar
    This is what I had to do. Delete all phones in sync. Do a battery pull while the phone was still on while on the bluetooth screen. Then after a few tries it was able to pair. After that press the gear icon and choose either phone or media. For some reason it doesn't like both so it's either or. YMMV
    07-19-2012 05:19 PM
  3. LS14EVR's Avatar
    How do you delete all phones in sync? It paired once for like a second, then no go. So might just be an issue of trying to pair same phone again eh? Thanks for the tips. I'll give it a shot.
    07-19-2012 05:31 PM
  4. LS14EVR's Avatar
    So last night I got it to finally pair with SYNC and download my contacts etc. Worked great. This morning I get in the car to come to work, look and no pairing. WTF! I want to chuck this phone. I'd go to Sprint store but I know that's not going to help. I'd call Sprint but that probably won't help either. I still may call and vent though.
    This is 100% all Sprints fault for a crappy roll out of this update.
    07-20-2012 06:07 AM
  5. Murphy5111's Avatar
    Same problem here. If I can get my phone to pair with something it works but next time it doesn't. Paired items used to stay available and now the don't. Plus you can't delete something and start over if it does happen to recognize it but won't pair. I can't pair with my Chevy Malibu - it keeps telling me I have the wrong pin even though I've tried several (it gives you a new pin each time). Then I tried to pair to my headset that paired fine and never asked me for a pin and it told me I had the wrong pin for that. It never asked me for a pin, plus the pin like most is 0000. And I think bluetooth is one thing that's messing my battery. I used to lose about 1% an hour overnight. Last night I was fully charged and this morning half of my battery was dead. I even did a factory reset without data and reinstalled all my apps. I know other apps are having issues too and may be contributing to the battery. Ugh.

    Sent from my SPH-D710 using Android Central Forums
    07-20-2012 06:16 AM
  6. LS14EVR's Avatar
    I agree Murphy!
    07-20-2012 06:40 AM
  7. dr_elusive's Avatar
    I too Am having a problem pairing with Sync on ICS. I LOVE Sync and i use it frequently to stream music so i am very disappointed it is now broken. My Sync is up to date according to ford and it worked fine before.

    It will Pair with my Aftermarket Sony BT deck in my other car, but it disconnects randomly and does not work as well as it did before. Has anyone found any tips to getting sync to pair?
    07-25-2012 02:26 PM
  8. LS14EVR's Avatar
    Are you having other issues witht he phone as well? I'm chalking it up to my phone being basically a brick right now. Waiting for my replacement.
    07-25-2012 02:29 PM
  9. dr_elusive's Avatar
    aside from the BT problems it has been ok. The Battery life is not quite as good as it was before but not a huge difference. All the vital functions work, and i do like some of the new features but if the bluetooth wont pair I may have to downgrade back to GB as that is something I use daily.

    Dr.
    07-25-2012 02:42 PM
  10. JayWill's Avatar
    I was quite sure we would see reports of Bluetooth issues after the ICS update. I had bluetooth function issues in both my aftermarket Sony car stereo and my Infiniti factory audio system, mainly involving bluetooth media audio. I also found that if you disable media audio in the pairing settings, it would ultimately lead to auto-repairing issues for the phone side. This was on every ICS leaked build I flashed, up to and including the final release version. I posted about it all over the place but a fix never came to light.

    How did I fix the issue you might ask? I flashed Cyanogenmod 9. The Cyanogenmod team and the developers who ported it to our phone and created a kernel for it succeeded where Samsung failed ... regarding Bluetooth at the minimum. Samsung builds great hardware, but software is not their strong suit. Hopefully that will change some day.

    The best I can suggest is to report your issues to Sprint. Once enough calls come in regrading Bluetooth issues it may get on a fix list and sent over to Samsung. Until then, you may just have to deal with it, or consider doing as I have. Flash an AOSP ROM like CM9 and never look back.
    Murphy5111 likes this.
    07-25-2012 02:55 PM
  11. Murphy5111's Avatar
    I was quite sure we would see reports of Bluetooth issues after the ICS update. I had bluetooth function issues in both my aftermarket Sony car stereo and my Infiniti factory audio system, mainly involving bluetooth media audio. I also found that if you disable media audio in the pairing settings, it would ultimately lead to auto-repairing issues for the phone side. This was on every ICS leaked build I flashed, up to and including the final release version. I posted about it all over the place but a fix never came to light.

    How did I fix the issue you might ask? I flashed Cyanogenmod 9. The Cyanogenmod team and the developers who ported it to our phone and created a kernel for it succeeded where Samsung failed ... regarding Bluetooth at the minimum. Samsung builds great hardware, but software is not their strong suit. Hopefully that will change some day.

    The best I can suggest is to report your issues to Sprint. Once enough calls come in regrading Bluetooth issues it may get on a fix list and sent over to Samsung. Until then, you may just have to deal with it, or consider doing as I have. Flash an AOSP ROM like CM9 and never look back.
    It's just crazy that with all the time it took especially since there was no new build for awhile that these problems weren't fixed. Oh well. Thanks for trying

    Sent from my SPH-D710 using Android Central Forums
    07-25-2012 07:56 PM
  12. dr_elusive's Avatar
    I will try to disable media streaming if i can ever get to to pair enough to get the option.. I am not against flashing a custom rom. I come from the palm pre and i ran all kinds of custom kernels and software on that, i just have no experience doing it with android, and the bricking bug i keep hearing about has me a little shy to to do it on my Samsung. But if the builds are stable enough i would consider it. I will do some research.
    07-25-2012 10:40 PM
  13. atl10pnr's Avatar
    What I posted has worked for me. It didn't work for others. So it may or may not work for you.
    07-25-2012 10:46 PM
  14. LS14EVR's Avatar
    I tried again yesterday for the heck of it. and now it decides to work. SO far. It reconnected this morning by itself and I made a phone call. Nothing was updated. It did take me a few times to connect and pair again, but it worked. Still taking a new phone though.
    07-26-2012 07:32 AM
  15. cyberdman's Avatar
    I got my phone and my wifes phone connected to SYNC in each of our cars. I noticed that I had to delete everything in SYNC and then re-do each phone. When I did that though I had to try several times, because when SYNC gives you the pin number to enter into your phone, you have like maybe only a 3 second window to enter all 6 numbers in your phone. So just keep hitting SYNC on your phone after the phone finds it as many times as it takes you to click in the number field and enter all 6 numbers in like 3 seconds time. It does work as long as you are fast enough.
    07-26-2012 10:45 AM
  16. LS14EVR's Avatar
    That's the glich is that 3 second window. It's not supposed to be like that. In fact, when it worked on mine I took my time entering it and it stayed up. I took took a previous posters advice and deleted all devices, but I had done that before, and it connected, but then never connected again. This time is appears to be working. Now I need to see if I can get this stupid phone to stream pandora bluetooth through SYNC. That might just be the straw that broke the camels back. LOL
    07-26-2012 11:26 AM
  17. cyberdman's Avatar
    Yeah I know I hear ya. You definitely need more than 3 seconds, but somehow I managed to get it to work trying like a dozen times in a row. More annoying now is everytime it connects, it asks for permission to access the phonebook, even though the first time I clicked yes and don't remind me.
    07-26-2012 12:06 PM
  18. LS14EVR's Avatar
    Yeah, these phones are still glitchy. Can't wait for a new one or refurb. I don't care at this point what I get as long as it works.
    07-26-2012 05:30 PM
LINK TO POST COPIED TO CLIPBOARD