1. eptiger's Avatar
    Got the ICS update today and I backed up before I did so but I'm concerned that my apps backup may be incomplete so I was trying to do it again and copy the files over but now I can't use the device for USB mass storage. I can get around this using my SD Card, but I'd still like to be able to access my phone via USB.

    I downloaded the drivers from Samsung and installed them and restarted, but I get this error when I plug in the device:

    "Windows cannot identify the device plugged into the SAMSUNG Mobile USB Composite Device .

    For assistance, contact the hardware manufacturer."

    Anyway been able to resolve this problem? I've tried uninstalling then re-installing the driver with no luck.

    08-08-2012 11:43 PM
  2. eptiger's Avatar
    Wow, I'm the only person to run into this issue? That's not good

    08-09-2012 08:55 AM
  3. TWC_SouthPhilly's Avatar
    Wow, I'm the only person to run into this issue? That's not good

    No your not the only person running into this problem.... Just need to search a bit better.

    As of the ICS update Samsung has moved to MTP file system and has stopped supporting USB file system.

    Sent From My GalaxyClass StarShip 10.1/4.1.1(jb)
    08-09-2012 09:43 AM
  4. TWC_SouthPhilly's Avatar
    JayWill posted this about it back on 7/17....

    Samsung removed the USB mass storage option in the ICS update, instead moving entirely to MTP (Media Transfer Protocol) for file transfers. Checking USB debugging will not change this unfortunately. There were some ICS builds during developement where there was an option to enable USB Mass Storage, then plug your phone in which would list internal and external storage as physical drives. However, this was removed at some point.

    In order to have USB mass storage on a Touchwiz based ICS ROM for this phone, you would need to run a custom ROM that includes the functionality. For example, I currently have this ROM [ROM][TN] MIJJz ICS {GOODNESS 7/9}{MINI 6/30}{LTD 6/25}{NO-NAME}{SLIM} - xda-developers on my phone, and USB Mass Storage is the default. I know not everyone wants a custom ROM on their phone though.

    I also know sfhub had created a simple flashable file that would toggle on USB Mass Storage on the stock Samsung Touchwiz ICS ROM, but it's been awhile since I saw it and I don't know if it still works.

    It is possible to get back to Gingerbread, but it requires you to hook your phone up to a PC and manually flash firmware to it via Odin. There seems to be a good number of people that are interested in going back to Gingerbread, so I may post up a guide on how to do it.

    Sent From My GalaxyClass StarShip 10.1/4.1.1(jb)
    08-09-2012 09:45 AM
  5. eptiger's Avatar
    No I searched just fine and discovered that they switched to MTP, I just didn't get that MTP meant only for syncing music. I thought it was just a protocol for transferring files via USB - I thought I had old school mp3 players back in the day that used MTP and I was able to interact with them via Windows Explorer - my memory kind of sucks though.

    Alright, copying to the SD card it is!


    08-10-2012 02:55 AM
  6. DoubleYoupie's Avatar
    Hi Elton,

    I solved the same problem by going to developer options in the settings and set the option USB Debugging. After this the error is gone and you can connect the tablet using the USB.

    I hope this will also solve your problem.

    Greetings form the Netherlands.
    09-25-2012 01:46 PM
  7. Eulipian's Avatar
    I had the same issue. USB Debugging was checked. Unchecked and rechecked, plugged in and Windows Vista 64 likes my Galaxy III once more.
    10-04-2012 07:10 PM
  8. timmus's Avatar
    Have finally got Kies to work with wireless connection.

    Preferences/device shows the device correctly identified as GT-I9300 but this is followed by (00000000000) - 11 zeros - which looks as if it should display the telephone number. The telephone makes and receives calls and displays its number to caller ID but I wonder if this is the missing ID and if so, how to restore it.

    Does anyone know?
    10-07-2012 07:17 PM
  9. Elborath's Avatar
    Got a new Galaxy 3 S LTE last week--and--no connection to PC--including the ID error. Downloaded and installed Kies from the Samsung Website. No joy. Not even the connection trouble shooter worked. Tried again today--instantly got invited to update Kies. Did so, restarted and ran Kies troubleshooter--which found errors and offered to fix! Accepted. Drivers reinstalled themselves AND connection established! Full access! Yay!! (This is via USB--now to try Wi-fi...)
    10-17-2012 08:27 AM
  10. John Mandel's Avatar
    no, me too....same , WTH???

    12-02-2012 02:26 PM
  11. MobileMadness002's Avatar
    The overall issue is that Windows updated the drivers automatically. The threads state that you need to cancel the update process when you are prompted then make sure that Windows does not attempt to update those drivers again.
    12-02-2012 04:29 PM
  12. Mike Ingram1's Avatar
    This was driving me crazy. I tried lots of ways to solve it. I finally stopped using the USB ports built into my system and use the USB card I installed. Now my system sees my Galaxy Tab. I don't know if this will work for everyone, but it worked for me.
    01-04-2013 02:04 PM
  13. garwynn's Avatar
    For anyone using FL04 and higher, a USB driver update was required. You can get the 12/16 version from Samsung's website. (Also asking rwilco12 to update his copy on the Repository.)
    01-07-2013 09:23 AM