1. Aaronscore's Avatar
    Hello everyone,

    I recently got the Epic 4G touch Gs2. After upgrading to ICS, I found that my 4g data didn't work at all. I've been using the 3G to access without a problem, but I realized that I can't send photos or receive them while on the 3G.

    Mobile data is on, of course, not using Wi-fi, and I also did a factory reset that didn't do anything.

    Do i need to return my phone?
    09-30-2012 04:04 PM
  2. Uglyfido's Avatar
    Sounds like you might need to get a hold of Sprint. 3G should send and receive pics just fine.
    09-30-2012 04:44 PM
  3. ready2rise's Avatar
    My post is not helpful to your situation sorry, but even after this has been out for some time now, this so called update is still giving people problems. This shizz is just unacceptable. I would really like something new on my phone, but it seems so risky to try anything without it resulting in disappointment. And that I am not willing to accept. Is there a bulletproof way of getting this update to work?
    09-30-2012 09:03 PM
  4. Uglyfido's Avatar
    My post is not helpful to your situation sorry, but even after this has been out for some time now, this so called update is still giving people problems. This shizz is just unacceptable. I would really like something new on my phone, but it seems so risky to try anything without it resulting in disappointment. And that I am not willing to accept. Is there a bulletproof way of getting this update to work?
    No bullet proof way, but it helps to perform a factory reset after the upgrde, and to also clear the cache manually after the update.
    10-01-2012 10:20 PM

Similar Threads

  1. WiFi Tether not working after ICS upgrade
    By reyxlp in forum Droid RAZR
    Replies: 17
    Last Post: 06-25-2013, 01:11 AM
  2. Does Foxfi still work after ICS upgrade?
    By freeky1 in forum Droid Bionic
    Replies: 9
    Last Post: 08-08-2012, 12:07 PM
  3. usb drivers not working after ICS upgrade
    By donavan in forum AT&T LG Phoenix/Thrive
    Replies: 3
    Last Post: 07-13-2012, 04:42 PM
  4. AFTER ICS upgrade could not load apps
    By snakeman4066 in forum AT&T Samsung Infuse
    Replies: 8
    Last Post: 02-18-2012, 04:23 PM
  5. 4G not working after Froyo Root
    By freedumb87 in forum Epic 4G Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 02-16-2011, 12:52 AM
LINK TO POST COPIED TO CLIPBOARD