1. Kevin8520's Avatar
    Hello all,

    Long time listener, first time caller. I have an Epic 4G Touch and about 3 days ago my power button stopped working. I can not lock the screen or turn off the phone. I also can not end a phone call with the power key (when that option is enabled in Accessibility). One day the phone randomly rebooted and after that the power button has not worked.

    Is there any way to test the function of the power button hardware? I want to make sure it is a hardware issue and not a software issue, if possible.

    I am running stock Gingerbread rooted. No new apps have been installed in a week and no updates have come in.

    Thank you!
    10-13-2012 08:30 PM
  2. patrao_n's Avatar
    Not sure about gb. But on ics there is a developers options section. It has a hardware test function you can use. You might try posting to xda-developers.com under the subsection for this phone. Ill try leaking some more though.

    sent from my BAD A$$ Epic touch
    10-13-2012 10:31 PM
  3. captfbgnet's Avatar
    Just a thought: Have you tried a 'Batt pull' while the phone was on? Sometimes this can help reset phone functions..
    10-14-2012 07:40 AM
  4. jenluvs2sing's Avatar
    My Nexus S did that, and it was a replacement phone I'd had for not even a week. After the next replacement phone after that stopped working my tech at Sprint ordered me the GS2. Still some moving in pains but I'm getting used to it. Have you taken it to the store?
    10-14-2012 08:17 AM
  5. srkmagnus's Avatar
    If you have rebooted and did a factory reset and it still doesn't work it's definitely a hardware issue. take it to Sprint and have them take a look at it.
    10-14-2012 10:29 AM
  6. Kevin8520's Avatar
    I took it to the sprint store and they ordered me a replacement. They say it's a hardware issue but I am not convinced. I'm going to factory reset this one before I swap to the new one to see if really is the hardware.
    10-16-2012 11:13 PM
  7. egarciadesigns's Avatar
    I am also having an issue with the power button. I know its not the software issue because i had the issue on both GB and ICS. What happened with mine is that the button with get stuck internally, sometimes it worked and sometimes it didn't. In order to turn it i would have to pull the battery. It would also reboot occasionally because of the button being stuck. Right now its stuck, so in order to use it i have to unplug the charger for the screen to wake up. I took it in and they couldn't fix it so i'm picking up my replacement tomorrow.
    Surj138 likes this.
    10-17-2012 06:15 PM
  8. jlmalone's Avatar
    I too had this problem...i put up with it for a week...tried wiping the partition, factory resets...nothing worked...went to the Sprint store and finally 5 days later...got a replacement phone. Also upgraded to fl127 on replacement phone and UT is working fine...

    Sent from my SPH-D710 using Android Central Forums
    10-17-2012 08:29 PM
  9. egarciadesigns's Avatar
    I'm picking up my replacement today, getting the white one since the black one has a 10+ day waiting period. Well last night i backed up my phone that is having problems using kies and did a complete factory reset and deleted all the data including pictures, videos, ect. and stuff on the internal memory. After i did that i haven't had the power issue anymore. I'm wondering if maybe there was some sort of bug on my phone, I always just did the regular reset where it didnt delete any of my pictures and videos. Either way i'm still turning it in for my replacement
    10-18-2012 12:39 PM
  10. patrao_n's Avatar
    You do realize all your pics can still be retrieved right? To prevent it may be a hassle. But usually when I turn in a phone I will wipe the device then fell the sd card with random files or movies. Then wipe then put it back on again. To actually sanitize your device I believe its required 5 times. Way more than most people will do. But one rims I had a refurb and deleted pics by accident. I tried to restore them and ended up with a hell of alot of the persons pics before me. So ya. I do it anytime I trade a device in with memory cards.

    sent from my BAD A$$ Epic touch
    10-19-2012 12:32 AM
  11. Jordan Brown1's Avatar
    Well here's what I did to fix the problem,
    1. I took the battery out at night and let it sit while i was sleeping
    2. When i woke up I tried to see if it was working ( It wasn't )
    3. I dropped my phone on the carpet <----- softly and still didn't work
    4. i went and tapped the side with the power button on my counter and STILL DIDN'T WORK
    5. I was fixing to go back to my old phone so i took out my SD card and BAM it worked! I don't know how or why but it worked

    i keep trying the button to see if it still works and does!

    Hope this helps!
    08-15-2013 05:51 AM

Similar Threads

  1. any way to keep some app out of recent apps?
    By cfmx123 in forum General Help and How To
    Replies: 0
    Last Post: 09-07-2012, 09:55 AM
  2. Any way to re-map "double tapping" of the home button?
    By Mikhailov in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 07-25-2012, 06:56 PM
  3. Replies: 3
    Last Post: 07-13-2011, 07:33 AM
  4. Replies: 3
    Last Post: 07-11-2010, 11:44 PM
  5. Is there any way to get rid of the alarm clock icon?
    By kalldrexx in forum Motorola Droid
    Replies: 2
    Last Post: 04-06-2010, 03:52 PM
LINK TO POST COPIED TO CLIPBOARD