1. Hvacmanjc's Avatar
    Hello everyone. I have been noticing lately that my phone seems to drain the battery a little faster than normal. Now, I noticed the battery level was down to like 10% so I decided to plug it in. Its been charging for like an hour or so and its down to like 6%. Obviously, its not charging. The red led light is lit up like its charging and when I go in to the battery status it says charging but its not. I pulled the battery to reset it to see what would happen and noticed the battery was cool/room temp. I placed the battery back in and let it boot up and plugged it back in. Its been roughly 30 minutes and still not charging, but slowly draining. The led is still lit up and the battery status says charging but its not. Has anyone experienced this before? Possible failed battery? Any help would be appreciated! Thanks in advance ****I also tried a different charger and had the same results**** Thanks again

    Sent from my A200 using Android Central Forums
    10-28-2012 09:43 PM
  2. patrao_n's Avatar
    If your phone is stuck take it to sprint. Its either a faulty usb or faulty battery

    sent from my BAD A$$ Epic touch
    10-28-2012 09:59 PM

Similar Threads

  1. Battery charging issue after 2.2...who to notify?
    By Chondog in forum Verizon Droid Incredible
    Replies: 4
    Last Post: 09-08-2010, 01:00 PM
  2. Serious charging issues!!!
    By captainsplat in forum Sprint Epic 4G
    Replies: 1
    Last Post: 09-01-2010, 08:34 PM
  3. Charging Issue
    By as4life in forum HTC EVO 4G
    Replies: 0
    Last Post: 06-05-2010, 11:37 PM
  4. Charging Issue
    By Fazulka in forum HTC Hero
    Replies: 2
    Last Post: 05-16-2010, 08:41 PM
  5. charging issue?
    By johnolesen in forum Motorola Droid
    Replies: 2
    Last Post: 05-15-2010, 10:15 AM