05-15-2014 06:16 PM
43 12
  1. rxvexe's Avatar
    I can't find any other place to post this, but since virgin is basically sprint, I'll post this here.

    I didn't root the phone or anything, I followed a guide using my phones model number SPH-D710 on virgin mobile in the United States. It's a S2 4G, doesn't say Epic or anything. So I installed clockwork, using Odin3 1.85

    So I installed many different roms just for my model, D710, and I always get a Status 7, which from what I understand, won't install the rom when it checks for the compabile device, even though it is listed in the code when it attempts to install any rom I use.I'll be glad if anyone could help, I don't have a backup, and I can't seem to find one that will work. The phone is basically bricked.

    11-21-2012 02:03 PM
  2. srkmagnus's Avatar
    Status 7 usually means an incompatible recovery. What recovery are you using?
    11-21-2012 03:11 PM
  3. scrubbybubbles's Avatar

    I just found out that Virgin Mobile has the Galaxy s2 too, I just switched from there to boost! I Haven't had even CLOSE to the issues with boost that I have had with V.M. Sorry this is slightly off topic, but, I wouldn't do anything extra to their phones! I hope you can get some help with this.
    11-21-2012 03:50 PM
  4. rxvexe's Avatar
    Recovery? I'm not sure what you mean? Use Odin,Clock, and some stock roms and modify roms, using Clock to install them, but constant status7 error. I was unable to unbrick (well get a working rom on it, using 'SPH-D710 FI27 (FI27 Modem/Kernel/ROM - Root/Stock)' but it was a sprint rom, and now I cant use my data, I can load up an email, but not even open them play store (with 3g and 4g on) Won't use 4G at all.

    If there is any more info you need, I'll try to provide it, I'm only semi-tech savvy. Virgin Mobile is just a mess, but then again it was just released, I wounder if someone could do a backup of their rom if you have an S2 with virgin. Thanks for your replies.
    11-21-2012 05:38 PM
  5. AlienTechnology's Avatar
    Does the device work with Wifi?
    I'm new to this too.
    But it sounds to me like you may have lost your ha or aaa keys.
    That's in NV memory, flashing rom shouldn't erase or change those settings
    but if it's not that, it has to be some configuration that got changed.
    You should connect the phone to Qpst using service programming and check your settings. Can also use DFS.
    You will need to read up, though, you need your msl code, or samsung password, you have to set your phone
    as a modem using the dial shortcut keys, this is done just like if you were dialing a phone number.
    Install drivers etc.
    check this thread for pointers:
    Epic 4G to Virgin Mobile(SMS/MMS/VOICE/3G)*WORKING!* UPDATED:4-23-2012 - xda-developers
    I see you posting all over the different forums looking for help, good luck.
    11-21-2012 08:19 PM
  6. rxvexe's Avatar
    Thanks a lot, I'll check that thread out.

    What basically happened, I assume I deleted the stock rom, and was unable to get any other one working on my device, I was using clockwork mod, trying to install roms(zipfile ones) and I would only get a Status 7. But thanks to 'SPH-D710 FI27 (FI27 Modem/Kernel/ROM - Root/Stock)' it was a topic I found, on another forum, it basically installed a rom from my pc, while the phone was in Download mode (Hold+Vol Down). It installed a Sprint rom and andriod was back up and running again on the phone. It would let me call and txt, but no data, but after a few hours of being connected to the service, 3g started working some. Still a bit slow, and 4g doesn't work.. yet.

    Basically I lost the andriod OS, but got it working. This is my first posts online, I guess some others have issues too. Thanks though for the link!
    11-22-2012 12:48 PM
  7. AlienTechnology's Avatar
    That's the same firmware I'm using
    You do realize you can't send/receive mms now with the sprint rom. Since you no longer are using a virgin rom which has a proprietary framework piece of code.
    Just a thought but I think you should find out what your average data speed is, because you might not be on 3g but the older EVDO Rev0.
    Use the speedtest app in google play.
    Here is a link that explains the speeds:
    Sprint 3G Network

    I was thinking you may have lost your aaa key, if you can't get actual 3g speeds but only 2g.
    Your ha key is universal to all virgin mobile phones: vmug33k which is for the slower speed EVDO Rev 0.

    About 4g not sure, might have lost your wimax settings for that as well, they are under data programming, ##data# dialing code, then click view, then click wimax
    then enter your msl #, (get msl by using app like connectbot and following directions others have posted.)
    I know your realm has to be correct for virgin mobile, whatever that is. and you of course need your 4g mac address which looks to be under "eap method type". there's probably other important stuff too?
    I do hope you have the phone working better now with higher speeds.
    11-23-2012 09:28 PM
  8. rxvexe's Avatar
    Yea, it seems like running a sprint rom messed up all of my settings, I was able to get my MSL and tried to fix what you said previous, seems like I am running on their 2g, and not real 3g. Spent a few hours searching for settings for realm (which sadly didn't work),wimax, and other stuff, but I can't seem to correct my issue. Will a virginmobile rom correct these issues? If it can, I should just wait for someone to post a VM rom, if all else fails, I might just have to 'lose' my phone, and shell out 100$ for a replacement phone, no way in hell VM will replace a rooted and custom rom based on their parent company.
    11-24-2012 02:01 AM
  9. AlienTechnology's Avatar
    Are you sure you don't have 3g? You have a good signal on your phone like -75db (under settings/aboutphone/status/signal.
    I guess you have 2 options.
    1. Brick the phone so you can't boot it, and play dumb, getting it replaced.
    2. Wait, for a VM rom, but will it bring back all your settings?
    I wish someone more knowledgeable could chime in on what exactly does "Hands Free activation" update, PRL,AAA,MSID,MDN,etc,
    In my opinion you spent a lot of dough of a phone that has no hardware problems and VM makes a lot of money anyway, so they owe you.
    If I was you I try to get a replacement.
    or option 3 buy the same exact phone, make a backup of the rom and return that one.
    Try not to lose too much sleep over it, I'm rooting for you. I'm just a little worried about the AAA key, if you decide to keep the phone.
    rxvexe likes this.
    11-24-2012 06:28 PM
  10. rxvexe's Avatar
    Signal is a bit off, I either get low to mid bars, from about 85-110db

    Speedtest settings are slow, max is around 500kb down, sometimes 200kb up but its all over the place sometimes near 20kbs down/up. Not sure if a VM rom would work, but it could, maybe, unsure whether what settings would be changed with a different rom, and which are not. As for now, I'll just wait a while, it's a semi-working phone, aside from 3/4g and maybe mms. I bought the phone online, before I saw it instores, and returning a phone online is a big hassle, wait times, possible problems, etc, it's the holidays. Possible, just a huge inconvenience for me.

    Not sure about option 3, it's possible depending according to store's policy on returns. Not sure about the AAA key, it just seems to be 1234, which is default? Hard to find info on all the settings, what they're for, how to set them up and etc. But thanks for your help, I'll try to keep an eye out on VM roms for now, might be hard to find.

    I find Epic 4g topics and whatnot, but I trying to find d710 with VM is impossible, most guides are for different phones or using another network.
    11-24-2012 11:57 PM
  11. AlienTechnology's Avatar
    I suppose you should go to a better signal location and check again.
    I just found some apps that can tell you if you're on EVDO Rev0 2g or EVDO RevA 3g. Since this phone doesn't tell you straight off.
    Try them if you like "2G,3G,4G Network Monitor L" or "Network info Widget" (this one you have to create a widget on your home screen for it to work, do this from the home screen,clicking menu,then clicking add, then clicking widget,then find the name of the app) on phone.

    My speed are always all over the place too, but on average I get 1000Kbps down and 600kbps up with a signal of -76db, I know it depends on the data traffic of the neighborhood too.
    I think technically the AAA key is suppose to be 10 characters long. But back when I was trying to find my AAA key on the epic I used catlog and logged the ##data# dial code and then searched for my AAA it showed it as 1234 also, so not sure on that one, but my phone did have the sprint rom not vm rom. That 1234 might be the sprint default or something.
    If you can get a VM rom on the phone again, it has a app, activate apk for the handsfree activation, it's automatic it updates the phone to the correct network settings, phone #,prl. possibly other things. The don't think it will work on a sprint rom, I tried it before, may be the one I used was not the correct one for the epic s2 though. Like this one:

    I agree about topics with this phone & VM is just about nonexistent.
    Good luck and if I find anything I'll let you know.
    rxvexe likes this.
    11-25-2012 09:29 AM
  12. bmillar43068's Avatar
    I have the exact same problem, accidently flashed the sprint rom as well. how long does it take for a stock rom for a new phone to be released. im tempted to take mine back as well but i could REALLY use that rom so i can use my 4g
    11-26-2012 08:12 PM
  13. rxvexe's Avatar
    Sadly we'll just have to wait and hope someone post the stock VM rom. I haven't been able to fix the issues yet. But you can't give up, it's only a software problem.
    11-26-2012 08:45 PM
  14. rxvexe's Avatar
    I've been messing around with the phone a bit more, I installed 'cm-9-20120628-EXPERIMENTAL-epic4gtouch-alpha6.zip' only other rom my phone accepted besides the sprint rom. Sadly, CM9 still thinks I'm on the sprint network, and it does display what network I'm using, which is EvDo-rev.A:8 I'm assuming that it's a 3g network, and I get low bars at my house, which is weird, before on VM i would have a good signal, might be the phone, or some settings issue still, i assume since I can not access 4g and on the map, I should be able to get it according to sprint. (But I'm using VM, but it should still be the same. I would say most of the time I have a crappy signal, where I used to get something decent. 3g may be working, but something about my signal strength isn't, and 4g won't work yet. Just trying to provide more information if anyone else can help.
    11-27-2012 05:46 PM
  15. AlienTechnology's Avatar
    If someone were to back up their personal rom, it could show up tomorrow. An official version of the installation Rom??
    I keep checking:
    Shipped ROMs
    Samsung Galaxy S II/SPH-D710/ROMs - XDA-Developers
    Samsungs Open Source Release Center website has the virgin mobile rom in source code, if you or someone could compile it I guess it would be usable??
    Samsung Open Source Release Center and search for SPH-D710

    Hey Rxvexe I figured I suggest you check your PRL file, make sure it is 61007, check on phone by going into settings/about phone/status/PRL version.
    Can get it here http://forums.androidcentral.com/vir...nt-towers.html

    IF that doesn't help you need to go over your settings for your phone again using QPST and DFS programs following a guide like
    Epic 4G to Virgin Mobile(SMS/MMS/VOICE/3G)*WORKING!* UPDATED:4-23-2012 - xda-developers sometimes the settings don't get saved correctly, you have to check them and try to correct them again.
    If that doesn't help I have nothing, sorry. I doubt installing a custom rom would help any, but some roms do help or worsen a signal from what I was reading something to do with the modem version that is used with the rom, not too sure.
    rxvexe likes this.
    11-27-2012 08:08 PM
  16. rxvexe's Avatar
    I tried using the PRL swap guide, spent a few hours on it.. but didn't get very far. New computers don't use com ports, and sadly my two computers are too new @.@ so I can't even use CDMA workshop (unless I showhow get the full version, which was unsuccessful as far as to a usable update version). That was a huge mess, trying to find out why I didn't have the ports tab in DM, etc, but at least I learned something. I did check out that open source release, and it seems like the last one for d710s was for VM, said VM in the file name. But I would have no clue how to use the source code. I might try to do the PRL later, if I can find an older computer to use. Currently running on 61009, close, but not correct with VM.

    I looked at that last guide many times, but was unsure if I wanted to mess with it, and I was gonna to do it now, BUT same issue previous, CDMA won't work, you need Ports in Device Manger, and now, everything goes by IPs rather than com, or something, I read about it, just not sure what it was, but basically newer tech= can't edit the com value for under 10, which is why I can't use CDMA.

    Such a mess, but thanks for trying to help me. I'll keep trying and see what happens, I have limited time to mess with my phone, and being only semi-tech savvy isn't too good.
    11-28-2012 12:39 AM
  17. bmillar43068's Avatar
    yea im gonna try this when i get off work today see if i can get something out of it, its gotta be the same process

    edit nm theres directions inside lol
    how nice of them

    . How to Build
    - get Toolchain
    download and install arm-eabi-4.4.3 toolchain for ARM EABI.
    Extract kernel source and move into the top directory.

    $ export CROSS_COMPILE=/opt/toolchains/arm-eabi-4.4.3/bin/arm-eabi-
    $ export ARCH=arm
    $ export USE_SEC_FIPS_MODE=true
    $ cd Kernel/
    $ make u1_na_spr_defconfig
    $ make

    2. Output files
    - Kernel : Kernel/arch/arm/boot/zImage
    - module : Kernel/drivers/*/*.ko

    3. How to make .tar binary for downloading into target.
    - change current directory to Kernel/arch/arm/boot
    - type following command
    $ tar cvf SPH-D710_Kernel_ICS.tar zImage
    rxvexe and AlienTechnology like this.
    11-28-2012 08:41 AM
  18. AlienTechnology's Avatar
    Cool bmillar43068 good going dude. I guess those commands are typed in the program "toolchain" on windows OS?
    The ehow link you posted, state you need Ubuntu OS.
    I'll try it when I get some free time.
    Rxvexe your original prl is probably correct, I think you may have the newest prl for vm being 61009.
    My original sprint prl on the epic s2 was 60690, either way I was reading it's all sprint/virgin mobile/boost mobile, so it is not that vital.
    I now currently use 61007. I bet others who buy the samsung galaxy s2 from vm have the same prl as you have currently.
    If you are still interested in messing with the phone settings in regards to ports on windows,
    I myself sometimes have trouble with windows 7 when it comes to ports, but try this
    1. Install samsung drivers on windows.
    2.make sure phone has usb debugging checked, it's under settings/developer options.
    3.on phone in dialer dial ##8778# Select All
    4.on phone in dialer dial *#7284# Select Modem for both UART and USB
    5.Connect phone with usb cable to computer, check under control panel/system/device manager (or some other crazy maze that windows 7 + makes you go through)
    6.Under Ports (Com & LPT) the phone should show up. Take note of the port #.
    7.Open QPST Configuration and select it there.
    8.Open QPST Service Programming follow the guide I mentioned earlier.
    Cross Fingers Before changing anything either copy it down by pen and paper,do a windows Print Screen save to JPG, or backup with QPST.
    rxvexe likes this.
    11-28-2012 06:39 PM
  19. cbarnhil's Avatar
    I've already rooted my VM SGS2. I have a nandroid backup you can have. It may be worth a shot. You need to have agat recovery installed. Thats the only way to flash rom. Don't use CWM on this phone. CWM works great on OV &Triumph but not so much this one. Heres the link that i used to Root: Rwilco12's Android Repository follow that guide step by step. If you have any questions just let me know.
    rxvexe, bmillar43068 and ksg97 like this.
    11-29-2012 05:41 PM
  20. bmillar43068's Avatar
    i could definitely use that back up anyway you could upload it to mediafire or something?
    11-29-2012 09:57 PM
  21. sirredbeard's Avatar
    Where do I get and how do I install agat recovery? Sorry, I couldn't find any information on my own that I was confident about.
    11-30-2012 12:08 AM
  22. cbarnhil's Avatar
    i could definitely use that back up anyway you could upload it to mediafire or something?
    I'm uploading to dropbox now. Its a massive file so its taking a minute. Do you have custom recovery flashed to your phone? If not you'll need to do that 1st. Click on the link that I posted yesterday. Follow it step by step. (Credit goes to Rwilco12 over @ XDA, he's got the tools and the know
    how) When you get to the part about flashing superuser just flash the nand.zip in its place.

    Please follow the directions on the repository completely!!! Just remember you are in control of turning your phone into a brick or not. Follow the guide and you'll be fine.

    1st: Go to Samsung.com and download the usb drivers from their site.

    2nd: Flash and install the recovery via "One Click" on a PC.

    3rd: Flash the Nandroid Back-up and you should be good. (it comes rooted btw)

    4th: Enjoy your now rooted and backed up SGS2
    bmillar43068 and imme2007 like this.
    11-30-2012 09:19 PM
  23. cbarnhil's Avatar
    Click on the link from my original post yesterday. You'll want to flash the recovery on the repository site. It's a "One Click" method that requires a pc. But just follow the rooting guide and it flashes the recovery. There's always a chance that you could make an expensive paperweight/Brick. So be careful. Just follow that guide (Credit goes to Rwilco12 over @ XDA) it worked for me.
    bmillar43068 likes this.
    11-30-2012 09:28 PM
  24. bmillar43068's Avatar
    But just follow the rooting guide and it flashes the recovery.

    i flashed the recovery and made a backup but it wont boot now and i have the yellow triangle

    so do i just put your nand.zip (when you get it uploaded) on the sd card and restore it using that or am i installing it like i do superuser?
    11-30-2012 11:26 PM
  25. imme2007's Avatar
    hey,i am in the same boat and i need the backup too,would like to say thanks to everyone here,i been following this thread for days and this is the only one that has been going anywhere,waiting for the upload
    12-01-2012 11:40 AM
43 12

Similar Threads

  1. Virgin Mobile's 4g
    By prime0025 in forum Virgin Mobile HTC EVO V 4G
    Replies: 41
    Last Post: 05-28-2013, 11:51 PM
  2. It's been fun but I am off to Virgin Mobile to SAVE $100 A MONTH
    By mknollman123 in forum Verizon Fascinate
    Replies: 3
    Last Post: 07-22-2011, 09:35 PM
  3. Replies: 1
    Last Post: 06-24-2011, 02:01 PM
  4. Motorola Announces Photon 4G on Sprint, Triumph on Virgin Mobile
    By Preach2k in forum General News & Discussion
    Replies: 0
    Last Post: 06-09-2011, 01:03 PM
  5. Atrix 4g on Virgin Mobile?
    By x2z in forum AT&T ATRIX
    Replies: 9
    Last Post: 03-01-2011, 04:51 PM