1. chewedpup's Avatar
    HELP! Suddenly, out of nowhere, today when I plugged my Sii into my laptop with the USB cable, instead of it showing up as an external drive (which I wanted, so I can move some pics over) - it shows up with the attached "HARDWARE ID MISSING - windows cannot identify the device plugged into the Samsung mobile USB composite device. NEVER happened before. I have looked on the internet and see some people suggest uninstalling KIES. On my samsung, there is no option to uninstall it, only to uninstall the updates (which I have done).
    I have tried selecting the USB debugging option in developer options - no help. I looked where people suggested under Settings - More - (then looking for USB options but my Sii doesn't have that option) - so that was pointless. I have rebooted phone AND laptop.... no good - I still keep getting that error - and as far as I know, nothing has changed on my phone.

    I just took TONS of photos in London and can't even put them onto my laptop now :-(((((

    Hardware version D710.10
    android version 4.0.4
    model number SPH-D710
    Attached Thumbnails Hardware ID missing - windows cannot identify the device plugged in ...-hardwareidmissing.jpg  
    Pravin Thakker likes this.
    01-22-2013 11:20 AM
  2. Tsukiyomi's Avatar
    I just got that for the first time last week after putting the latest JB (GA10) on my phone. As you've seen, what fixed it for me was doing a full uninstall of Kies ON YOUR PC using Control Panel's Add/Remove Programs if you're using Windows, then use CCleaner or similar to remove the Registry entries for it (via a cleanup), then Google Samsung Kies and get the latest version. Reinstall Kies and the Samsung drivers and you should be good to go.
    01-22-2013 02:33 PM
  3. chewedpup's Avatar
    Thanks for the response. On my actual laptop, Kies isn't installed - whenever I've used it, I just type in the ip address given to me by my phone, and that takes me to where I can (or could) transfer files - but it hasn't installed anything ON my laptop. I double checked and went to uninstall and there is no Kies anywhere on my computer, even in the registry (I checked it out too).
    So it doesn't seem to be anything to do with Kies, at least not on my laptop - so at least now I can eliminate that possibility. But thank you for suggesting that anyway, was good to check.
    01-22-2013 05:38 PM
  4. Tsukiyomi's Avatar
    Hmmm. Have you tried picking up the most recent drivers then uninstalling the ones on your computer and replacing them?
    01-22-2013 08:13 PM
  5. Uglyfido's Avatar
    You need to install Samsung Kies onto your laptop. What you are using is Kies Air. Once you actually download Kies from Samsung and install it on your laptop, your problem should likely be solved.
    01-22-2013 09:36 PM
  6. mile5's Avatar
    Look at the other thread of Hardware Id Missing error and particularly the comments by dsvendee as it worked for me with an S2 & Vista.
    01-23-2013 10:42 AM
  7. chewedpup's Avatar
    THANK YOU! THAT WORKED! I must admit to not knowing that there even was a KIES program to install on my laptop - I'd only ever used KIES Air, whereby you just run the app on the phone, it generates a URL which I type in on my browser on laptop and it would take me to my phone. Actually downloading and installing KIES to my laptop somehow fixed the drivers because then I just plugged in my Galaxy and it installed some other drivers, and worked PERFECTLY. Now it shows up as another drive and I can move stuff back and forth - so THANK YOU THANK YOU for this information and for resolving my problem.
    On a side note, while trying to resolve all this, someone recommended using WIFI FILE TRANSFER, an app for my phone - so I downloaded it, and it works very similarly to Kies Air - it generates a URL, you type in that URL on your laptop browser and it gives you immediate access to your phone. I will use that when I have good wifi - but if I'm somewhere where I don't have access to the internet, at least now I CAN hardwife my phone to my laptop with the USB cable and transfer files that way. THANK YOU!!!!!
    01-23-2013 10:52 AM
  8. lirwin's Avatar
    Sorry if this is a dumb question, but I cannot find "the other thread" that mile5 refers to "with the comments by dsvendee". Can you send me a link?

    I've been struggling with this same issue for a week or more and I am totally frustrated. Any help would be greatly appreciated!
    01-29-2013 03:19 PM
  9. DroidNooby's Avatar
    Been long enough that you've likely fixed it or bought another phone, but linking for the next guy (me at the moment as I'm struggling with this on my new S3 as a new Droid user).

    05-15-2013 04:15 PM
  10. Mattix724's Avatar
    Uninstall the drivers, Uninstall Kies also. Reinstall Kies and plug the phone in.

    Sent from my SPH-D710 using Tapatalk 4 Beta
    05-16-2013 02:31 AM

Similar Threads

  1. Galaxy Tab 2 10.1 Hardware id missing error code???
    By ateague88 in forum Samsung Galaxy Tab 2 10.1
    Replies: 4
    Last Post: 05-29-2013, 05:23 PM
  2. Hardware Id Missing Error
    By eptiger in forum Sprint Galaxy S II Epic 4G Touch
    Replies: 12
    Last Post: 01-07-2013, 10:23 AM
  3. Hardware ID Missing
    By VAVA Mk2 in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 3
    Last Post: 10-02-2012, 12:29 AM
  4. Replies: 2
    Last Post: 05-31-2012, 07:48 PM
  5. Record a screencast on the device (not in the emulator)
    By seanubis in forum General Help and How To
    Replies: 5
    Last Post: 12-26-2010, 04:18 AM