12-29-2013 05:43 PM
59 123
  1. joesake's Avatar
    It looks like still no firm resolution to this one? I'm having the same issue. In addition, I get 'USB Device Not Recognized' when I connect to a computer. I have uninstalled and reinstalled the Samsung drivers.
    06-11-2013 05:46 PM
  2. kris2340k's Avatar
    Urm I think what you guys are referring to as use storage is sd ext maybe, it's a partition inside the internal memory, try downloading Ubuntu live cd and booting it and connecting your phone in there,,

    on another note today my SwiftKey decided to stop accessing the sd card, everything else was fine, just SwiftKey thought that one wasn't in. This happened after I turned my computer off and forgot to turn use storage off on the phone.

    FIX : I solved the problem by removing the back cover, and with my left hand holding the phone upside down used my left thumb to hold the battery in, with my right hand I removed the sd. The phone said sd removed, good. I put the sd back in and the phone began to lag. But it detected the sd, it said scanning for errors. After I went into settings then storage, unmounted and mounted the sd and from that point SwiftKey works fine, in fact I am typing from it now
    07-15-2013 06:53 PM
  3. kris2340k's Avatar
    Edit: forgot to add that android uses the Linux kernel, and usb ext uses a Linux file system and can therefore only be read within Linux, this is a very long step and it's probably wrong as I doubt sd ext would be mixed up with usb storage, have you guys tried clearing your dalvik cache, phone cache and clearing your data
    07-15-2013 06:57 PM
  4. Timothy Takemoto's Avatar
    I am using a different device (NEC Medias Tab N08-D) but I have a similar problem - Android thinks I am
    connected via USB, so I can't use my camera.

    Update: I turned on and off my device while connected to my PC and I can now reconnect USB storage,
    and since I can reconnect, I can disconnect USB storage, unplug my USB cord and yes, use my camera.
    But android needs to offer better control of USB connections.

    I think that it is due to my attempt to view the internal memory in the device by turning on the PC link,
    before I had installed the required drivers.

    [By the way, it is not immediately clear how to get to the screen which allows one to select
    between PC link to internal memory, and USB mass storage to SD card. Solution- Click on
    storage then the three dots that appear top right, and then on the one item menu
    "USB Computer connection"]

    I have subsequently installed the drivers first on another Windows machine but still can not see
    the device internal memory from my computer.

    Even so, Android thinks that there is a USB connection.

    When I change the storage settings, to view the SD card as a "USB Mass Storage Device", the
    "USB Connected" green-android screen is displayed but when I click on "Turn on USB storage"
    I get the swirling circle (android equivalent of an egg timer) and never get to the orange android
    screen, or the option to disconnect, irrespective of the SD card I use.

    After a while the swirl circle disappears, and the "Turn on USB storage" button reappears.

    So my device things that there is a USB connection, probably to the internal memory, and I
    can't break the connectin.

    And as Treesham the OP writes, this means that my camera says disconnect USB, so
    I can not use my device's camera!

    There is a work-around, which is to install a third-party camera, such as Zoom camera.

    But I would like some way of killing rogue USB connections, since I will never be able to
    access my SD card via USB.

    I have tried installing some USB software such as
    USB Host controller (which did not seem to be compatible with my device)
    USB Device Info
    which told me that no USB device is connected (when connected to my PC)

    I would like an app called "USB connection killer" or "Unmount USB connection" or some such.

    Related problems elsewhere....

    Here a factory reset is advised.
    Pain in the **** reinstalling all my apps, but I guess it might work.

    I have Winamp installed which should press the "turn on USB storage" button for me (it did that till this problem arouse)

    I have tried turning on "USB debugging" in developer options, which resulted in an "ABD Interface" being installed on my computer, but still I can't see my device from my Windows computer (clicking on my computer) and I still can't connect to my SD card, and I still can't use the camera since it still thinks I am connected by USB (even when I disconnect).
    07-30-2013 11:14 PM
  5. Konica Tester's Avatar
    I have AT&T Galaxy S2 Skyrocket with Jelly Bean 4.1.2. It says my USB Mass Storage is on even though I am not connected to my pc. I had tried the USB utility and the storage options and uninstalling apps, but none of them work.

    I ended up installing TWRP ([HOWTO] THE ULTIMATE NEWB GUIDE > | INSTALL TWRP/CWM | ROOT | UNROOT |the SKYROCKET - xda-developers) and then did a wipe of internal SD card.(in TWRP, select Wipe->Advance Wipe->check only Internal SD card)
    All my pictures, videos, and memos are gone. But my Contacts, APPs and my email account settings are all there. And I can finally use my Gallery and Camera, and any apps which require internal SD card.

    I wish someone can come up with a better solution.
    08-20-2013 07:12 PM
  6. Aditya Gulia's Avatar
    Hey guys,
    I have an HTC ONE X, and just encountered a similar issue. Somehow didn't "safely remove" the sd card (probably), and was stuck with Swiftkey and Camera (Stock sense based) refusing to work coz I "didn't have an SD card". I was going nuts over this and this is surprisingly not a widely known thing (probably a new bug?).

    Anyhow, I did manage to get everything to work, without having to format anything. As I understand, to the phone the SD card was still Mounted elsewhere, and not available as its internal storage. So I needed something to Unmount the card from this phantom place, and Mount it again on the phone. But there was no place to do it in the settings. (HTC has an app of its own called "SD Manager", but that just made the situation more frustrating!). So, I did that from the Recovery, and that did it!

    I used TWRP, went into "Mount" section, and mounted and unmounted the internal storage. Also wiped cache and Dalvik cache just in case, and after the restart everything is working perfectly.

    Hope this helps someone else.
    10-11-2013 03:46 PM
  7. Timothy Takemoto's Avatar
    Thanks. That sounds very useful. When I next get locked out of my SD card (having disconnected in too much of a hurry) I will report back. I am not sure what the cache and the Dalvik cache are but if it is just as simple as mounting and un mounting using TWRP (twerp?) then that will be a breeze and very helpful.
    10-11-2013 06:25 PM
  8. Norbe Rojas's Avatar
    you have to plug in the USB in your tablet and in your computer. then, when your tablet is unlocked, a popup will appear asking wether to turn on or turn off your USB storage
    12-04-2013 03:41 PM
  9. billyray4766's Avatar
    as i continue to self-diagnose this problem (until someone who really understands this stuff can help me figure it out), it does appear that there are some crossed wires, and renamed things.

    when i attempt to move something from the device storage to the SD Card, it implies that it has done so. but when i go into settings>storage i can see that the memory available on my SD Card has remained the same, while the memory available in "USB Storage" has decreased.

    (keep in mind my phone is not connected to the computer during any of this).

    so, clearly, things that should be moving onto the SD Card are, instead, moving into USB Memory, which may or may not actually exist. when i use AppManager, it shows me that they are on the SD Card, but, as indicated earlier, settings>storage shows the file to be in "USB Storage".

    does this make sense?

    can anyone else offer some suggestions so i can have my camera and my apps that require an SD Card (like SwiftKey) back?

    Finally I find someone with the same problem I have but can't find an answer
    12-29-2013 05:43 PM
59 123

Similar Threads

  1. Replies: 21
    Last Post: 01-12-2013, 09:57 PM
  2. Jelly Bean Play Store apk with TV and magazines
    By newboyx in forum Android Apps
    Replies: 6
    Last Post: 07-07-2012, 01:28 PM
  3. Jelly Bean Play Store apk with TV and magazines
    By newboyx in forum HTC EVO 4G LTE Rooting, Rom's, and Hacks
    Replies: 3
    Last Post: 06-28-2012, 08:14 PM
  4. If the USB port is on top...
    By Shadnic in forum Sprint Epic 4G
    Replies: 8
    Last Post: 07-14-2010, 12:20 PM
  5. The Hunt is On... and It's Getting Ridiculous
    By kindaskimpy in forum HTC EVO 4G
    Replies: 30
    Last Post: 06-04-2010, 08:32 AM