1. UTnick's Avatar
    This is a link w/the method I used to install the apk (the linked OP method didn't work for me) and the Google Wallet app seems to work fine for me. It is showing me my unused $10, but it is too late in the evening for me to actually go test it. I will do my best to not be lazy tomorrow and find a store that has a NFC payment system.

    Anyway, you can try the linked OP method or I would recommend mine.

    Region / Device / Root Patched Google Wallet APK (1.1-R67-v5) - Android Software - MoDaCo

    ROMraid by MoDaCo

    *edit* I uninstalled wallet and also made certain I deleted the apk from both system/app and data/app before I went back and added them again. Thanks for the reminder fpineda101.

    The install method I used is similar to the linked OP method. I used Dropbox to get it on my phone from my PC. You can use whatever method you would like. Then I used Root Explorer to move the patched apk to system/app AND data/app. I also renamed the apk to what it was named previously on my phone when I downloaded Google Wallet from the Play Store. Your phone may have a different name as well. I think as long as they are named the same in system/app and data/app you should be fine. That is how I have it. Then don't forget to change permissions once you move it. With Root Explorer you will long press to get the menu and once you select permissions you will check the first two radio buttons on the first row of three. Then uncheck the last two radio buttons on the second row. Then uncheck the last radio button on the last row. Those permissions should match with all the other apps listed. It will look like this: rw-r--r--

    Good luck.

    Here is a solid step-by-step list from fpineda101:
    I had to reboot my phone to get it to work. Here re the steps I took

    1. Write down apk name in system/app
    2. Delete apk in system/app
    3. Mount r/w in system/app using root Explorer
    4. Copy apk to system/app and rename it
    5. Set permissions. I actually used this which worked for me
    x x x
    6. Mount system/app as r/o
    7. Delete apk in data/app
    8. Copy apk from system/app with rename to data/app
    9. Reboot and run the sucka

    Don't take the update in Goggle Play. It still doesn't fix Google Wallet for the Evo 4G LTE. BUT if after you did this apk switch you took the update -- don't fret. Because we installed the apk in system/app all you have to do is go back into the Play Store and select uninstall. It will revert back to the version we manually installed.

    07-01-2012 01:03 PM
  2. halmo20#AC's Avatar
    Did not work... It still kept on asking that app had to be updated....
    RawisTheGameHhH likes this.
    07-01-2012 02:48 PM
  3. UTnick's Avatar
    Did not work... It still kept on asking that app had to be updated....
    Did you go in and uinstall from market and then delete apks from system/app and data/app? That was the first step I took before moving the apks over. First to system/app and then to data/app.
    07-01-2012 07:42 PM