1. adlebo's Avatar
    Hi. I'm rooted but stock. Lately I have been getting repeated messages that "shell has been granted super user permissions" what's up with that?? It does that like 5 times one after another.
    04-10-2013 09:01 AM
  2. meyerweb#CB's Avatar
    Did you recently install an update to your SuperUser app, and are you using SuperSU?

    When you get that message, do you see something that looks like this:

    Attachment 64963

    If so, you need to uncheck the box that says "Ask Again."
    Attached Thumbnails Shell has been granted super user permissions-screenshot_2013-04-10-09-51-35.png  
    04-10-2013 10:01 AM
  3. adlebo's Avatar
    No I haven't installed any updates to super user and I'm not using supersu. What's weird is that I don't get that box with the option not to ask again. I guess because it's not really an app requesting permission. It's more of an internal system thing. In the super user app it doesn't show "shell" as one of the apps, but it definitely is in the "log" where it shows that it was granted permission in a repetitive way.
    Attached Thumbnails Shell has been granted super user permissions-screenshot_2013-04-10-12-27-36.png  
    04-10-2013 12:26 PM
  4. gijoecam's Avatar
    same situation here... No app called Shell to deny, and it usually happens when the phone freezes for a minute or two. I updated the su binary in superuser from 3.1 to 3.1.1 today and it made no difference. Still locks up once every few hours. Haven't found a conclusive solution yet...

    Oh, and the phone is a Samsung Galaxy s3 rooted stock.

    ETA. Forgot to mention, mine seems to be triggered by one particular folder in my gallery, specifically the folder that holds all the camera photos. Any of the folders in the gallery work fine, but the camera folder seems to be the sticker for some strange reason...
    adlebo likes this.
    04-13-2013 10:01 PM
  5. sev92's Avatar
    Have the same problem. It seems that when I adjust the volume with the buttons on the side of the phone it goes a bit crazy and shows that message repeatedly and sometimes the phone will randomly vibrate when it does this as well. The phone freezes as well.
    anyone found a solution?
    04-19-2013 08:42 AM
  6. weatheredeyec57's Avatar
    04-24-2013 08:00 PM
  7. adlebo's Avatar
    I just made an account to respond 'shell has been granted Superuser permissions' a result of Bug Report - xda-developers freeze or rename this file
    Appreciate your help, but I can't figure out which file to rename.
    04-25-2013 12:27 AM
  8. Q doemaarniet's Avatar
    In my case this problem was solved by renaming /system/bin/dumpstate and /system/bin/bugmailer.sh
    At first I only renamed bugmailer.sh, but this didn't solve it. Then I noticed there were no screenshots on my sdcard so I tried renaming dumpstate, which solved the problem.

    HTC Sensation
    CyanogenMod 9.1.0
    05-07-2013 10:55 AM
  9. Golfdriver97's Avatar
    I changed superuser apps from Superuser to SuperSU, that got rid of the messages as well.
    05-09-2013 10:57 PM
  10. gollum18's Avatar
    It would help to remember that android is a gui, that runs on top of linux, which is a clone of the Unix command shell. When you grant su perms to it, you are simply granting it to the linux system running underneath android.

    Sent from my SPH-L710 using Tapatalk 2
    adlebo likes this.
    05-28-2013 10:00 PM
  11. Azzipink's Avatar
    i don't understand all the techy talk.... how can i get rid of this? I don't know how to rename my superuser and this shell thing is blocking apps i use regularly.. help please!
    10-01-2013 12:21 PM
  12. Nikashi's Avatar
    I found the answer to this issue on another forum. If you press volume up + down + power inadvertently, this is the key combination to send a bug report, which also is what causes the superuser permissions to be required/given to shell. Normally this would all be silent in the background, but because you have root and a su app, the messages are all generated and logged, causing the temporary slowdown.

    Hope that helps!
    11-20-2013 03:02 AM
  13. ciun's Avatar
    hi,
    did u solve the problem ?
    01-25-2014 07:43 AM
  14. Rana Mahfuz's Avatar
    I just solve the problem.
    In my side, I find that it was a background process of Viber. which want root permission, it can be a bug from Viber. May be first time I allow that access, I dont remember, as a result there is no way to block this from 'Super User'. Because Superuser dont show any allowed app for that.

    So I Unroot and Root again using Frameroot then restart and the bug (something that) want to allow the root access (SuperUser Asked me), I dont allow that and check the remember button. thats it.

    Thanks
    02-01-2015 08:13 AM
  15. dogafterbone's Avatar
    Open SuperSU. Click on each app listed and make sure none of the Notification boxes are marked as "Enabled" ... They should either be Global default or Disabled. For me it was Nova Launcher asking for root permission constantly and notifying me of it every goddam time.
    02-09-2015 12:49 AM
  16. Imtila Temjen Longchar's Avatar
    Hi. I'm rooted but stock. Lately I have been getting repeated messages that "shell has been granted super user permissions" what's up with that?? It does that like 5 times one after another.
    06-22-2015 10:57 AM
  17. calebgoesbig's Avatar
    Thank you dogafterbone! Now I don't have to add wait time to have the superuser/shell message clear out.
    10-27-2015 01:49 AM
  18. Nubz500's Avatar
    I went into super user tap shell and gave it access to root changed defaults to acess only full content
    05-14-2016 09:40 PM
  19. Nubz500's Avatar
    I mean notification disabled acess full content and root in that order hope it helps
    05-14-2016 09:43 PM
  20. michael lowe4's Avatar
    Hi. I'm rooted but stock. Lately I have been getting repeated messages that "shell has been granted super user permissions" what's up with that?? It does that like 5 times one after another.
    Everyone, you are making your solutions far too complicated. If you have a rooted phone just open the SuperSU APP by ChainfireSU the only SU app you should ever use, scroll down to allow toast notifications and uncheck it! That simple! No more notifications about such and such has gained permissions to an interactive shell!!! Problem solved!
    08-14-2016 05:40 AM
  21. umar 123's Avatar
    supursu permission
    02-18-2018 05:28 AM

Similar Threads

  1. Shell has been granted Superuser... ??
    By Somegeek in forum Samsung Galaxy S3
    Replies: 9
    Last Post: 02-08-2013, 12:26 PM
  2. WugFresh's Nexus Root Toolkit has been updated - Super easy JB root tool. (10-11-12)
    By 2waterfowl in forum Google Nexus 7 (2012) Rooting, ROMs, & Hacks
    Replies: 0
    Last Post: 10-12-2012, 12:50 AM
  3. Super User Permission Problem
    By evieeve in forum HTC Hero Rooting, ROMs, and Hacks
    Replies: 1
    Last Post: 05-23-2012, 10:18 PM
  4. stuck lg optimus v in clockwork recover no Super User permission
    By md108 in forum General Help and How To
    Replies: 6
    Last Post: 10-06-2011, 10:52 PM
  5. Do I really have to grant Super User access EVERY time???
    By ShawnWDP in forum HTC Hero Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 06-04-2011, 05:11 PM
LINK TO POST COPIED TO CLIPBOARD