1. Joshua Ford 74's Avatar
    Hi everyone. 1st post. I'm a Noob when it comes to all this rooting. After about 6 hours of trying yesterday I FINALLY got my S3 rooted and up and running. The reason I went through all of this is because I don't have high speed internet where I live. I do have 5GB of Hotspot, but of course that limits the things I enjoy doing (Gaming, etc). I had unlimited data until Sprint dropped the hammer on everyone. So... now my phone is rooted. Being naive I just thought that was the hard part, finding a tethering app would be the easy part. Of course since I'm here, we all know how wrong I was. I've tried numerous ways. Including the Treve Mod ( I get an error when starting it up, telling me to check the file log and there isn't anything there. here's what I've downloaded onto my phone since I rooted it..

    TWRP Manger
    Root Checker

    Please remember that until yesterday I had no clue what those 3 things were, did, or even existed. So, I'm asking for any help I can get. Feel free to talk to me like I'm 5 years old when explaining things to me like flashing, wiping, backing up etc... All I really want out of all this is to be able to use my phones data so my family can get on the PC. If I can get that I'll be a happy Dude/Dad.

    Thanks in advance, I've read some of the threads here and it's crazy how much you guys/gals know about all of this.
    02-23-2014 04:27 AM
  2. Joshua Ford 74's Avatar
    Okay. So I read a few other threads and attempted to install the Hotpot that was posted by meyerweb. I went into my TWRP Manger to install it and when it went to install I got this message.

    This package is for "ace" device. this is "d2spr".

    Any idea what I did wrong ?
    02-23-2014 05:03 AM
  3. Super Dave426's Avatar
    You downloaded the wrong version, d2spr is the sprint version of any download and is for Sprint phones. Look for that download. Or you can install a custom ROM that has Hotspot built in, but being a NOOB you might want to read up on it a while before you attempt it. Before you attempt anything boot into recovery and choose the back up and restore option, choose BackUp and make a back up of your phone in case you mess things up real bad you can always restore to the state it is now by choosing restore. When I was new at this I read as much as I could and wrote out notes of the steps, I still do, because it is still new to me.

    Meyerweb posted a new hotspot to try instead of Trev. It is here : [MOD][Deodex][Odex][MB1][MC3][MD4][MK3]Hotspot Mod - Working 4G - xda-developers

    I am guessing you are stock rooted on the MK3 modem so you will need this download: Dev-Host - MK3HotspotMod-odex.zip - The Ultimate Free File Hosting / File Sharing Service

    That is for MK3, go into Settings > More > About Device and look at the build number to see if it ends in MK3. Then read the thread and see how it's done, looks pretty straight forward, boot into recovery, wipe cache partition, wipe dalivik, flash zip. One thing you should always do is check the MD5 Sum to make it matches with what is posted on the download page, I use MD5 Hash on my phone and WinMD5Free on my PC.
    meyerweb#CB likes this.
    02-23-2014 10:10 AM
  4. Joshua Ford 74's Avatar
    Okay thx to everyone's help I got it installed properly. Now, how can I tell if its working ? I have 5gb of Hotspot, so how can I know if I'm using that or if I've done this successfully?
    02-23-2014 04:45 PM
  5. GTWalling's Avatar
    Are you trying to not use Data. It will use what you have. The Tethering apps are so you do not have to pay extra to the provider for a separate Tethering Package. It will use your 5gb so keep an eye on your usage.
    02-23-2014 06:00 PM
  6. Joshua Ford 74's Avatar
    Yes, I want to tether my phones Data and eventually get rid of my HotSpot (That I pay for every Month). I've tethered my phone and checked since my last post and it IS using my 5GB of data. So, is there something else I need to do for this to.. I don't know "take over" or however the correct phrase would be. I was always able to tether my phone (since I've paid for the 5GB) Thanks for any help.
    02-23-2014 06:19 PM
  7. meyerweb#CB's Avatar
    I've never had the official tethering plan, and the hotspot mod is built into the ROM I run, so I'm not sure what you need to do, but here are a couple of guesses. In you app drawer, is there a separate icon for the hotspot mod? If so try starting tethering from that app. If not, or if that doesn't work, I think you may have to cancel the Sprint plan to use the free tethering.

    If you haven't already, you might want to read through the XDA thread that Super Dave linked to. The question may have been asked an answered there.
    02-23-2014 08:22 PM

Similar Threads

  1. I prefer not to use kies but what else?
    By Courtenay Dawn in forum Samsung Galaxy S3
    Replies: 13
    Last Post: 03-23-2015, 10:51 AM
  2. keep being told to log into "Samsung Account" after 4.3 update
    By Arlizz in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 3
    Last Post: 02-24-2014, 03:38 PM
  3. how to manually update to 4.4.2
    By asteinmetz54 in forum Moto X (2013)
    Replies: 2
    Last Post: 02-23-2014, 02:35 PM
  4. I'm rooted. How to install a ROM?
    By combat82 in forum myTouch 4G Rooting, ROMs, and Hacks
    Replies: 1
    Last Post: 02-23-2014, 09:43 AM
  5. Replies: 0
    Last Post: 02-23-2014, 03:56 AM