1. coop616's Avatar
    I'm a recent S3 owner, 2nd hand:

    ss odexed blue holy grail 3.5
    baseband MB1

    I've done a lot of searching, but it gets confusing as I did not do the rooting, etc.

    in SuperSU settings, I thought I wanted to UNroot the phone selecting the 'unroot' option, then found out where I live I do have a decent enough signal to use free HOTSPOT.

    Trouble is, HOW DO I reroot the phone and restore root option. SuperSU comes up with binary not found.

    Feel like it was easy to screw it up, but very complicated to fix it.

    I'd be happy to either restore CWM and be rooted again (supersu perhaps if not to difficult). Keeping or losing the odxed blue is not as critical as long as I can get the free Hotspot to work.

    P.S. I have read that baseband MD4 is newer and part of why I originally unrooted was so that I could "update" the phone. ALSO, if fixing CWM means losing APPS, i'm fine with that coz I don't have any apps saved and previous owners apps don't concern me.

    Thanks so much for any help. I know there is plenty of talent out there and I applaud those who take the time to help out those of us that are still learning.
    03-03-2014 09:42 AM
  2. meyerweb#CB's Avatar
    Can you still boot into your custom recovery? (CWM) If so, this ought to work:

    Download the flashable zip version of SuperSU, and copy it to your internal or external SD card. Then flash it with CWM, and reboot. Now download the latest SU from the play store, and use it to update the version that you flashed. The flashable version is here: UPDATE-SuperSU-v1.65.zip | by upndwn4par for Galaxy S 3

    If that doesn't work, you'll need to reinstall a custom recovery with Odin first.

    Oh, you don't really need to unroot to update the modem. Flashable (in recovery) versions are available.

    I have the MD4 modem (and ROM) here: https://drive.google.com/#folders/0B...mF6T0RBSzdZOTQ

    And here's the newest Sprint modem, MK3. Should work fine with earlier ROMs, so you might want to try it, too.

    coop616 likes this.
    03-03-2014 09:28 PM
  3. coop616's Avatar
    hey meyerweb, your feedback sounds really good, however I'm having trouble right out the gate. the supersu zip file doesn't appear to have the file to download. If an when I get that loaded, not sure I know how to " flash w CWM".

    I tried searching for the zip file to see if there's one that will have a direct download but haven't found one yet.

    I'm pretty green at this, but I am trying.

    your solution sounds great, I just need to see if I can get past the first download file.

    I want to thank you for doing a very indepth reply, sorry if it's all new to me.
    03-04-2014 09:05 PM
  4. meyerweb#CB's Avatar
    If you're having trouble downloading it, here's what you need to do. The big green download button on that page is actually an ad. When you go to that page, look at the right side of the page and you should see a countdown timer. When the timer hits zero, there will be a list of sites there from which you can download the SuperSU zip.

    To flash, or install the file, you'll need to copy it to your phone storage as is. Don't unzip it. The shut your phone off and boot into recovery. (Volume UP, Home and Power buttons. You should have done this in order to root.) I don't use CWM, but I think you want to tap on the option to "Install zip from SD card." Navigate to where you copied the zip file, tap on that file, and select "yes" to install it.

    Once the install is done, reboot the phone.
    03-05-2014 03:55 PM
  5. coop616's Avatar
    thank you for clarifying. I will try this tonight.
    03-06-2014 12:18 PM
  6. coop616's Avatar
    while waiting for the time out, it says it works better to register. comes up w a list of mirror options which downloads a .98mb supersu file that does nothing.

    03-06-2014 06:40 PM
  7. meyerweb#CB's Avatar
    Did you try to install the supersu file using your recovery (Volume UP, home, power)? What happened? Many people have successfully used that file. It should be 1008 MB (Or 1007.7, but Windows isn't that precise.)
    03-07-2014 12:28 PM
  8. coop616's Avatar
    when I click ur link a timer counts down n says something about being registered is better. then it gives several choices that say mirror. when I pick one of those it just loads a tiny supersu file that won't even open.

    I did a search for the supersu zip file n they all seem to have some sort of 3rd party "load" file u have to get before u can load the supersu.
    03-07-2014 01:55 PM
  9. meyerweb#CB's Avatar
    I just downloaded it, and it opens fine. How are you trying to open it? The zip itself isn't executable, and there are no executable files within the zip. You copy the zip, as is, to your phone, and then install it using recovery. You don't have to unzip it at all.
    03-07-2014 03:04 PM
  10. coop616's Avatar
    I go to this forum and open the post with your first reply and click on the supersu you have in your post, when i look to the right, i see the green link button with a timer counting down and the phrase denoting that it works better if i'm 'registered'. So i've never gotten to a point where the 1008mb file was available to load. I get the same result if I try to capture the file from my laptop as I do when i try to download it from my phone.

    I bought this phone 2nd hand, so any files that might have been loaded on a computer i do not have access to. If you want to PM me for more detail, i'd be fine with that. BTW, thank you so much for putting in all the help you have been doing. I really want this to work and I'm sorry if i'm being a pain in the you know what.
    03-07-2014 03:24 PM
  11. meyerweb#CB's Avatar
    Once you wait 10 seconds or so, and get the list of mirrors, you should be able to download the 1008MB file. I downloaded it from the first mirror that appeared in the list.

    I've copied the download to my Google Drive. See if you can download it from here:

    03-07-2014 10:27 PM
  12. coop616's Avatar
    all I get from that link is an adoption application.
    03-08-2014 10:18 AM
  13. coop616's Avatar
    I went back and downloaded the file from the MIRROR options. The file says it's .98MB as a zip file. When i double click on folders within that file, i see a supersu.apk file that says it's 845MB so perhaps that file will UNZIP when i do the recovery??? Yeah, that adoption form was something i had from awhile back, ignore that.
    03-08-2014 10:35 AM
  14. coop616's Avatar
    Ok, i did some digging, there were like 5 copies of the zip file on my SD card....i deleted all but one of them, went into recovery mode and flashed the file. Then i downloaded the supersu app, but all it says is "no apps configured".

    loaded root checker and it says device is rooted. So not sure about supersu not being configured. One thing i did read somewhere, i have CWM and i believe it said .4 has a bug. may have to do some searching on that. Next challenge is to update to MD4
    03-08-2014 11:07 AM
  15. meyerweb#CB's Avatar
    Not sue what the error means, but I'm glad you got the zip installed and have root again. Good luck.
    03-08-2014 03:31 PM

Similar Threads

  1. HTC One: need help with 2 things
    By Carl_Barr in forum HTC One M7
    Replies: 14
    Last Post: 03-31-2014, 05:52 PM
  2. Need help finding compatible U.S. Carrier.
    By Ratchet clank in forum General Help and How To
    Replies: 2
    Last Post: 03-03-2014, 07:18 PM
  3. Typing question
    By marios1441 in forum General Help and How To
    Replies: 1
    Last Post: 03-03-2014, 04:13 PM
  4. Simpleton questions
    By Ludditejones in forum Samsung Galaxy Tab Pro 8.4
    Replies: 3
    Last Post: 03-02-2014, 11:28 PM
  5. Please help to identify MID 7" tablet
    By axe6st in forum Other Tablets
    Replies: 4
    Last Post: 03-02-2014, 10:58 PM