08-18-2015 08:30 PM
27 12
  1. jtcsrvbi's Avatar
    How to root your samsung galaxy s3 (easily) - XDA Forum

    i followed the instructions. no luck. it said passed but root checker says no.

    i tried a few times,
    the boot screen reads:

    odin mode
    product name : sph-l710
    current binary: custom
    system status : custom
    qualcom secureboot: enable
    waranty bit: 1
    bootloader ap swrev: 2

    odin screen info

    <ID:0/014> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> CF-Auto-Root-d2spr-d2spr-sphl710.tar.md5 is valid.
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/014> Odin v.3 engine (ID:14)..
    <ID:0/014> File analysis..
    <ID:0/014> SetupConnection..
    <ID:0/014> Initialzation..
    <ID:0/014> Get PIT for mapping..
    <ID:0/014> Firmware update start..
    <ID:0/014> recovery.img
    <ID:0/014> NAND Write Start!!
    <ID:0/014> cache.img.ext4
    <ID:0/014> RQT_CLOSE !!
    <ID:0/014> RES OK !!
    <ID:0/014> Removed!!

    it takes abt 30 sec to complete and flashes something about "stock recovery" on the red pirate screen

    any Detailed ideas on how to properly root would be great.

    07-16-2014 07:32 AM
  2. Golfdriver97's Avatar
    07-16-2014 08:50 AM
  3. jtcsrvbi's Avatar
    Tried that... cant find a good link to GalaxyS3RootUSCanada.zip

    so many download ads on that site i cant find the right file

    but thanks for trying
    07-16-2014 10:11 AM
  4. jtcsrvbi's Avatar
    tried this... i get a cant mount error. i sent him the info and am waiting for a reply... great video, very well done.
    07-17-2014 07:53 AM
  5. droidtrix11's Avatar
    Have you tried towelroot? One click root. Easiest root ever. I've used it on Galaxy S3 and worked 100%.
    07-21-2014 10:35 PM
  6. droidtrix11's Avatar
    forgot to say towelroot is here : https://towelroot.com/
    he's a top hacker
    07-21-2014 10:42 PM
  7. geronimo4242's Avatar
    Have you tried opening SuperSu? And if you had, what did it say?

    Here: .

    That should work. It is a link on how to to fix Supersu issues for the sprint s3. It worked for me. Hoped this helped.

    Posted via Android Central App
    07-22-2014 04:13 PM
  8. jtcsrvbi's Avatar
    THANKS geronimo4242 and droidtrix11

    i have been away a few days and just checked back in on this post. i will look over both ideas and see if either work
    07-24-2014 08:13 AM
  9. geronimo4242's Avatar
    In the video, he flashes a Supersu update and I don't think he included it in the description. So here is a link he uses for the supersu update


    If you have any more questions. Feel free to ask us.

    Posted via Android Central App
    07-24-2014 09:46 PM
  10. jtcsrvbi's Avatar
    If you have any more questions. Feel free to ask us.

    Posted via Android Central App
    thanks... i have a few. let me try to explain best i can.
    the first flash "i think thats what it is... very new and not sure of the terms) goes through, boots to the red pirate droid and reboots.
    then i flash the custom recovery and can get into that. on the TWRP screen at the bottom center is a box that brings you to what looks like a linux terminal screen.
    this is where i think the problem is. but everything i have found online so far is written for someone who already understands what they are doing...

    anyway it reads

    e: unable to find partion size for '/boot'
    e: primary block device 'dev/block/mmcblkop15' for mount point '/data' is not present

    then a slue of cant mount errors

    i am sure this is why it dosent load supersu. i loaded it via GP but it says the binary is missing.

    if i load the zip you posted on my phone and use TWRP will this load the binary? or is the cant mount error blocking the binary?

    thanks again...
    07-25-2014 07:28 AM
  11. geronimo4242's Avatar
    Maybe this will help maybe not : http://forum.xda-developers.com/show....php?t=2228447

    Can you please exactly what you are doing and what you have? Like are you on stock? What android o.s you have? Jellybean? KitKat? I want to help you as much as I can if you can answer my questions.

    So basically, you want to flash cf auto root via Odin. After that, if it says "SuperSU has stopped" or something like that when you either tap on the app or it happens when you reboot and so you will have to install SuperSU itself with a file explorer every time you reboot. Now the SuperSU update I gave in my last reply will or could fix that problem. Now here comes your problem. When you try to flash TWRP, all these can't mount errors keep popping. I am not familiar with that as that never happened to me. But please tell me what do you have going on in your phone? Be specific as you can be so others and I can help.

    Vanir ROM in use!
    07-25-2014 08:33 AM
  12. jtcsrvbi's Avatar
    thanks and sorry for the confusion,
    first i flashed back to stock os. 4.4.2 and verified it in DL screen

    next i flashed cf auto root via odin for Samsung siii.
    no SU app appeared anywhere on my phone. not in apps or on any screen so i loaded it via GP
    when i try to run it i get the "no binary found" error

    then i flashed TWRP (see errors in post above)

    androin ver 4.4.2
    baseband l710vpudnd8
    kernel ver 3.4.0-1368792 dpi@swdd5812#1
    build kot49h.l710vpund8
    se for android status enforcing sepe-sph-l710_4.4.2_0011
    07-25-2014 08:52 AM
  13. geronimo4242's Avatar
    Ok I never heard of GP. Sorry but what is it?

    Vanir ROM in use!
    07-25-2014 09:17 AM
  14. jtcsrvbi's Avatar
    Ok I never heard of GP. Sorry but what is it?

    Vanir ROM in use!
    google play store
    07-25-2014 09:19 AM
  15. geronimo4242's Avatar
    Oh duh. ._. I've been looking everywhere online like XDA and couldn't find a solution. I'm sorry but I will continue looking to try to find a solution. That is weird though. I have a sprint 4.4.2 s3 and it never happened to me before.

    Vanir ROM in use!
    07-25-2014 09:36 AM
  16. geronimo4242's Avatar
    When you couldn't find SuperSU.. Did you look via a file explorer?

    Vanir ROM in use!
    07-25-2014 09:38 AM
  17. jtcsrvbi's Avatar
    no... i just went to GPS and loaded it... i really think the cant mount is the problem. thats linux for cant read the drive... so it cant get the data. i have seen a few posts for fixing this but non seem to be 100% what i have and i dont know enough about it to risk trying. most of the links i find are old. i found out the hard way installing the wrong or old version will brick your phone. my hope was to find someone who could help explain it better.

    thanks for all your help... we may both learn something new from this
    07-25-2014 09:48 AM
  18. jtcsrvbi's Avatar
    07-25-2014 10:36 AM
  19. jtcsrvbi's Avatar
    forgot to say towelroot is here : https://towelroot.com/
    he's a top hacker
    tried but the site went nowhere... it had a donate button... i dont mind donating but want it to work first... thanks for the try
    07-25-2014 10:39 AM
  20. chuyfawkes's Avatar
    I am having the exact same issue. Boost mobile, 4.4.2, gs3 L710. Odin root method does is thing, says it passed. But root checker can not verify root.

    Towel root method says my device is not supported. Can anyone please help
    09-05-2014 03:10 PM
  21. jtcsrvbi's Avatar
    i never did find an answer...
    09-05-2014 04:23 PM
  22. magdaleno hernandez's Avatar
    Mount error is because the version of twrp is not compatible with ur build or had a bug or is corrupt... ive run into this many many times...
    Sometimes a reset will work or reinstall the recovery and if that doesnt work then redownload recovery and reflash... still not fixed- try a different version of twrp or cwm...
    09-05-2014 11:11 PM
  23. bejamin77's Avatar
    Fellas, I'm having the exact same problem. Can we please work on a solution? After flashing CF-Auto using Odin the phone reboots but NO SUPERSU app is displayed in the phone's app tray. I try flashing CF-Auto then manually booting to recovery. However, the phone will not boot into recovery after the CF-Auto flash. It just display the RED android logo and go through the normal sequence of stating it's rooting the phone, adding SuperSU etc... then it boots up but you don't have root access or a SuperSU app present. I then flash (using Odin) TWRP recovery. This allows you to gain access to a recovery menu. However, you can't get anywhere (to install the UPDATE SUPERSU file that you download to your phone) because all you get is a bunch of mounting errors. In fact, both the internal and external storage read as "0" MB. I think the issue is as the guy who started this thread allude to is for some reason these tools can't read/write to the drives (internal or external). Any help will be greatly appreciated.

    Model: SPH-L710

    Let me know what other info you may need to help me out here. Thanks in advance!
    09-17-2014 10:00 AM
  24. devildogwillbur's Avatar
    same issue as OP. Couldnt run SuperSU either, asks for updated binary. The TOWEL link worked perfectly. BUT Norton would not let me download it on my PC, it was listed as a trojan, and on the phone if you attempt to install it gives warning that it bypasses google security and recommends you do not install... Works in 2 seconds once downloaded and installed (15 seconds, if that) no reboot (says if it reboots it did not work) I then ran SuperSU and it did its ran, update and disabled Knox it froze, so i restarted and ran it again and Knox was removed. (which is your problem to begin with I think, had this issue months ago but its been a while i forgot, then I remembered...) you also can try running the Knox removal script then running CF auto root worked for me last time.
    09-24-2014 09:02 PM
  25. Lisa Mitchell27's Avatar
    Hey folks, I too have a Sprint galaxy s3 that will not root.
    Flashed via Odin, all seems to work well, screen says 'Pass', but when phone reboots, red droid appears and a few sentences telling me basically restoring stock recovery.
    All instructions found for rooting once on 4.4.2 are easy enough, but they are taking. Unable to use towelroot b/c computer keeps refusing it as a bad file.
    Root checker says not rooted and TWRP says no custom recovery installed.
    What am I missing??
    12-26-2014 03:24 PM
27 12

Similar Threads

  1. Weather app wont open chrome since the update
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-10-2016, 09:21 AM
  2. The back cover of Galaxy S5
    By Little_Pharaoh in forum Ask a Question
    Replies: 1
    Last Post: 07-16-2014, 07:49 AM
  3. ATT Galaxy S4
    By Stu Parker in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 0
    Last Post: 07-16-2014, 07:29 AM
  4. Replies: 1
    Last Post: 07-16-2014, 07:15 AM
  5. anyone know if the sprint update fixed the signal issue
    By stevextragedy in forum HTC One M8
    Replies: 0
    Last Post: 07-16-2014, 06:08 AM