07-04-2017 08:18 AM
57 123
tools
  1. fivegear's Avatar
    I have looked around on this forum and done some searching elsewhere. I don't see many complaints about it. If I go into the dialer and *#0011# and turn off the power save mode for WiFi then it stops doing it, but if not then it randomly and frequently throughout the day will turn the WiFi off and then right back on. It will do it while trying to use data, it will do it while sitting the idle. It doesn't seem to matter.

    The most frustrating part is that this setting will toggle back to on (by itself) and start the madness all over again if I power the phone off and on again.

    I can't figure why the second symptom would be related but if I have this WiFi power saving setting in the default ON position then I also get a situation where about every third or fourth time the screen comes on (doesn't matter if it is the power button to wake it or proximity sensor during a call) the touch input won't work for 3 to maybe 8 seconds. This is often enough time to miss a call beeping in on call waiting because the phone won't register touch input for my to answer even though the screen is on.

    If I make sure to turn off the WiFi power saving setting through the dialer then both of these issues seem to go away completely.

    Am I the only one with these issues?
    McPlot likes this.
    07-23-2012 10:53 AM
  2. Skunkape60's Avatar
    instead of using the dialer code use the menu.

    Menu settings/under wireless and network settings choose more settings / mobile network / automatic connections / uncheck Sprint automatic connections

    Leave the power saving mode in the dialer menu alone. This is the way it's supposed to work. Since WiFi uses less power it automatically looks for WiFi. Go into the menu and turn off Sprint automatic connections and leave the dialer setting alone. It will no longer try to find WiFi.

    ssweet97 and Ntchwaidumela like this.
    07-23-2012 11:11 AM
  3. fivegear's Avatar
    Thanks for the reply but that isn't the same setting. This is a power saving setting only.
    07-23-2012 11:15 AM
  4. bryanw504's Avatar
    Never heard of that problem there is also a power saving mode toggle switch when you press the menu button from the home screen.

    Sent from my SPH-L710 using Android Central Forums
    07-23-2012 11:20 AM
  5. fivegear's Avatar
    Yes I have that one turned off as well
    Both settings mentioned were off before going into the dialer and turning the WiFi power saving setting off. I am curious to see if it is ON or OFF in other peoples phones now.
    07-23-2012 11:42 AM
  6. kpurcell's Avatar
    I'm experiencing the same issue. Every couple of minutes the phone just drops the WiFi signal and then almost instantly reconnects. At first I quite using the AN radio on my router only using the BGN and that seemed to fix it. But now its happening on the BGN network. After reading this thread I tried to engage the Power Saving mode from the Notfication center because it was always off. Since turning it on I've not had a problem with dropping WiFi. Its got me confused.
    fivegear likes this.
    07-23-2012 04:55 PM
  7. Skunkape60's Avatar
    I'm experiencing the same issue. Every couple of minutes the phone just drops the WiFi signal and then almost instantly reconnects. At first I quite using the AN radio on my router only using the BGN and that seemed to fix it. But now its happening on the BGN network. After reading this thread I tried to engage the Power Saving mode from the Notfication center because it was always off. Since turning it on I've not had a problem with dropping WiFi. Its got me confused.
    this is a different issue all together. His phone turns WiFi on when he wants it off.

    07-23-2012 05:21 PM
  8. storino03's Avatar
    I made this very same topic, so if you searched properly, you would have seen it.
    07-23-2012 05:26 PM
  9. Skunkape60's Avatar
    Thanks for the reply but that isn't the same setting. This is a power saving setting only.
    So what is this setting supposed to do? When i enable the power saving mode it disconnects and reconnects but none of the settings change in the dialer menu at all. You have obvious used this before. I never before bothered looking at these. I'm not trying to be an jerk, I am trying to learn here. Cause I don't understand what it is your trying to do or why. I mean how does it save power?

    07-23-2012 05:39 PM
  10. sushi's Avatar
    There is a similar thread on XDA with the OP collecting logs.

    http://forum.xda-developers.com/show....php?t=1790187

    ----

    Brought to you by my ghetto Samsung Galaxy S III mount
    07-23-2012 06:41 PM
  11. ZiggSeVO's Avatar
    I made this very same topic, so if you searched properly, you would have seen it.
    And if you read the thread you'll notice this isn't the same issue so please keep the poor attitudes like that on the less friendlier forum.


    Edit#2. Thanks

    Sent from my SPH-L710 using Tapatalk 2
    ladyc0524 and MaXXimus like this.
    07-23-2012 08:52 PM
  12. storino03's Avatar
    You're welcome.
    07-23-2012 09:26 PM
  13. mc_gusto's Avatar
    I just noticed this happens to me. almost everytime the screen goes to sleep for a couple of minutes it disconnects wifi. I wake the phone and its on 3g. When I unlock it connects to wifi. Is this similaar? the sprint smart connections thing or something different?
    07-24-2012 12:45 AM
  14. fivegear's Avatar
    To add insult to injury my phone added the "sleep of death" to my day yesterday. That makes the 4th time it has performed that neat trick (sarcasm). So that was the last straw, I filed a warranty claim on it! Please note that I spent time on the phone with both Samsung and Sprint (including more than one hard reset) trouble shooting this phone to attempt to resolve the issues before proceeding with a claim.
    07-24-2012 09:19 AM
  15. mrsimps's Avatar
    I'm curious too. If i'm using my phone, I'll repeatedly see a message appear that reads something like "connecting to xxxx wifi." I've unchecked the sprint automatic connections feature because I saw that on some other forum, and that worked for a while, but it started up again last night. I went through to make sure that the sprint auto connect hadn't somehow been re-activated; it hadn't. So, I don't know what's going on. The connection remains fine, meaning I can still use my phone as normal; it's just annoying that the message repeatedly pops up at the bottom of the screen, which is indicative that something isn't functioning quite right.
    07-24-2012 01:18 PM
  16. Reveille's Avatar
    MIne does same thing. Turn off wifi and then in a few minutes wake up phone and it is connected to wifi again. Very annoying
    bluestatemania likes this.
    07-24-2012 03:10 PM
  17. fivegear's Avatar
    MIne does same thing. Turn off wifi and then in a few minutes wake up phone and it is connected to wifi again. Very annoying
    I think what you are experiencing is Sprint's automatic connections. This is different from that. This is a random powering off and then immediately back on of WiFi.
    07-24-2012 04:48 PM
  18. ZiggSeVO's Avatar
    You're welcome.
    No see you misunderstood...the thanks was for someone editing my post for me...not for your unneeded unhelpful comments.

    Sent from my SPH-L710 using Tapatalk 2
    ladyc0524 and cruiserandmax like this.
    07-24-2012 06:28 PM
  19. furnace's Avatar
    I think what you are experiencing is Sprint's automatic connections. This is different from that. This is a random powering off and then immediately back on of WiFi.
    Fivegear,

    Thanks for starting this thread. My S3 WiFi (on Sprint) is also constantly turning itself on. I think you've solved this issue in your first post though. I entered the code you mentioned and got to that WiFi menu. I saw that the "WiFi power save mode" is checked on by default.

    I think this is what is turning the WiFi back on randomly. It makes sense: I've read in many forums that the WiFi radio uses less power than 3G or 4G. Therefore, it makes sense that if "WiFi power save mode" is on, then the phone will always periodically look to connect to a WiFi network in order to save power. It stands to reason that if you turn OFF this feature, then it won't be trying to save power by finding a WiFi network to connect to on an ongoing basis.

    I will report back and let you everyone know how it goes...
    08-06-2012 03:16 AM
  20. Skunkape60's Avatar
    Fivegear,

    Thanks for starting this thread. My S3 WiFi (on Sprint) is also constantly turning itself on. I think you've solved this issue in your first post though. I entered the code you mentioned and got to that WiFi menu. I saw that the "WiFi power save mode" is checked on by default.

    I think this is what is turning the WiFi back on randomly. It makes sense: I've read in many forums that the WiFi radio uses less power than 3G or 4G. Therefore, it makes sense that if "WiFi power save mode" is on, then the phone will always periodically look to connect to a WiFi network in order to save power. It stands to reason that if you turn OFF this feature, then it won't be trying to save power by finding a WiFi network to connect to on an ongoing basis.

    I will report back and let you everyone know how it goes...
    Yes this is good in theory but in actuality not so good. As the majority of places have their wifi password protected, it will be rare to find an open signal. So unless you are in an area that has wifi you can connect, to it is wasting battery by continually searching for what it will rarely find.

    _______________
    Just Flash It !!!
    08-06-2012 06:31 AM
  21. 93mustang50's Avatar
    Not sure I am in the correct area,if not please let me know where I should look for help. I have the Samsung S3 on Verizon network. Today my wifi at home turns it self off and on constantly. It will connect, less than 15 seconds later it turns off, scans, reconnects, disconnects, scans, reconnects and does this continuously. Thank you for any help that can be given. This is driving me crazy and I have read about this dialer thing and then a menu to disconnect powersaving on wifi, but I don't know how to get there. Thank you
    09-26-2012 09:38 PM
  22. terryb58's Avatar
    For those of you on AT&T, I had this same problem where when I'm at home I'm able to connect just fine but when I'm at work, my phone would connect to the wifi network and then disconnect after a few seconds. It turns out the AT&T Smart WiFi app was managing my WiFi connections. After I connected to my work wifi network using this app I haven't had any problem since. You may have to change the Auto-connect Wi-Fi hotspot setting to My Spots but that is actually what you want it to do. My Spots only includes AT&T wifi hotspots and hotspots you specifically connect to. Hope this helps.

    I just realized I'm in the Spring Galaxy S3 forum. Sorry about that. I'll leave this post though because it may give you guys an idea of what may be going on like having some other app trying to manage your wifi connections.
    terrykwms and TerranCPI like this.
    10-03-2012 04:57 PM
  23. Shantnu Chaturvedi's Avatar
    My phone was getting connected to Home WiFi but at work it got disconnected after a few seconds.
    Looks like I had the same problem with AT&T Smart WiFi app.
    I disabled this and my WiFi works perfectly fine now.
    Thanks for your solution.
    11-15-2012 12:32 PM
  24. Herduc's Avatar
    I'm having similar problem with my home wifi, I get the banner at the botton: reconnecting toXXwifi, every now and then. Also while I'm watching youtube it will disconnect and to into 3g, but if I look at the pull down menu it shows that wifi is on but not connected to my router. Tried the power saving on and off with not much diference, still getting the message: reconnecting to wifi...,
    Called sprint today and told me to remove battery, and reset the network from dialpad: ##72786#, seems a little better, but still reconnecting and loosing wifi. I don't know what else to do, is very annoying, my son has same phone and has no issues, as all the other devices connected to my home network work fine.
    I'll will try the sprint store today and see if I can get any straight answers.
    12-01-2012 04:45 PM
  25. Herduc's Avatar
    I'm having similar problem with my home wifi, I get the banner at the botton: reconnecting toXXwifi, every now and then. Also while I'm watching youtube it will disconnect and to into 3g, but if I look at the pull down menu it shows that wifi is on but not connected to my router. Tried the power saving on and off with not much diference, still getting the message: reconnecting to wifi...,
    Called sprint today and told me to remove battery, and reset the network from dialpad: ##72786#, seems a little better, but still reconnecting and loosing wifi. I don't know what else to do, is very annoying, my son has same phone and has no issues, as all the other devices connected to my home network work fine.
    I'll will try the sprint store today and see if I can get any straight answers.
    Well, I went back to Best Buys and used my geek warranty, got another phone the next business day and so far wifi doesn't drop off anymore like my other phone. Maybe there was something wrong with the antenna. I will never know...

    Sent from my SPH-L710 using Android Central Forums
    12-06-2012 11:18 AM
57 123
LINK TO POST COPIED TO CLIPBOARD