10-17-2014 07:34 AM
56 123
tools
  1. Trevor Ostrom's Avatar
    Shameless stolen from cleave @ droidforums

    forum/droid-razr-maxx/225787-not-getting-text-messages-iphones.html



    Here's what the problem is:
    Apple's iMessage essentially intercepts all "text messages" from the iPhone. It checks if the recipient has an iPhone or not. If not, it will send as a text instead of an iMessage. It seems to do a really horrible job of detecting that someone has left the iPhone world. Some of your friends phones must still think you are in Apple land.

    Heres what to do:

    Go to: https://supportprofile.apple.com/MySupportProfile.do
    Log in if not already logged in.
    Click on "edit products"
    Click on the "x" to the right of the product.
    Click "unregister"

    Hope this works.
    Mike Wood1 and footmatix like this.
    01-24-2013 12:37 AM
  2. Nathan Tawil's Avatar
    I have the same issue please help!!!
    02-06-2013 10:13 PM
  3. meyerweb#CB's Avatar
    I have the same issue please help!!!
    Seriously, did you read the posts in this thread? There are several possible solutions to the issue. If you try them all, and none work, let us know.
    02-06-2013 11:43 PM
  4. rugbymurf's Avatar
    Same thing is happening to me. At first I found that they were going to my iPad into iMessage land there. So I went into my settings there and made sure that it was set that the phone number was no longer associated with iMessage. And actually turned iMessage off completely for my iPad too. But iPhone messages are still going into the ether and not to my Galaxy in most iPhone cases. I was puzzled why a few people with iPhones could get through, but now that you said that about them turning off iMessage, that must be the difference. It's infuriating. Some people definitely think I'm ignoring them.
    02-09-2013 08:08 PM
  5. rugbymurf's Avatar
    Sorry Meyerweb, but the thread didn't initially show me all the messages. I have deleted my imessage account and the texts are still going missing. I guess I'm going to have to go through my 500 or so contacts and send messages to the 50 or so iPhone contacts I know who I really need to make the change on their end. This really is ed. It does make me mad at Apple. Although I like some aspects of their technology.

    Murf
    02-09-2013 08:22 PM
  6. Nancy MacInnis's Avatar
    I have a similar problem (unfortunately no answer). If I send a text from my SG3 to an iPhone user and they reply, the reply will go to my iPad but not to my SG3. It's a pain because sometimes I don't get the reply until much later in the day.
    03-07-2013 08:52 PM
  7. willizen's Avatar
    So some device of yours still has your phone number linked to imessage, thus when your friend tries to send you an imessage, the servers automatically route it to whatever device is still linked, as opposed to sending a text message. Make sure every imessage device you have has your phone number unlinked. You can go to settings -> imessage -> and then I think it's accounts. You should be able to unselect your cell phone number under there. Once that is done on every device you own, that should be it. You can also reset your apple ID password if none of the above works. Calling apple would be your next bet.

    I switch occasionally from an iphone to an android phone, and before I do, I always unselect my phone number in the imessage account tab from my ipad, my MBA and iphone. I do this before I switch phones just to give it a little while to propagate through the server, even though it's generally instantaneous.
    03-09-2013 10:39 AM
  8. Lisa Finney's Avatar
    One of these days I will start here to find info. My friend and I both had Iphone 4's which I used for a week and gave it to my son, then went back to my Samsung. Since then, we are not able to text each other. I sent her the info I received from here. So I don't know yet if that resolves it. However, I suspect it will. Also, before all of this, my daughter got her 1st Iphone 5. I was using my old Samsung. She would receive my tx but I didn't get hers unless she sent as a pic msg. We were able to tx each other fine of course during my week of h$() with the Iphone (I probably would have liked it if it was a 4S or 5, but the 4 was the only one free). Once I went back to the Samsung our texting was still fine. So hoping the posted info with fix things. Ya just can't NOT be able to text your bff.
    03-10-2013 12:32 AM
  9. peterthedino's Avatar
    Hey, if anyone is still having problems with this, I found a solution that worked for me:

    After sending the message from the iphone, have the sender hold down a finger on the sent message. That will bring up the option to resend it as a text message. Do this with about 3 or 4 consecutive messages and eventually the iphone will give up trying to use imessage. Hope this helped. Worked for me.
    03-10-2013 11:56 PM
  10. a_pirates_heart's Avatar
    Ok i created an account here to tell you that it works if you go to apple and deactivate your device!!! I was having the problem where all apple phone users's text messages were going to my iPad. Very annoying when 60 percent of ppl i know have one. Go to apple sign in with your apple id and deactivate your old phone. Im so happy i didnt want to have to trade in this phone and go back to iphone
    03-22-2013 08:15 PM
  11. fiddleeatworld's Avatar
    I'm not sure what the problem is, but I solve this issue by downloading GO SMS PRO on my SIII and now I can receive messages from everyone! Try it out, it works like a charm!
    04-06-2013 04:16 PM
  12. Dave78155's Avatar
    It worked. Turning iMessage off on iphone works. Thanks!
    04-30-2013 08:30 PM
  13. slittle#AC's Avatar
    Thank You Justin - worked like a charm and no one has to make changes. I had to do this with my new Galaxy 4 - weird. Sometimes I would get messages to both phones, sometimes only to one, and this happened only from my mom.
    05-02-2013 08:14 PM
  14. Linda McDougall's Avatar
    It's happening to me too! With the s4 help!!!!
    05-09-2013 10:02 AM
  15. Iamtech1's Avatar
    This works with the GS4 too just tried it with a positive result having the same issue...
    05-20-2013 02:11 AM
  16. meyerweb#CB's Avatar
    It's happening to me too! With the s4 help!!!!
    Have you read any of the posts above yours? The answer to your problem has likely already been posted.
    05-20-2013 10:30 AM
  17. Skyway Limos's Avatar
    06-03-2013 04:55 PM
  18. filoli's Avatar
    I just bought a Samsung Galaxy Centura yesterday and I can't receive texts from iphones. They can receive mine and read them and reply but I get nothing. I thought my mom had lost her mind when she said she can't text anyone with her new iphone unless they have an iphone. The only ones in the family who don't have iphones are me and my nephew. He has a Nokia so we are able to text each other. Would like this fixed. I'm not taking my phone back, because I love it. But I would like to text everyone in my contacts.
    06-10-2013 06:33 PM
  19. Kenny Kang's Avatar
    Hi, if you had an Apple ID associated with the iPhone, this solution should work; I just tried it out with my new Galaxy Note 2 and it worked. If you go to "iforgot.apple.com" you have the option of changing your Apple ID password. What this does is essentially it logs you out of your Apple ID account from all the devices that were logged in with it. After a few minutes, your Apple ID should no longer be linked with your old iPhone and texts should come through just fine. Hope this helped!
    06-17-2013 02:34 PM
  20. Krish x's Avatar
    Uh had the same issue with my iphone 5 and switching over to S4. What I did was factory reset my iphone 5 from settings as in get full reset and take out the sim card. Have the person who tried to text me before delete the branch text and start a new conversation/text with me and it went directly to my s4.

    Cheers.
    06-20-2013 08:32 PM
  21. jeffazi's Avatar
    For the win! Thanks.
    07-05-2013 04:59 PM
  22. junior gonzalez lopezzz's Avatar
    I'm having the same problem! I've even tryed using other apps and its still not working?
    07-11-2013 12:10 AM
  23. aestrada225's Avatar
    You have to have them edit your phone number on their contacts list by changing your number from iPhone to cell phone. Otherwise their phone thinks you have an iPhone.
    07-19-2013 07:27 PM
  24. ladyfran's Avatar
    I agree...I just turned it off in setttings and have had no problem now with my iPhone contacts...
    07-30-2013 03:55 PM
  25. LoriT706's Avatar
    I just had this same problem...Try this...Log into your itunes account. Go to account information, device management and remove device. This will immediately resolve your problem....good luck!
    10-09-2013 08:09 AM
56 123

Similar Threads

  1. file transfer from PC to Galaxy S3
    By tumtum83 in forum Samsung Galaxy S3
    Replies: 9
    Last Post: 05-09-2014, 04:58 PM
  2. Calendar, Contacts, etc. transfer from iPhone to Galaxy Note 2
    By rablaw in forum Samsung Galaxy Note 2
    Replies: 7
    Last Post: 08-12-2013, 09:30 PM
  3. Desiring to upgrade from iphone to Galaxy S3
    By tech_fan in forum Verizon Galaxy S III
    Replies: 13
    Last Post: 09-03-2012, 09:36 PM
  4. Replies: 3
    Last Post: 05-08-2010, 07:33 PM
LINK TO POST COPIED TO CLIPBOARD