1. mrsimps's Avatar
    As most of you probably know, Sprint allows you to use your phone number as a Google Voice (GV) number. I used GV on Sprint for the last several months. My set-up was that my Sprint number (personal number) was converted to a GV number. I then added my work phone to the set-up via the GV app, so when people called my personal number, it rang both my personal (Samsung Galaxy S3) and work (iPhone) phones.

    About a month ago, GV started getting glitchy, so I disabled it. I waited a month and reactivated Sprint GV Thursday (11.15.12). Note: during the time GV was disabled, my phone was updated to JellyBean. When I re-enabled GV, I could receive calls on my personal phone (the Sprint GS3), but I could not dial out. When I tried to dial out, I got a message stating, "We could not compete your call; please try again." However, the work phone (iPhone), which was connected through the GV app could recieve and make calls. Since my primary phone (GS3) was unable to make calls, I uninstalled GV altogether - removed it from both phones.

    A few days later (11.19.12), I re-enabled GV on my Sprint phone (GS3). Now, i can't make or receive calls. When I dial out, I still get the same message as before ("We could not compete your call; please try again") AND when I'm called, the caller hears the same message. So my phone is COMPLETELY unusable for calling. Thus, I've had to disable the Sprint GV integration again.

    I've tried to dial phone numbers as 7 digits, 10 digits, added a 1 before dialing, and attempted to call by tapping saved contacts. None of those worked. I even went into my application manager and cleared the data for GV (disabled, then re-enabled GV) and that didn't work. I've turned the phone off and pulled the battery a few times. Still nothing. I can't seem to find anything online that speaks to this scenario. I've posted on the GV forum, but thought maybe some of you had experienced this issue and could advise me.

    Primary Phone: Sprint Samsung Galaxy S3 (Model SPH-L710; Android Version 4.1.1)
    Phone connected through GV app: Verizon iPhone 4s (Model MD276LL; iPhone Version 6.0)
    11-19-2012 01:37 PM
  2. jay28w's Avatar
    Are you able to update PRL and Profile?

    I seem to remember a while back on ICS I was stuck like you described and I had Sprint send a 'activation' signal to the phone and it cleared it up.
    11-19-2012 05:03 PM
  3. mrsimps's Avatar
    I updated the profile and PRL, but that didn't help. So, I took your advice and called Sprint, explained the issue, told them that a forum member suggested an activation signal, and the rep tried to get it working, but couldn't. She finally disabled GV on her end and instructed me to get online and re-enable it. Because I was re-enabling it so soon after she disabled it, GV popped up a note that said I had to wait 15 minutes before being able to proceed. The rep said that she would call me back in 15 minutes to check on me - she even had her floor supervisor get on the call with me to confirm - but, here I sit 45 minutes later and no call. And, unfortunately, GV is still not working for me. I'll re-post if anything changes in the coming minutes, hours, or days.
    11-19-2012 09:51 PM
  4. jimt1029's Avatar
    I had issues with not receiving calls with GV a few weeks ago, so I downgraded to GV lite. I'd like to turn it back on, so hopefully they figure this out.
    11-21-2012 08:20 AM
  5. McPlot's Avatar
    I use Groove IP for internet calling, so I cannot comment there, but... After the jb update, Google voice has been crapping out on me too. It takes several minutes at times to load a 30 seconds voicemail, while on a fast wifi. Other times, out just doesn't load it. The voice to text that is IM to me it's good enough for me to know what the voicemail was about. (Free with google voice, Sprint charges for it)

    Damn auto correct. You always end up posting some thong you didn't Nintendo.
    11-21-2012 08:25 PM
  6. mrsimps's Avatar
    So, it seems that I got a "bad" install when my phone was updated to Jellybean. I reluctantly performed a factory reset over the weekend, and, to my surprise, it cleared up my GV issues, as well as enabled features I wasn't getting, such as the expandable notifications and a 5th shortcut on the lockscreen. I had heard that whenever a "major" update releases, that it's best to perform a factory reset, but I've never done that. Perhaps I will do it from now on.
    11-26-2012 11:11 AM
  7. StoppingIn's Avatar
    Sprint is the one with a problem and to me they are seemingly taking their sweet time figuring it out. The issue on GV Known issues has only been reported 26 times... Seems as though there is no rush. When I called in the tech spent an hour with me before checking this link (Google's link not Sprints) before she realized she wasn't able to help me out
    Google Voice Known issues - Google Voice Help I need my Google Voice back I just removed my number from Google Voice all together and now I can't go back until Sprint fixes the problem.
    11-29-2012 07:02 AM
  8. Doug8585's Avatar
    Identical problems, have found no resolution so far. Tried multiple factory resets to no avail.
    12-18-2012 04:44 PM

Similar Threads

  1. Google Video Chat on sprint gs3
    By navinag in forum Sprint Galaxy S III
    Replies: 9
    Last Post: 09-21-2012, 03:04 PM
  2. Replies: 0
    Last Post: 01-17-2012, 12:43 PM
  3. Verizon Google Voice Integration vs. Sprint
    By fadydizzle in forum Verizon
    Replies: 3
    Last Post: 12-15-2011, 10:24 PM
  4. Problem with Google Voice/Notification Panel
    By rosariorose9 in forum Verizon Droid Incredible
    Replies: 3
    Last Post: 11-12-2010, 07:51 PM
  5. 2.2 Froyo problem with Google Voice
    By TheMan876 in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 22
    Last Post: 07-14-2010, 03:02 PM