1. JohnnyRanz's Avatar
    So the other day my worst fear struck me again. My previous phone, an HTC EVO LTE had the same issue. I had to keep ejecting and putting back in my sd card. Finally I bought a new one and it was working fine. I got the S3 last week and it only took a week for my 3 week old memory card to act up. So I ejected it and put it back, and worked. Now since then, it happened again and now my phone doesn't recognize my sd card at all. This is my screenshot with my 3 week old sd card inserted. Please help!

    Sent from my SPH-L710 using Android Central Forums
    Attached Thumbnails SD card not showing up in storage-uploadfromtaptalk1355293339425.jpg  
    12-12-2012 01:22 AM
  2. Buddlespit's Avatar
    If you plug the card into the computer via a card reader, does the computer recognize the card? If not, then you have a card problem. If it does read it, then you have a phone problem.
    12-12-2012 06:31 AM
  3. ncwitz's Avatar
    I posted about the same problem in the general Samsung Galaxy S3 forum: http://forums.androidcentral.com/sam...ecognized.html

    * Same message about to "Mount SD card"... but nothing happens.
    * Same message with the card in another S3
    * Card does work in an external card reader attached to my PC (I was able to copy all of the data from the card to backup)
    * No option to reformat the card... it doesn't even recognize that a card is inserted.

    So... is the the card or the phone, or, in this case, two different S3s that don't see the card. This is a PNY 32 gb class 10 card. A particular problem with the S3 recognizing the PNY cards for some reason?
    12-12-2012 08:49 AM
  4. DoesItMatter's Avatar

    Might be similar issue to that user.

    If the card is being recognized in the computer - try to do a full wipe/format


    Once you backup (or looks like you've already backed up the sdcard) use that utility to completely wipe/reformat your microsd.

    Then power off the phone, insert the card, power up and see if it recognizes it.
    12-12-2012 03:47 PM
  5. JohnnyRanz's Avatar
    I put in my old sd card and it works. Looks like my 3 week old memory card is broke already ugh

    Sent from my SPH-L710 using Android Central Forums
    12-13-2012 11:57 AM
  6. jdwintx's Avatar
    Well as of today here is the answer.
    SanDisk Responsible for Malfunctioning Galaxy S3 Micro-SD Cards

    SanDisk Responsible for Malfunctioning Galaxy S3 Micro-SD Cards
    SanDisk is now claiming responsibility for Samsung Galaxy S3 issues that users complained are killing memory cards and randomly leaving users with dead batteries.
    According to SanDisk a newly documented problem that effectively fried SanDisk micro-SD cards was in fact a manufacturing default.
    Ben Chen likes this.
    03-20-2013 12:10 PM
  7. Jane Filina's Avatar
    I never installed on the SD card I thought it was installed when you purchased it so how do you make sure it is installed and how do you uninstall it
    12-13-2013 12:14 PM
  8. Jane Filina's Avatar
    this is on galaxy s3 sorry about that
    12-13-2013 12:16 PM
  9. GSDer's Avatar
    I'm not exactly sure what you're asking. Do you want to know if you already have an SD card installed IN your phone, or are you trying to determine if something is installed ON your SD card?

    If the former, you can go to Settings -> Storage and scroll down to the lower portion of the information. If you have an SD card installed in the phone it'll look something like this:If you don't have an SD card installed and you want to install one, you should power the phone off completely, (take your case off if you have one) and then take the back cover off the phone.

    Once the interior of the phone is exposed you'll find the little slot where the SD card goes - just slide it in there until you hear it click. Put the back cover on (along with your case if you have one) and power the phone on.

    When you check the Storage view again it should show the SD card information.

    Edit: this is what the Storage view looks like if you don't have an SD card installed.Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    12-13-2013 02:50 PM
  10. Khizer Abbasi's Avatar
    when i pres recovery after ther is now sd card file show
    08-11-2015 01:22 PM
  11. anmolj's Avatar
    i also have same issue. i have a quick and easy way to do this:- 1.first of all you need to copy all the data from your sd card to pc
    2.then no need to reboot or recover your phone,just go to the settings with keeping your
    sd card in the phone, my card prefference is(uhs-1,class 10 upgraded 64gb).
    3.change your phone to open usb debugging mode, after that you need to go to storage
    and erase sd card and restrat your phone again now this time your your card with empty
    storge will have an option to mount but don't do it.
    4. now power off your phone and restore all data from your pc to sc card.
    the problem will be solved.
    07-12-2016 01:43 PM

Similar Threads

  1. Replies: 5
    Last Post: 11-19-2012, 09:17 PM
  2. apps stored in sd cards not showing up
    By shinydiscopants in forum Android Apps
    Replies: 2
    Last Post: 03-15-2011, 09:50 PM
  3. Installed app not showing up in program list
    By 172av8r in forum HTC Droid Eris
    Replies: 1
    Last Post: 06-10-2010, 10:26 AM
  4. Copy protected apps not showing up in Android Market
    By jwhtc09 in forum General Help and How To
    Replies: 0
    Last Post: 11-22-2009, 05:37 PM
  5. Contact thumbnail image not showing up in gtalk app
    By mnorris12706 in forum Android Apps
    Replies: 4
    Last Post: 11-09-2009, 04:07 PM
We have updated our Privacy Policy and Terms & Conditions. Please check them out.