08-18-2018 09:47 AM
90 1234
tools
  1. Bryce Davis's Avatar
    Thank you thank you thank you. Sososososo happy you told me that
    08-21-2013 11:52 PM
  2. Low Jie's Avatar
    how to update Google play?
    08-26-2013 06:38 AM
  3. mhl080's Avatar
    This definitely worked for my S3. That was a quik step. I tried and failed clearing the cache, app data , disabling and enabling the app then restarting several times didnt worked. Reset app preference in application manager just worked.
    08-27-2013 12:57 AM
  4. RainbowBrony409's Avatar
    I am having the same problem. ..I have a Samsung galaxy s 2 epic 4g touch rooted with stock jellybean rom...and I replaced google play with the chelpus mod play store and thts wht did it for me...after I installed it..I opened it and it force closed on me..so I replace it with the original play store and tht didnt work either...so I clear data and cache..didnt work I EVEN REFLASHED MY ROM TO JELLY BEAN AND THAT DIDNT WORK...so yea..
    09-03-2013 04:20 AM
  5. macgyver71's Avatar
    Never thought I'd be saying it to a Dalek, but THANK YOU rrwoods1978! I was going batty trying to figure out why I couldn't get Play to stop closing. Solution worked perfectly.
    (I would've done the "thanked by", but I don't know how...)
    09-04-2013 06:34 PM
  6. Maverick Coltman's Avatar
    Resetting app preferences seems to work
    09-20-2013 01:49 AM
  7. Bernice Rohdenburg's Avatar
    I can't install the updated party store on my samsung galaxy s3. Also, can't install games please help.
    09-21-2013 12:21 PM
  8. Philipp Borer's Avatar
    Resetting app preferences worked for my S3 also. Thanks!
    09-30-2013 12:44 PM
  9. Ect Contreras's Avatar
    That did not work for me I had to go to settings/Google and sync my account and then delete my account and then resign in to Google and this cured my issue. No reset is needed. There is a thread that I was in that made reference to this you must all be terrible at hitting the search button!
    **This was the only thing that worked for me! Deleted my main Google Acct & then roloaded it...all is perfect again! Thx!!! **
    10-17-2013 03:49 AM
  10. Mike Nieuwland's Avatar
    this is the solution
    10-24-2013 02:54 PM
  11. PohYoung Lee's Avatar
    But is still crashing how can i fix it? Plsss help me
    11-03-2013 01:28 PM
  12. raymb1's Avatar
    Check your date and time. Reset if it's off. Ray
    11-03-2013 08:08 PM
  13. malakawaan786's Avatar
    Im new to all this blogging as its my first time, please help it will be greatly appreciated thanks in advance

    Basically my zte u791 handset i purchase from.ebay is an Android device running 2.3.5 and i resetted it, after reset google play store was not seen anywhere, it just vanished checked everywhere done.more resets.etc downloaded.external.play stores but no avail
    So need help really bad from some one who is willing to.
    Now when it loads up it says sign in.to use play store
    But forces close on me tryed rebooting.etc.but.nothing

    Thanks
    11-08-2013 07:31 AM
  14. Bill Jones3's Avatar
    I was having the same issue and going to the APP MAN.>ALL TAB>then hitting the lower left button on my screen which popped up a menu to reset all apps was the only thing that worked.
    11-08-2013 10:23 AM
  15. malakawaan786's Avatar
    No luck
    Mines shows sort apps.by name or size
    Please help
    11-08-2013 12:51 PM
  16. nicholaaaas's Avatar
    The way to fix this is go into Settings>Applications select ALL applications. Scroll the the very bottom of the list as you should see an app named "Downloads" select it, and then change it from "Disabled" to "Enabled". for some unknown reason it is getting switched to disabled. It has to be enabled for the Play Store to work.

    I've been pulling my hair out the past few days. I hate the downloads app cause it does basically nothing so I froze it. thanks so much
    11-09-2013 12:57 PM
  17. mce1281's Avatar
    "Go to settings, then Apps then menu then click "reset application preferences" should most definitely work"

    This worked perfectly! Thanks!
    11-12-2013 02:18 PM
  18. Muhammad Naqiuddin Md Nasir's Avatar
    Thank you so much. It really helps.
    11-14-2013 08:43 PM
  19. EpicDave's Avatar
    Uninstalling updates, clearing cache, and data did the trick.
    11-16-2013 02:40 PM
  20. marknie's Avatar
    I dont see download manager anywhere. Where is it? Google Play Store doesnt even show up on the app list now!!

    - - - Updated - - -

    Did not work for me!
    11-18-2013 11:26 AM
  21. marknie's Avatar
    I went to settings, there is no google in settings. Where is it? This did not work.
    11-18-2013 11:29 AM
  22. marknie's Avatar
    Fail! does not work.
    11-18-2013 11:31 AM
  23. raghu nandan1's Avatar
    thanks..worked for me
    11-25-2013 04:09 AM
  24. GSDer's Avatar
    1. go to Settings -> Application manager -> ALL, find 'Google Play Store' and select it - Clear cache, if that doesn't work Clear data, if that doesn't work Force stop; if that doesn't work Uninstall updates (restart the phone between each intermediate step)
    2. go to Settings -> Application manager -> ALL, find 'Google Services Framework' and select it - Clear data, if that doesn't work Force stop
    3. go to Settings -> Application manager -> press the Menu button -> select 'Reset app preferences'
    4. go to Settings -> Application manager -> ALL; scroll to the very bottom of the list and see if 'Downloads' is disabled - if it is, Enable it; also see if 'Google Account Manager' is disabled and if it is Enable it
    5. go to Settings, find the Accounts group, select Google, select your Gmail address then select the 'Remove account' button. Restart the phone then add your Google account back.
    6. Last is the dreaded Factory Reset - go to Settings -> Back up and reset -> Factory data reset. Be sure you've: synced your Google account; saved any pictures/videos to your computer or SD card or the cloud; saved any SMS/MMS that you care about (the Kies software is the only reliable method I've found to backup/restore MMS); saved your call logs if you care about that; backed up your application data if you want to save your game progress, etc.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    Chad Bilyeu-Clark likes this.
    11-25-2013 11:37 AM
  25. Destiny Jorgensen's Avatar
    thank you RRWOODS1978! lifesaver! errrrr tablet saver!!
    Chad Bilyeu-Clark likes this.
    02-16-2014 04:39 PM
90 1234

Similar Threads

  1. Google Play Store crashes or refuses to open
    By rxgadget in forum Google Nexus 7 Tablet (2012)
    Replies: 49
    Last Post: 05-22-2017, 01:42 PM
  2. Google Play Store crashing
    By Rithisak in forum Misc. Android Tablets
    Replies: 1
    Last Post: 09-06-2013, 04:42 PM
  3. [DUMB] Is It Possible to Move Google Play Store to sdcard?
    By XulChris in forum Optimus V Rooting, ROMs, and Hacks
    Replies: 4
    Last Post: 07-24-2012, 04:58 PM
  4. Google Play Store constantly crashing?
    By seanlongoria in forum Droid RAZR
    Replies: 2
    Last Post: 07-11-2012, 04:43 PM
  5. Google Play Store crashes after downloading any app
    By wooziemama in forum Market Help
    Replies: 0
    Last Post: 06-28-2012, 02:06 PM
LINK TO POST COPIED TO CLIPBOARD