1. Ashlynsmommy's Avatar
    Had charging port replaced and its not charging. Although plugged in battery continues to drain. I know there are battery apps and such do they help and if so what would you recommend? Very frustrated with this phone. It's my livelihood and my sole connection to the world

    Posted via Android Central App
    09-14-2013 02:56 AM
  2. meyerweb#CB's Avatar
    if it's not charging a battery app won't help. At best, they can slow the drain, but they can't add power to the battery.

    Charging problems are usually one of a few things:

    Bad charging port: it's possible the repair is faulty

    Bad charger. Any micro USB charger will work, so try a different one. Or plug the USB cable into a computer, instead of the charger

    Bad USB cable. Samsung's cables are pretty cheap. Try a different cable, both in a PC and in the charger.

    If you know someone else with an S3, try swapping batteries, but I don't that's the problem.

    If different chargers and cables don't make a difference, I think you need to take your phone back to whoever repaired it and tell them they screwed up.
    09-14-2013 02:49 PM
  3. Ashlynsmommy's Avatar
    Thank you.

    Posted via Android Central App
    09-15-2013 01:06 AM
  4. duddy23b's Avatar
    So true! in my case I had the charging port tested and the battery as well, it was the charger, for whatever reason the micro usb port would not carry a charge so had to buy a replacement one now everything is working just fine.
    09-17-2013 07:28 AM
  5. 5dadd7's Avatar
    Had the same issue, took the phone to the Sprint store and they said it was a bad USB cable. Replaced USB cables and so far so good for about 2 days.
    09-19-2013 10:38 AM
  6. Umar Farooq khattak's Avatar
    I have sky mobile 770k .....i connected a usb cable to my phone the cable was faulty and it restated my phone after that phone only charges when it is powered off.....it do not dectect charger whel it is powered on .plese tell me solution for that problem.....i shall be thankfull......
    04-22-2014 09:00 AM
  7. GSDer's Avatar
    Welcome to the forums!
    it do not dectect charger whel it is powered on
    That is most unusual - you don't see the charging icon at all? Have you tried different wall chargers and different USB cables?

    When the phone is turned off and you charge it, does it take a normal amount of time to fully charge?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-22-2014 04:00 PM
  8. Vignesh Waran4031's Avatar
    H,

    While plugging, my mobile (XOLO) getting under charging mode but battery wont get 100% charge... for 3 to 4% getting charge itll take 2 to 3 hours..

    I dont know whats the real problem.. kindly assist ........
    05-02-2014 08:30 AM
  9. Umar Farooq khattak's Avatar
    Welcome to the forums!That is most unusual - you don't see the charging icon at all? Have you tried different wall chargers and different USB cables?

    When the phone is turned off and you charge it, does it take a normal amount of time to fully charge?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    08-12-2014 10:34 AM
  10. Umar Farooq khattak's Avatar
    i have changed so many chargers ...
    when phone is off i connect charger it start charging then in that state when i turn on the phone it do charging but when phone is already in on state and i connect charger then it do not detect charger and no charging icon is shown....
    every time when i have to charge my sky 770 mobile i turn it off then connect charger ant again power it on.
    plz tell me what to do.
    08-12-2014 10:45 AM
  11. GSDer's Avatar
    when phone is off i connect charger it start charging then in that state when i turn on the phone it do charging but when phone is already in on state and i connect charger then it do not detect charger and no charging icon is shown.
    That's pretty strange. Have you tried a Factory Reset?
    Or perhaps you need to reload the firmware - I can't imagine this being a hardware problem.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    08-15-2014 10:42 PM
  12. caditya's Avatar
    That's pretty strange. Have you tried a Factory Reset?
    Or perhaps you need to reload the firmware - I can't imagine this being a hardware problem.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    .........................
    I am also having the same problem with mi I ball phone.... I does not charge end it is on and it onlyharges when it is power off... Please help some one
    . ihv just bought this phone....
    06-03-2015 02:52 AM
  13. wilburlikesmith's Avatar
    I have a S2, found this but haven't tested it yet: youtube [dot] com [slash] watch [questionmark] v [equals] yjnXcFG3674
    09-17-2015 12:19 PM
  14. Jaded1994's Avatar
    I had the exact issue described. It started out with my phone dying attached to a bad usb. It then would not charge on its stock chargers. I was reading through and someone recommended a hard reset but i dodnt see a way to do that so instead i tried a weird thing. I turned on and off airplane mode while attempting a charge and what do you know its working now.
    06-01-2017 05:42 AM

Similar Threads

  1. Replies: 10
    Last Post: 04-24-2014, 10:52 AM
  2. S4 keypad sounds not working
    By KXXTINE in forum T-Mobile Samsung Galaxy S4
    Replies: 2
    Last Post: 09-20-2013, 02:54 AM
  3. location not accurate
    By rockcandymountain in forum ViewSonic
    Replies: 4
    Last Post: 09-14-2013, 01:59 PM
  4. Unread email number not showing on gmail icon on home page
    By mcefalu in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 09-14-2013, 07:26 AM
  5. [Help] Won't turn on and charge after battery loss
    By bonsly16 in forum Sprint Galaxy S III Rooting, ROM's, and Hack's
    Replies: 0
    Last Post: 09-13-2013, 10:52 PM
LINK TO POST COPIED TO CLIPBOARD