02-27-2018 09:58 PM
30 12
  1. Larry Pasekoff's Avatar
    I suspect this is a repeat of a previous thread but I've not seen anything to actually resolve.

    I have an Sprint Galaxy S3. Android v4.3. When I open my contacts list I get the Headers but no content. It may take 1-3 minutes before this refreshes. Once I get the list selecting an individual contact repeats the delay. In some cases once I get the contact selecting "dial" repeats the process yet again.

    I've been selectively uninstalling apps to see if one of these has caused the problem. Previously when I had this issue the only advice Sprint could give me was to reset my phone to factory defaults. This worked but then the pain returns once system updates occur and apps are installed. Any suggestions? Are there any tools available the show CPU and/or memory utilization so I can see who the hogs are? This might give me a better indication of which processes are sucking up all the resources.
    04-03-2014 11:23 AM
  2. Andy Faulkner's Avatar
    Same issue here but mine is AT&T. It started happening in the last few days so I also am uninstalling recent updates. WTF. Not worth having to reinstall the entire phone every time this starts to happen
    04-29-2014 11:52 AM
  3. GSDer's Avatar
    Welcome to the forums (both of you)!

    You can start by clearing the cache in the Contacts app: go to Settings -> More (if using the Tab view) -> Application manager, scroll right to the ALL tab, scroll down until you find 'Contacts' and select it, then select the 'Clear cache' button.

    (If you're very trusting, AND you have all of your contacts synced with Google [as in, you just checked and are SURE!] you can also select 'Clear data' and then 'Force stop'.)

    Finally, you can reboot into Recovery mode and clear the system cache (this is very quick and doesn't affect your data).

    Let us know if any of that improves the performance.

    BTW, how many contacts do you have?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    04-29-2014 02:32 PM
  4. markilus's Avatar
    I have a Note 3 and it regularly freezes too when I am searching for Contacts. I believe the reason for this is that the phone is looking
    online and if the data connection is poor/the remote server busy it delays. The fix is really simple:

    a) Open Contacts till you get a list
    b) Go to Settings (left hand 'button')
    c) Turn off Online Search

    Works and the speed on Contacts is now amazing

    Good luck

    08-30-2014 05:07 AM
  5. Nadim Ghanem Pares's Avatar

    I tried find the ¨online search for contacts´ in order for me to disable it, but I did not find it anywhere on the phone.

    I am using a Note 3,

    Please advice,

    All the best,
    10-12-2014 02:23 AM
  6. Ken Clements's Avatar
    THe problem is that i am using LinkedIn as well.. and it appears to be going online to source contacts.

    should get instant results now.
    10-19-2014 11:18 PM
  7. Nilesh Shah India's Avatar
    To be honest none of this works in my case..! I am using Nexus 5 and tired with this problem.. Sometimes it takes 5 minutes to bring contact list. I selected only my gmail contacts to display so off Skype, whatsapp, linkedin etc.. but this is pathetic really. Can someone find the best solution to it ?

    11-02-2014 02:23 AM
  8. Atharkhan101's Avatar
    No, i can't locate that option. Yes I'm too having the same problem but it only happens when I'm connected to wifi. Reason behind my lag is, when i type in first few letter of name, in background it also searches contact info from my office exchange account. I unchecked the contact sync when i configured my exchange account as in my company three are lakhs of employees and i don't want their contact
    info appear when i try searching contact. This is still not sorted out. Please help me.
    03-12-2015 09:15 AM
  9. At_pandey's Avatar
    Hi Nilesh,
    I am facing same issue. When did the problem started? For me this issue started suddenly so it can't be number of contacts. Neither I synced any other app at that time. I suspect it's due to Android update. Anyone else with nexus 5 facing same issue?
    To be hqonest none of this works in my case..! I am using Nexus 5 and tired with this problem.. Sometimes it takes 5 minutes to bring contact list. I selected only my gmail contacts to display so off Skype, whatsapp, linkedin etc.. but this is pathetic really. Can someone find the best solution to it ?

    08-25-2015 05:18 AM
  10. octopusmacaw's Avatar
    The solution for me was removing the LinkedIn app...

    It spawned a whole bunch of duplicated contacts (10x at least) for each and every one of my linkedin contacts, of which I had like 1000
    So I had to delete the app, delete all my contacts, and re-sync them from google etc. but now it's working great. If you don't have all your contacts associated with a google account or something, you might want to back some up to the SD card, but be careful not to get all those duplicated LinkedIn contacts!! You can see if you have any contacts on your phone itself but looking in contacts --> settings --> contacts --> contacts to display and choosing device only. See if there are any in there. Then you can go back in and set to "All" again when you are done.

    And a side note is that my phone is going much faster than before now as well for all tasks. That LinkedIn app was a real dog, would have liked if it worked better.
    11-02-2015 11:20 AM
  11. CommodCommander's Avatar
    Confirmed. It was the Linkedin app on my phone, too.
    12-04-2015 07:21 PM
  12. xwardos's Avatar
    I'm also experiencing this issue with a Huawei G7 phone, But i tested using different profile/accounts first. For some reason, out of the x3 google accounts i have tried...it's only happening with one account. So for sure there is something different from one account to an other but not sure if it's to do with synced data like, loading of pictures or contact information. We might be blaming Android for nothing regarding this issue.
    12-28-2015 05:27 AM
  13. amila kumanayake's Avatar
    Its solved as advice after I've changed my contacts settings. I changed it from huawei cloud to gmail. Because for me huawei cloud account I had more than 30,000 contacts
    01-08-2016 03:47 AM
  14. Ahmed Ghazy1's Avatar
    I have Huawei P6 and faced this problem after upgrading to Kitkat 4.4.2.

    Contacts issue solved after uninstalling Linkedin and disabling accounts auto sync.

    Problem is Linkedin contacts were merged before with google, so still big contact list, but much faster.

    01-25-2016 06:51 AM
  15. Bilal Somu's Avatar
    Where is the Linkedin App??? Help
    01-28-2016 07:53 AM
  16. JonZuniga's Avatar
    I had the same issue...tried to wipe the cache but made no difference. I went into the call logs and did a select all then delete all my calling history and bingo...back to normal speed
    01-29-2016 10:22 AM
  17. praveen_16july's Avatar
    Thanks Mark,

    Great help, the issue resolved

    02-20-2016 05:15 AM
  18. praveen_16july's Avatar
    Thanks Ken,
    Great Help, Thanks for more detailed help.
    02-20-2016 05:17 AM
  19. GovindOjha's Avatar
    Hey Guys,

    I was facing the same problem from long time but then i Stopped the syncing of all accounts....it works for me and now my phone is working very fast


    03-05-2016 11:58 PM
  20. Ramy Diab's Avatar
    I tried this and it worked with me

    1st-Copy your contact list to your SD card.
    2nd-there is an app named contacts storage (com.android.providers.contacts), clear cash then clear data then restart the phone.
    3rd-restore your contacts from SD card and it will work fine (be aware that it may clear your calls log).
    03-23-2016 06:19 AM
  21. MarceloRio's Avatar
    This app dosen't appear at my apps list.
    And now what should I have to do?
    It still lagging........
    03-28-2016 01:43 PM
  22. LoneVoice's Avatar
    We noticed same problem on Huawei Phones running Kitkat.

    Issue may be due to email client apps (Microsoft Outlook App, Built-in eMail and Yahoo email app in our case) which were accessing the Contacts Storage, locking & overloading the Contacts Storage DB (probably with all the incoming email addresses).

    Whenever this problem arises, say once in a month, clearing of Contacts Storage data with the below steps would solve the issue for some time.
    Settings->Manage Applications->All (Tab) -> (scroll to ) Contacts Storage-> Clear Data.

    This would force re-sync and re-build the contacts from Gmail contacts which may take around an hour. Repeat the above if the problem re-appears again after a month.
    04-01-2016 05:53 AM
  23. rakesh bachhawat's Avatar
    Honestly, i have the same problem with my MI4 which is 3GB RAM , i alos have samsung s advance, samsung galaxy S5, all the android phones have same problem after some days of operation , Google should think seriously about this problem since contacts is the most used and useful feature used in a phone (for which a phone is made). more over there is no options when in contacts.
    this is really really bugging please do something google.
    06-01-2016 06:43 AM
  24. fabimar's Avatar
    This link gives you an idea of the problem (and the solution)

    I went from a 180MB size to 8MB size with following steps:

    Stop synchronization from settings/accounts/google select account and uncheck google contacts
    Go to contacts, on Contacts to show go and Select all contacts (Sim Card, Device, even Google contacts) and exported them to a file.
    I imported that file to my gmail/contacts and merge all the duplicates, I check for duplicates 2 or 3 times.
    Also browse those contacts to see if you can manually correct and erase some of them
    Then, go to settings, more, application manager, look for "contacts storage" and "contacts" apps and delete data, reboot, just in case.
    Then, go back to contacts, I deleted all possible phones left on sim or device (and check if they were on gmail contacts)
    Then, settings, accounts, google, google contacts and check to synchronize google contacts and wait and smile.
    (I left on "contacts to show" google only, I don't want to mess with device or sim cards if I have a automatic cloud back up with google)

    I hope they work for you - blessings, Fabio
    Aquila likes this.
    06-28-2016 10:18 PM
  25. derrickw7's Avatar
    For me here was the solution:

    1. Open Application Manager (from Settings)

    2. select Contacts

    3. select Permissions

    4. remove "Your Location"
    10-08-2016 10:41 AM
30 12

Similar Threads

  1. [FREE] BitKar - Your Auto Repair And Management Expert
    By akshatgoel in forum Android Apps
    Replies: 2
    Last Post: 04-04-2014, 08:16 AM
  2. WiFi and apps
    By newtda513 in forum Droid RAZR MAXX HD
    Replies: 8
    Last Post: 04-04-2014, 07:43 AM
  3. No more roaming costs for Europeans. America and Asia to follow?
    By Vsweety in forum General News & Discussion
    Replies: 0
    Last Post: 04-03-2014, 10:14 AM
  4. To do list
    By PapaBear44 in forum Samsung Galaxy S4 Active
    Replies: 1
    Last Post: 04-03-2014, 08:08 AM