1. RammerXMG's Avatar
    I know I'm not alone in having this problem looking at the reviews for this app on the Play Store and I hope an update fixes this issue. The issue is when using the Lens Blur mode the picture gets through the processing step but then when the image is being rendered the picture flashes briefly and the progress bar disappears and you are left with a normal image that you can't change the focal point or blur intensity of. I was most looking forward to updating to KitKat just to get the Google Camera for this feature and it's the one thing that isn't working. I see in the reviews that some people are having issues with panorama and photosphere as well but those are working fine for me. I got the lens blur to work a few times but 95% of the time the image fails to render. I have tried everything to try and get it to work but I'm wondering if people here are having the same issue or if they have found a method of getting it to work consistently.

    I'll tell you though when the lens blur works it's amazing. I've uploaded a few pics to DEPTHY the Lens Blur viewer and it's fascinating what you can do with these pictures as you can see below.
    Attached Thumbnails Google Camera on stock S3 w/ KitKat - Lens Blur fails to render image-watch.jpg  
    05-14-2014 02:57 PM
  2. guitarhead2000's Avatar
    I have the same issue here. Haven't found any workarounds. Stock Sprint S3. Hope it gets fixed soon.
    05-18-2014 12:30 AM
  3. thecleveralias's Avatar
    Same issue here man. GS3 with Stock KitKat on sprint.
    05-19-2014 02:53 PM
  4. dcaunce's Avatar
    Never yet got this to work on my stock S3 (Sprint). Guess i'm stuck with using the afterfocus app...
    05-21-2014 08:05 AM
  5. RammerXMG's Avatar
    The Google camera app has been updated so I tried taking photos again with lens blur after updating and it still fails most of the time but I'm able to get it to work much more often now. On my first 5 attempts with the updated app I got 2 pictures to render. I hope a future update will fix this completely as this is an awesome feature.
    05-29-2014 02:19 PM
  6. RammerXMG's Avatar
    Update: The latest update to the Google Camera app (ver. 2.3.019) that released yesterday has fixed the rendering issue for me and the lens blur function now works all the time. Yay! Thanks for fixing it Google.
    07-11-2014 10:54 AM
  7. guitarhead2000's Avatar
    Just noticed that this morning! Glad it was fixed.
    07-11-2014 11:30 AM

Similar Threads

  1. Foxfi working on Kit Kat?
    By jim2112 in forum Verizon Samsung Galaxy Note 3
    Replies: 9
    Last Post: 05-22-2014, 03:10 PM
  2. Who's going to tap and pay first with Google Wallet?
    By jim2112 in forum Verizon Samsung Galaxy Note 3
    Replies: 6
    Last Post: 05-15-2014, 05:31 PM
  3. Asus MeMo Pad HD7 apps to sd card
    By alb28 in forum General Help and How To
    Replies: 0
    Last Post: 05-14-2014, 02:54 PM
  4. "Watching OTA" on my lock screen
    By bhorinek in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 05-14-2014, 02:52 PM
  5. Copyright policy on Google Play - Help!
    By kostko in forum Google Play Store
    Replies: 0
    Last Post: 05-14-2014, 02:39 PM