1. jerryinWA's Avatar
    I wanted to return my Boost Galaxy S3 to stock prior to selling it. This phone worked perfect until I started fiddling with roms again. Now I can't do anything at all. I know I caused this and the hardware is perfectly fine.

    I think what ultimately caused this was when I used CWM to install Philz Touch from a zip on the sdcard. Immediately afterward my phone exhibited this new, completely unusable state it's in.

    Current Phone status:
    --Won't power on. Nothing at all happens. No buzz, no logo. Nothing. (I have tried 3 batteries, all 80%+ charged)
    --Won't enter Download Mode (Home, -Vol, Power)
    --Won't enter Recovery Mode (Home, +Vol, Power)
    --On PC, Odin doesn't see the phone (obviously) and Kies doesn't see it either. (using various cords and directly to back of PC)
    --Plugged into PC will cause red light on phone to illuminate (even without battery). Plugged into wall power, the LED does nothing.
    --Tried flicking the phone body around the power button (as I saw a common issue is it gets stuck)

    So here's how I got to this point:
    I rooted my phone years ago and upgraded the stock Boost to CyanogenMod and then I got lazy and left it that way for two years.
    I recently planned to switch carriers so this Galaxy S3 was going to be sold at some point.
    While looking for stock roms I found the CM13 Marshmallow 6.0 rom and got it running (while this phone was still active on Boost service).
    Everything worked except for data (no 3g/4g signal). I decide to try some modem rom files which bricked the phone/text service completely and eventually my phone got soft-bricked.
    All of the roms I had in archive kept failing during installation (Odin or through recovery mode)
    I found/used a one-click Odin recovery rom and restored phone to 4.4.2 stock. Only thing was it was a Sprint rom. I decided I should try for a Boost rom. (I should have used Kies but didn't)
    I found one but it kept failing while installing through CWM. The instructions called for using Philz Touch so that's when I got the zipfile and installed Philz Touch using CWM.

    Now, here I am with a nice paperweight.

    I have tried removing the battery and holding in the power button for 30+ seconds to de-energize anything left in phone. Doesn't help.

    I'm open to any crazy ideas now.

    Phone Model: SPH-L710
    Samsung Galaxy S3 16GB

    (re-posted here from another forum)
    02-21-2016 10:24 AM

Similar Threads

  1. Replies: 74
    Last Post: 03-01-2016, 02:45 PM
  2. Outlook won't sync Google account
    By Atticus242 in forum Samsung Galaxy Note 5
    Replies: 4
    Last Post: 02-21-2016, 11:59 PM
  3. My emails wont download - why?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-21-2016, 10:39 AM
  4. Replies: 0
    Last Post: 02-21-2016, 10:12 AM
  5. GS3 won't power on, won't enter download or recovery modes (right after installing Philz)
    By jerryinWA in forum Samsung Galaxy S3 Rooting, ROMs, & Hacks
    Replies: 0
    Last Post: 02-21-2016, 09:24 AM
LINK TO POST COPIED TO CLIPBOARD