10-23-2013 08:25 PM
39 12
  1. flpalazzojr's Avatar
    I spent 6 or 7 hours last night trying to unroot my One. I found a 1.29.651.10 RUU but when using the HTC ROM Update Utility, I get error 140 saying something like "image version does not match", because I'm basically trying to go from image version to an older version, 1.29.651.10. I desperately need an executable file with RUU image version!!!! Does anyone have any idea where to find this, know when it might be released, or have any other methods of unrooting the Sprint One? Any help would be much appreciated, thanks in advance!

    Posted via Android Central App
    10-03-2013 08:39 AM
  2. Redchong's Avatar
    I encountered the same issue. Get s-off on your One. Qbking77 on YouTube has a great tutorial on how to do so. Once this is done as long as the RUU, regardless of the version, is associated with the same carrier as you have then you can use it. I did so and then upgraded to 4.3 just fine
    10-03-2013 03:57 PM
  3. JKruesi's Avatar
    I'm having the exact same issue. Any help would be greatly appreciated.
    10-03-2013 05:59 PM
  4. flpalazzojr's Avatar
    turning s-off with qbking's recone method worked flawlessly - well, almost - if after you enter chmod 755 in the terminal emulator, it says "file or directory not found" or whatever, just go to the file in the data/local/temp locations and rename it if it still has the .bin extension on it. so to be clear, rename from revone.bin to revone, then try commands again in the terminal. other than that, everything is working flawlessly. last night i actually flashed an old version of the stock sense rom (1.29.651.10) to try to get thr rom update utility to match correct versions, and as a result, after turning s-off with revone, had to update to 1.31, and now i'm in the process of updating to 4.3. in fact, it just finished booting up to 4.3 as i was typing this. THANKS REDCHONG!!!! I could have avoided all of this last night cause i started using revone and hit the chmod 755 directory issue and bailed on it, not thinking that would have been the issue. thanks again!!!!
    10-03-2013 06:16 PM
  5. flpalazzojr's Avatar
    @JKruesi, just follow qbking youtube video for turning s-off with revone, then use his unroot/unbrick htc one video. that should work. if you have any problems, just ask, we can probably help.
    10-03-2013 06:17 PM
  6. mmednick1's Avatar
    I unrooted my one following directions on YouTube. It now says relocked. It's a stock rom. Does anyone know if I will still get ota updates?

    Sent from my HTC One using AC Forums mobile app
    10-03-2013 06:21 PM
  7. flpalazzojr's Avatar
    that's fine if it says relocked. mine did when i updated.
    10-03-2013 07:13 PM
  8. flpalazzojr's Avatar
    it will not affect anything. no worries. once it was relocked, htc was aware that you unlocked your phone, but thats all, its fine.
    10-03-2013 07:17 PM
  9. mmednick1's Avatar
    Thanks for the info

    Sent from my HTC One using AC Forums mobile app
    10-03-2013 08:31 PM
  10. Redchong's Avatar
    Everything is working fine but should I be worried that my phone is still unlocked?

    Posted via Android Central App
    10-05-2013 03:02 AM
  11. flpalazzojr's Avatar
    I guess not if you've done the update and everything is working fine.

    Posted via Android Central App
    10-05-2013 11:43 AM
  12. jcperkins12's Avatar
    So I have gained S-off using revone and then tried running the RUU for the Sprint HTC one. This should fix any issues with not having the right 1.31.651.2 RUU, but the 1.29.651.10 RUU still won't complete the unroot. It gets to the "sending .... Updating the ROM image on your Android" step and then never finishes sending the files to my phone. I've tried running it overnight to give it more time, but it never completes the step. All of my fastboot and adb commands have worked so far, any ideas on why the RUU won't work?
    10-06-2013 04:06 PM
  13. Redchong's Avatar
    I'll look into your problem. Don't worry we will get you 4.3 one way or another lol

    Posted via Android Central App
    10-06-2013 06:50 PM
  14. Redchong's Avatar
    First thing is first. Make sure that you have got s-off correctly on your phone. Also I uprooted my phone before I used the RUU.

    Posted via Android Central App
    10-06-2013 09:03 PM
  15. javisuhfiks's Avatar
    I totally need help! I had the same problem as the OP however, I made it worse. Keeping it short, basically my Sprint HTC One has no rom installed in it now. I have installed and uninstalled HTC drivers over and over but the main driver needed to connect my phone so ADB and my laptop to recognize it wont install, it wont install the MTP USB driver. So when I try to run ADB it wont recognize the device, so I cant side load anything. I am running windows 7 64bit. I am able to get into fastboot and TWRP recovery but it is useless because I cant do anything. The weird thing is when I am in fastboot and connect my phone with the usb cable it goes to fastboot usb, so that should mean it is being recognized, right? Any help would be appreciated! I have this phone and not being able to use is sucks.
    Other things I messed up on is that internal memory was wiped so all recoveries are gone and I did not save any on my laptop.
    Other info:
    Bootloader is unlock
    HBOOT- 1.44.0000
    10-06-2013 11:41 PM
  16. Paul627g's Avatar
    I too am running Windows 7 64 bit. Didn't have any problems getting it to install all drivers properly. Try uninstalling the drivers, then install without the phone plugged in. Once that is complete then plug in the phone and let it install. You may have to try different ports until you find one that wants to work right. Out of 4 ports on my laptop only 1 would for me.

    I can also verify the 1.29 RUU works. I just did it last night S OFF and had no problems.

    I think you get the drivers installed correctly it will resolve the problems.

    Sent from my HTCONE using AC Forums mobile app
    10-06-2013 11:58 PM
  17. Redchong's Avatar
    Javi I had the same issue. I can get your phone back. Watch this video:

    I know it appears to have nothing to do with your problem but just trust me it will get your phone up and running again. Just follow the video.

    Posted via Android Central App
    10-07-2013 01:08 AM
  18. benny3's Avatar
    Paul is right , uninstall all drivers and any related softwae like HTC Sync. Leave the phone unplugged and install the driver package im attaching with this post. after they the install put the phone in fastbboot then plug it in let them install. the unplug and enter recovery and plug it back in and let them install.

    HTC Driver Package
    Paul627g likes this.
    10-07-2013 07:00 AM
  19. MartialText's Avatar
    Had the same issue and was beating my head on the table (need that 4.3 love!). First I thought it was my recovery because TWRP couldn't even find the update. I switched to Clockwork, and while it could find the update, I got the error code. After numerous unsuccessful attempts trying to figure it out, I used the revone method (Qbking77) to get s-off, then was able to run 1.29.651.10 RUU. Upon rebooting, phone immediately downloaded 1.31.612.2, then downloaded the the 4.3 update flawlessly.
    10-07-2013 08:49 AM
  20. jcperkins12's Avatar
    First thing is first. Make sure that you have got s-off correctly on your phone. Also I uprooted my phone before I used the RUU.
    Is there a good way to check that I have gained s-off correctly? It says s-off of my fastboot screen on my phone and I checked a couple youtube videos. I don't think I missed any steps. I had the same issue with the RUU before I gained s-off. It never finished sending the files, and I thought it was because of the 1.31 to 1.29 incompatibility. I've checked a couple other threads and regalpimpin on a xda forum said there were problems with a security warning interfering with the process but I don't have that security warning flag on my fastboot screen.

    I've never seen the term uprooted? rooted and unrooted I'm familiar with. I'm kind of an "inadvertent developer" after i washed my stock phone and bought a rooted phone to replace it, what is uprooting?
    10-07-2013 09:10 AM
  21. Paul627g's Avatar
    Is there a good way to check that I have gained s-off correctly?
    I'm sure there maybe a more " technical " way by means of running code or something that verifies S OFF but if your bootloader is showing S OFF then I assume you have achieved your goal.

    I followed QB King's instructions myself and using Terminal Emulator worked flawlessly.
    10-07-2013 09:14 AM
  22. jcperkins12's Avatar
    Ok so I have re-installed all of my drivers and I have the same problem. Here's a new development though which is confusing me. I flashed back to the stock rom and I'm not receiving ota updates because I have TWRP recovery which makes sense. I tried to flash a stock recovery to try to fix this and get back to 1.31 but I ran into the same problem trying to flash a recovery as i did trying to run the RUU. Here is what I get when I try to flash a recovery file:

    C:\android-sdk\platform-tools>fastboot flash recovery recovery_Stock_HTCone.img
    sending 'recovery' (9586 KB)...

    Which is the same result that I get when I try to run the rom.zip from the RUU in the cmd prompt or run the .exe. It will stick on "sending" all night if I let it. Any Ideas? I tried reformatting my phone and it still won't get through. I lock the bootloader for the RUU and unlock for the recovery.
    10-07-2013 12:23 PM
  23. Paul627g's Avatar
    Hmm... That is weird..

    I know you don't have to lock the bootloader to run the RUU. I left my bootloader unlocked to RUU back to 1.29 to reset my device from a problematic update to 4.3.

    Strange thing too is having TWRP on there shouldn't stop you from getting the OTA notification. I was running 1.31, rooted w/S OFF and still receiving the OTA notification to update to 4.3
    10-07-2013 01:16 PM
  24. jcperkins12's Avatar
    my phone says that the OTA update 1.31 is corrupted which I thought meant that I needed the stock recovery as well. I flashed the deodexed 1.29.651.10 rom earlier. Should I have flashed the odexed instead? My biggest concern is getting those automatic updates with the stock ROM
    10-07-2013 01:34 PM
  25. javisuhfiks's Avatar
    Thanks for the response however, it did not work. I tried uninstalling HTC drivers and reinstalling while trying each usb port, I have 3 ports, and none of them worked. The drivers install except for HTC MTP DEVICE driver which is the one that allows one to access the storage on the phone. Like I said before, I have no operating system in my phone, when I boot up my phone it stays on the HTC quietly brillant screen.
    I tried running the 1.29 RUU and it goes through but I forgot to mention that before all this happened I had a android 4.3 version, so that is a 1.31 RUU. So when I run the 1.29 RUU it ends up with an error because it is not the correct software.
    So thats where I stand, I cannot access the storage on the phone because the driver is not installing correctly for some reason. So no ADB, i can't get s-off or anything. If I can get my laptop to finally read the phone's storage then I can fix the phone but for now it is stuck.
    Does anyone have or know where I can access a 1.31 RUU exe file? It is either finding that file or try to find a way to make my phone connect. Any more suggestions?
    10-07-2013 10:47 PM
39 12

Similar Threads

  1. Someone please help! Htc one sprint unlocked
    By NikolasAmicone in forum HTC One M7
    Replies: 5
    Last Post: 11-07-2013, 08:29 AM
  2. How to get a software update on HTC DNA using non-Verizon carrier
    By ferrarl in forum General Help and How To
    Replies: 5
    Last Post: 10-04-2013, 12:59 PM
  3. Replies: 4
    Last Post: 10-04-2013, 04:16 AM
  4. The Note 3 Is Going to be my first real phone
    By Dullahan_Lover in forum Samsung Galaxy Note 3
    Replies: 8
    Last Post: 10-03-2013, 10:22 AM
  5. Sprint HTC One - Flashing RUU through bootloader! HELP!
    By cowkong in forum Sprint HTC One
    Replies: 1
    Last Post: 10-03-2013, 10:05 AM