1. WillDaBeast509's Avatar
    I messed up my build.prop (if anybody read my recent thread) and I have flashed clockworkmod recovery so I can mount USB storage. I couldn't figure out how to fix it with my computer (if anybody can help me do that it would probably help my issue) but I was thinking if I formatted system from recovery if it would restore it to the original. Will it? Or will I end up with even more of a brick than I already have?
    07-05-2012 08:53 PM
  2. piizzadude's Avatar
    bigger brick. You would wipe the rom out I believe. Why don't you find a rom, extract the build.prop from it, then push it to your phone via adb?
    WillDaBeast509 likes this.
    07-05-2012 09:03 PM
  3. WillDaBeast509's Avatar
    I have the original build.prop, I tried to move it into the system folder with android commander but no dice with that.
    I just tried the adb thing, when I type adb devices into the cmd prompt I get 'adb is not a valid command' or something to that effect. I know I have the drivers, I needed them to root. What's the problem?
    Also, if you could step me through the commands I would use to push the build.prop to the phone, that would be great. I've no idea what I'm doing, really.
    07-05-2012 09:32 PM
  4. Paul627g's Avatar
    adb push build.prop/system

    That should do the trick... I'll admit my adb is a bit rusty but that should work...

    Just make sure your device is booted to your boot loader at least.

    Sent from my Nexus S 4G using Android Central Forums
    WillDaBeast509 likes this.
    07-05-2012 09:55 PM
  5. WillDaBeast509's Avatar
    I think I'm supposed to do this from the windows command prompt, right? I typed that in and it gives me:
    'adb' is not recognized as an internal or external command,
    operable probram or batch file

    What do I do?
    07-05-2012 10:13 PM
  6. Paul627g's Avatar
    You have adb on your computer correct? Open a command prompt from within the same folder as your adb with that build.prop file included and try that command.

    Sent from my Nexus S 4G using Android Central Forums
    WillDaBeast509 likes this.
    07-05-2012 10:15 PM
  7. WillDaBeast509's Avatar
    Okay, okay, I typed in what you said and pushed the build.prop to my phone, the command prompt showed a bunch of stuff. I rebooted the phone and still nothing. Anything else?
    07-05-2012 10:33 PM
  8. WillDaBeast509's Avatar
    I think what its doing is showing me the avaliable commands for adb, which I take to mean the command I put in isn't valid.
    07-05-2012 10:49 PM
  9. pitmasterme's Avatar
    I'm probably wrong, or miss understand the problem, but why not just do a dirty flash of the rom you are running or flash another from?

    WillDaBeast509 likes this.
    07-05-2012 11:15 PM
  10. jstntp's Avatar
    Paul is correct except you need a space after build.prop.

    adb remount
    adb push build.prop /system/
    WillDaBeast509 likes this.
    07-05-2012 11:42 PM
  11. WillDaBeast509's Avatar
    I've gotten my phone to come up when I use 'adb devices.' It shows its connected in recovery, which it is. When I tried to type in 'adb remount' it says 'remount failed: unknown error 0.' I tried to use jstntp's push command, which it says was successful, but when I reboot my phone it still doesn't work. I tried to pull the build.prop from my phone with the command

    adb pull /system/build.prop /c:/

    but it says that 'remote object 'build.prop' does not exist.'
    07-06-2012 10:04 AM
  12. WillDaBeast509's Avatar
    Okay I got it!!!!!!!!!
    What I had to do was mount /system from recovery, then pushed the build.prop and it apparently worked!
    Thank you guys sooooo much for the help, I would still have a brick without you
    07-06-2012 10:21 AM
  13. jstntp's Avatar
    Great news! Yeah kinda forgot to mention that if doing it from recovery, lol. I was thinking about running my listed commands while booting (or trying to boot). Anyway, glad you figured it out!
    07-06-2012 02:31 PM
  14. Jamil Firdaus's Avatar
    can you give me a tutorial ?
    I accidently did the same thing as you on my Galaxy s plus , i hit the format/system . now its stuck in CWM-based Recovery v5.5.0.4 . please help me !
    Is my phone a goner ?
    02-28-2013 12:56 PM
  15. rodya234's Avatar
    If you have a backup in CWM just restore it. If not:

    1. Download a ROM (for your phone....) on your computer.
    2. Mount USB Storage in CWM and move the ROM from your PC to your phone.
    3. Install the ROM in CWM.
    4. Reboot.

    Once you confirm the ROM is working, go back to CWM and back it up.
    03-02-2013 02:47 PM
  16. Nitinsgupta193's Avatar
    I m unable to restore my backup on ubislate7c+. When i click on restore the process strts n then after few seconds erorr formating system this error appears i even tried to flash rom using flashtool then too upgrade fails such error appears any help plzz
    05-08-2015 10:14 PM
  17. Giovanni Derrick's Avatar
    I need help i think my tablet is a goner OK I hit the format /system on my alcatel onetouch pop 7 and now i can get into my recovery, boot-loader, and it has no roms for it ;(. What to do?
    08-12-2015 12:34 AM