1. philbw's Avatar
    Hey Everybody,

    My Nexus S 4G has been unusable for a few days now and I need some help diagnosing the problem and determining if it can even be fixed.

    What happened: I was running jstntp's Android 4.1.1 rom (ver 2.0). I liked the performance of version 1.2 a little better so I went back to it. Being 1.2 didn't have wifi tethering enabled I figured I'd try a 3rd party wifi tethering app just to see if it'd work (I can't remember the name of it). After install my phone rebooted itself (looking like a crash) and went into an immediate boot loop. I quickly booted to recovery and tried simply reinstalling 1.2. That failed. So I tried restoring a nandroid backup. That failed too.

    What i've tried to fix it: I have tried flashing (via fastboot) stock gingerbread, stock ics, google's official stock gingerbread, google's official stock ics, sprint's official ics via odin, and a half a dozen different 3rd party roms such as some bugless beast roms that I have used in the past. The stock images all appear to flash fine with no complaints from installers. Even odin installed and displayed it's "passed" message.

    Where it gets weird: In all of my recovery efforts I noticed a strange occurance happening. Everytime I would load something to the "sdcard" (whether it be by mounting in cwm or pushing through adb) it would appear in cwm while it was booted there (yet fail to install anything) and would disapear as soon as I booted out of cwm. Also, if I deleted any files while mounted (or deleted from adb shell for that matter) they would reappear after rebooting. At this point I figured the root of all of my problems is that my "sdcard" partition has a problem and needs to be fixed.

    How i've tried to fix the "sdcard" partition:
    - Chose to format /sdcard in cwm recovery. It said it was successful but didn't do anything at all
    - Chose to format /sdcard in twrp recovery. It said "E:tw_format_rmfr: unable to locate volume for device "/dev/block/mmcblk0p3" "
    - Did fastboot erase media
    - Locked the device and unlocked it again agreeing to wipe all data (nothing got deleted)
    - Pushed busybox over adb and ran mkfs.vfat on /dev/block/mmcblk0p3. It didn't complain and said it was successful. (still nothing deleted)

    At this point I'm really at a loss. I will do anything to get this to boot. I don't care what version of Android I wind up on, I don't care that I have to lose all of the stuff on my "sdcard" (it's all backed up anyway). Just having a working phone would be great.

    Thanks in advance,
    - Phil -
    08-16-2012 01:17 AM
  2. mattg67's Avatar
    I hate to tell you this but it sounds like you have a brick. I had the same thing happen to me about 2 months or so ago, from what I could gather it was bad nand chip. Do some googleing and see if you find the same conclusion. Good luck.
    08-16-2012 06:53 AM
  3. Keyon Thomas's Avatar
    Did you ever figure this out I have been going through the same problem for the past few days.
    01-23-2013 10:25 AM
  4. philbw's Avatar
    Wow, old post. Don't even have my Nexus S anymore. So I've got some bad news for you. I was instructed to take my phone to the main sprint repair store in my area and the guy put the thing through its paces. Tried every form of recovery imaginable. When all was said and done he determined that the flash chip has physically failed. The good news is that because it was a hardware failure and I pay for TEP I was able to have it replaced for free. Unfortunately they didn't have anymore Nexus S's in stock so I ended up running on an old phone for a week until they did. It was that or take an original Evo. Good luck!
    01-23-2013 11:05 AM