1. dj2big's Avatar
    I was getting cut off sometimes while online. This fix worked for me. Under wifi setting click menu, advance, wifi sleep settings click never.

    Now I never get cut off :-)

    Sent from my Nexus S 4G using Tapatalk
    HipHopSince1980 likes this.
    08-04-2011 08:28 AM
  2. tyrelian's Avatar
    I just tried it, works great

    Sent from my Nexus S 4G using Tapatalk
    08-04-2011 08:46 AM
  3. LeaninBack916's Avatar
    I am going to try this one. Good technique. Didnt realize there was an advanced menu on that screen. +1

    I just worked with Sprint Tech support. This guy who sounded highly intelligent at Sprint Tech (level 3 supervisor) stated that this phone in fact has a horrible radio and went on for 5 minutes that Sprint is working with them. He however, told me to change my network to Home Only. It wasn't a fix but its a workaround that has proven successful for many people. Places in low area would still continue to have a bit of an issue. I will try these and hopefully it will at least let me get a good connection. All I want is a stable 3G connection that loads relatively quick and phone reception that doesn't cut out. Here's to hope and change *Obama voice* *raises a fist*
    08-04-2011 10:05 AM
  4. bjones521's Avatar
    I am going to try this one. Good technique. Didnt realize there was an advanced menu on that screen. +1

    I just worked with Sprint Tech support. This guy who sounded highly intelligent at Sprint Tech (level 3 supervisor) stated that this phone in fact has a horrible radio and went on for 5 minutes that Sprint is working with them. He however, told me to change my network to Home Only. It wasn't a fix but its a workaround that has proven successful for many people. Places in low area would still continue to have a bit of an issue. I will try these and hopefully it will at least let me get a good connection. All I want is a stable 3G connection that loads relatively quick and phone reception that doesn't cut out. Here's to hope and change *Obama voice* *raises a fist*
    How did you change your network to home only? Dont you mean roaming?
    08-04-2011 11:50 AM
  5. chud's Avatar
    How did you change your network to home only? Dont you mean roaming?
    Settings, Wireless and Network, Mobile Networks, System Select.
    08-04-2011 12:00 PM
  6. goitsme48's Avatar
    This has definitely improved my wi-fi connection... thanks for the tip.
    08-04-2011 01:42 PM
  7. bjones521's Avatar
    Settings, Wireless and Network, Mobile Networks, System Select.

    Do you guys have data roaming checked??
    08-04-2011 02:32 PM
  8. 6tr6tr's Avatar
    Yeah. I already had this because I set my screen to turn off real fast to save battery life (since the screen sucks it up fast) so I knew I needed to leave wifi on always.
    08-04-2011 02:42 PM
  9. BlackHawkA4's Avatar
    Wait, all these people didn't know about wifi never sleep....

    Could this be a majority of wifi issues reported, lol.
    08-04-2011 02:42 PM
  10. HipHopSince1980's Avatar
    Thanks for the tip....its definitely helped!!!!
    08-04-2011 03:30 PM
  11. chud's Avatar
    Do you guys have data roaming checked??
    I have it checked but I rarely roam so I'm not worried about overuse. Would rather have more consistent coverage.

    Wait, all these people didn't know about wifi never sleep....

    Could this be a majority of wifi issues reported, lol.
    Ha, good point.
    08-04-2011 03:41 PM
  12. LeaninBack916's Avatar
    How did you change your network to home only? Dont you mean roaming?
    No, you change it to Home Only. Settings -> Wireless & Networks -> Mobile Networks (bottom option) -> System Select and 3 options appear. There is Automatic, Affiliated Networks, and Home Only. Home only will only look at Sprint towers. So far so go here. I still checked all the boxes for roaming regardless just because hahaha. But.. as of when I did that this morning. I haven't had any 'waiting for coverage' (Pandora/Tweetcaster error) or hang ups when downloading anything yet. We shall see though, I especially want to see if this wifi change fixes my problem at home. The connection is low in my room so it drops in and out. If it were to hold a connection at low and work, id actually be very happy.

    Again its not a fix, its a workaround as this shouldn't be needed. However, I got the phone for 50 bucks almost 3 months ago and the hardware is beastly (minus the radio)
    08-04-2011 04:25 PM
  13. bjones521's Avatar
    Darn...i really wish this fix worked for me!
    08-04-2011 05:38 PM
  14. bjones521's Avatar
    No, you change it to Home Only. Settings -> Wireless & Networks -> Mobile Networks (bottom option) -> System Select and 3 options appear. There is Automatic, Affiliated Networks, and Home Only. Home only will only look at Sprint towers. So far so go here. I still checked all the boxes for roaming regardless just because hahaha. But.. as of when I did that this morning. I haven't had any 'waiting for coverage' (Pandora/Tweetcaster error) or hang ups when downloading anything yet. We shall see though, I especially want to see if this wifi change fixes my problem at home. The connection is low in my room so it drops in and out. If it were to hold a connection at low and work, id actually be very happy.

    Again its not a fix, its a workaround as this shouldn't be needed. However, I got the phone for 50 bucks almost 3 months ago and the hardware is beastly (minus the radio)
    I don't have 3 options. i only have two. home and auto. is that a problem?
    08-04-2011 05:51 PM
  15. chud's Avatar
    I don't have 3 options. i only have two. home and auto. is that a problem?
    This is one of the last things I'd be worried about. Do you really want to be roaming all the time as a fix for your issue? Go back to 2.3.4, try it out for a bit, and then go back to 2.3.5 again. Things can get wacky during the update process.
    08-04-2011 06:03 PM
  16. dj2big's Avatar
    My fix is for people having strictly wifi issues not 3G or 4G issues.

    Sent from my Nexus S 4G using Tapatalk
    08-05-2011 06:56 AM
  17. dj2big's Avatar
    I am going to try this one. Good technique. Didnt realize there was an advanced menu on that screen. +1

    I just worked with Sprint Tech support. This guy who sounded highly intelligent at Sprint Tech (level 3 supervisor) stated that this phone in fact has a horrible radio and went on for 5 minutes that Sprint is working with them. He however, told me to change my network to Home Only. It wasn't a fix but its a workaround that has proven successful for many people. Places in low area would still continue to have a bit of an issue. I will try these and hopefully it will at least let me get a good connection. All I want is a stable 3G connection that loads relatively quick and phone reception that doesn't cut out. Here's to hope and change *Obama voice* *raises a fist*
    I didn't know there was an option for wifi never sleep. I was trying to figure out why it would always cut off my chess games playing online.

    Sent from my Nexus S 4G using Tapatalk
    08-05-2011 06:58 AM
  18. gabbott's Avatar
    Wait, all these people didn't know about wifi never sleep....

    Could this be a majority of wifi issues reported, lol.
    I kind of wondered the same thing. It's the first thing I did on my phone as it can improve battery life also. I've mentioned it a few times.
    08-05-2011 08:49 AM
  19. LeaninBack916's Avatar
    Just an update for anyone interested. This has dramatically fixed the drop issue. I have only seen it 'drop' or a no data connection 2 times this weekend. The radio signal still isnt the best but this is way better. Between that and the Home only option for 3g/Voice, I am actually happy. Hardly an issue for 3g now too. At least for me personally after applying these two things. I am glad I stumbled upon this thread.

    Also, I purchased the Roam only app so if I happen to be driving away from Sacramento and some rural area isnt covered (most are though) I can just turn it on.

    Anyways, good luck to everyone trying things with their NS4Gs. As I keep saying, the phone is beastly, just wish they would have thrown the money into better radio hardware (I dont think its software personally).
    08-07-2011 05:25 PM
  20. lily princess's Avatar
    when i turn on wifi and then they ask for web i give the key n it starts coneccting but says looking for ip adress obtaining but not coneccting any idea plz help............
    06-07-2012 12:59 AM
  21. lily princess's Avatar
    sorry i mean WEP it says obtaining IP adress.... but not conecting plz helppppppppppppp
    06-07-2012 01:01 AM
LINK TO POST COPIED TO CLIPBOARD