1. hjmatt30's Avatar
    I am trying to connect the Dual XGPS150 to my Nexus S running 2.3.7. I have followed all the instructions the device is paired but when I go to connect it using the app Dual suggested, Bluetooth GPS, I get a connection refused error.

    I tried another app and got the same error. I tried calling their so called tech support and that was a waste.

    Does anybody have any suggestions?

    Will the GNS 5870 MFI work instead?

    Thanks in advance for any help.
    11-02-2011 06:26 PM
  2. 1spankdawg's Avatar
    Have you been able to resolve the "connection refused" error on the android device? I am having the same issue.
    02-26-2012 09:30 PM
  3. Zed729's Avatar
    The same issue for me: XGPS150A + Samsung Galaxy Tab 10.1

    Devices are paired (from tablet side, is seen in BT neighborhood incl. its unique serial #), Bluetooth GPS app installed and running, "Allow mock locations" is on in both the device setting as well as in the Bluetooth GPS app.

    When trying to connect the Bluetooth GPS app says "Connection refused".

    Whether internal Tab GPS is on or off has no effect.

    Any luck anyone?
    06-23-2012 08:45 AM
  4. barrelrollololol's Avatar
    I recently purchased the xgps 150 oct 11, 2012 for my android tablet and got connection refused also. This is what I did to get it fixed.

    I have the Toshiba Excite 10 tablet running android 4.0.3 (ice cream sandwich)
    and using "Bluetooth GPS" app version 1.0

    -Make sure the white mode switch near the usb connection on the XGPS is flipped to the left
    -Go download "Bluetooth GPS" by "GooGoo Android" in the app store
    -Go to your android settings in the developer option and enable mock location
    -Turn on the XGPS, then turn on your tablet/phone bluetooth and pair it up with the XGPS
    -Turn on your android GPS (some apps complain that GPS is not on and closes the program, android GPS is on but the program should use the XGPS)
    -Launch "Bluetooth GPS" and enable mock provider option
    -Go into settings of "Bluetooth GPS" and you'll have to play around under "Connection Problems Related". There are three options:
    *Use insecure connection
    *Connection workaround
    *Other workaround

    For my tablet to connect to XGPS I had to enable "Use insecure connection" and "Other workaround". For you and other people will probably have play around and see what combination will allow you to connect to XGPS.

    If after doing all possible combination and still not connecting then trying contacting developer for a fix or return the XGPS and get a different one. usglobalsat makes bluetooth gps.

    I also have Samsung Captivate Glide phone running android 2.3.6 and was able to connect to XGPS. I did not have to enable any options under "Connection Problems Related". Everything worked smoothly on my Glide.
    jmiked likes this.
    10-12-2012 05:49 PM
LINK TO POST COPIED TO CLIPBOARD