1. dedeandmaddog's Avatar
    Please help, for some reason last week my NS4G disconnected from my home wifi and I cannot get it reconnected. My phone will connect to my work Wifi and random wifi networks (Starbucks, my gym's, etc) but when at home it scans, attempts to connect, establishes connection then disconnects and then it repeats. obviously this is a huge battery drain when I am home so I end up turning wifi off. I have reset my home router, but that did not help, I have forgot my home network on my NS4G and tried to re-establish a connection but same problem. any help would be greatly appreciated.

    thanks,
    01-28-2012 01:07 PM
  2. skinneejay's Avatar
    Have you pulled the battery from your phone? Have you pulled the power cord from your modem and wireless router? I know sometimes when I first turn on my modem and router I have to replug in to get a connection. Weird I know.

    Sent from my Nexus S 4G
    01-28-2012 03:08 PM
  3. dedeandmaddog's Avatar
    Yes, I have. the only thing i have not done is reset my phone, not sure if that would help or not and I dont really want to go to that extreme.
    01-28-2012 05:15 PM
  4. jeffrok's Avatar
    I'd try a new home router.. just because it might not be worth the headache of troubleshooting a home router issue if you can buy another for 40 or 50 bucks.
    01-29-2012 08:55 AM
  5. dedeandmaddog's Avatar
    did a factory reset on phone, it now works again...

    still would like to know what the cause was, but I will accept that my phone can now connect to my home wifi again
    01-29-2012 09:55 AM
LINK TO POST COPIED TO CLIPBOARD