1. kgtfl1p's Avatar
    My Nexus s 4g is stuck on initializing when i turn on my 4g it doesnt even say connected or disconnected.
    02-13-2012 05:34 PM
  2. BenjaSands's Avatar
    This happened to me. I turned off the 4G and on, or restarted the phone. Or lastly, restart the phone with the 3G connection active theeen try to turn it on again.
    02-13-2012 07:43 PM
  3. kgtfl1p's Avatar
    I restarted and rebooted the phone its still stuck on initializing. :/
    02-13-2012 08:41 PM
  4. kgtfl1p's Avatar
    Anyone?
    02-16-2012 08:07 PM
  5. Makinola's Avatar
    What version of Android are you using and do you have a strong 4g network where you are turning on 4g?
    02-16-2012 09:16 PM
  6. gunderson's Avatar
    I'm having a similar problem: NS4G WiMAX stopped working on Feb 9th.
    - still in same area of strong coverage, also tried other parts of town where it always worked.
    - started with turning phone off and pulling battery.
    - reprogrammed phone from within terminal mode(re-entering phone# and MSL code), phone then restarts
    - deactivated, then reactivated phone meid from my Sprint account.
    - note that I also have a Sprint Overdrive Pro and Clear Spot 4G and WiMAX stills works great on both of those.
    - Finally, as last resort, did a hard reset on th phone.
    - during entire process, WiMAX connection status in settings shows: Connecting, Initializing, and Disconnected in quick succession.

    Still no WiMAX functionality. After telling
    Sprint tech support all of this, they suggested it is most likely my hardware that has failed, as I had feared.

    Hope that gives you some ideas.

    - TouchPad with webOS, Pre 2, Nexus S 4G
    02-17-2012 09:02 PM
LINK TO POST COPIED TO CLIPBOARD