1. ponlaluz's Avatar
    The other day, for seemingly no reason, my power button stopped working. I couldn't wake up the screen without plugging it in to the charger or removing and replacing the battery. However, it randomly started working again the same day and I had no problems. But this morning I clumsily dropped my phone and the power button stopped working again. This makes me think it's a physical problem, since I have had no issues with the ROM.

    Is there anything I can do about this? My phone is rooted so I don't think Sprint will fix it.
    03-04-2012 07:24 PM
  2. ponlaluz's Avatar
    03-04-2012 09:04 PM
  3. btc0526's Avatar
    Well this happens quite alot on the Galaxy and Nexus S line of phones. You can take it into the sprint repair store as is because its a hardware problem and not a software problem. Had that problem on my epic which was rooted with ACS frozen sydicate 1.2 rom and they didnt say anything about it. Just had me there 30 minutes and then they sent me on my way
    03-04-2012 09:24 PM
  4. kevincwelch's Avatar
    An easy thing to check would be to see if there is some lint or something else wedged in there. This has happened to me with both my power button and the mini USB port, both of which were cleaned by blasting air into the areas.

    Other than that, it's probably a deeper contact mechanical issue.
    03-04-2012 09:51 PM
  5. Ryuuie's Avatar
    This actually seems to be a large issue with this phone. There are two threads on XDA (both with fixes that seem to work or don't work) and multiple Google Support forum threads. It's as if a lot of phones just had their power button just fail randomly.

    The problem seems to be hardware based and something you'll have to take to Sprint (or T-Mobile) or Samsung to.

    Hopefully you can get this fixed and it doesn't turn out to be a big issue.
    03-04-2012 10:28 PM
  6. Paul627g's Avatar
    Despite what members say you should restore the device to stock to insure not having a problem with the store servicing the device.
    03-05-2012 01:59 AM
  7. kanucme's Avatar
    having the same issue but now i cant get into bootloader (power button unresponsive) to return it to stock... please help
    06-30-2012 02:50 PM
  8. justryan's Avatar
    My son's Nexus S had the same Power Button failure. I looked around online for a solution and saw something related to cleaning out the "gunk" behind the button. When I pulled the back panel off the device (you can see how to do so on this YouTube Video: )

    I cleaned out the button on the case panel, and then shot air into the white power button on the side. I also noticed that the mother board connector pad, which connects the white power button to the board, was not attached. This is critical and probably came loose when my son dropped the device. It could have also came loose when I took the back cover off. I gently connected the pad back to the board and reassembled the unit. Everything now works as designed.
    04-17-2013 10:03 AM
  9. gijoecam's Avatar
    FWIW, mine did the same thing in my pocket sometime in the last 48 hours... It's been retired from phone duty for several months, but I've been using it as a fancy MP3 player for several months now. Apparently it went dead since Monday, and when I discovered it this morning, I plugged it in to charge it, and get no response from the screen showing the charging indicator. Pressing the power button the first time flashed the google screen, and then nothing since. I tried a battery pull to no avail... Nothing happens at all. It was getting warm while plugged in, so presumably it charged for several hours today, but I still get no response from the power button. Unfortunately taking it to Sprint is pointless as it's not a usable phone on my account... Which sucks because I was keeping it for a spare in case my wife broke hers. I might try popping it apart tonight to see if it's a button issue, but I think there may be something else going on...
    04-17-2013 02:49 PM
  10. fcukyoukinja's Avatar
    The only problem is there is no connectors, power button in Nexus S is directly soldered to the main board.
    Touching (disconnect/reconnect) s o m e connectors helped me the first time I had power button problems with my Nexus S, unfortunately it wasn't so next time it happened.
    For now I'm stuck with software screen switch off and no lock - volume button screen switch on.
    02-06-2014 01:40 PM