1. PreAaronr's Avatar
    I'm hopeful someone would verify where I found the positive and negative charging terminals are before I take a soldering gun to my new Photon. I want to mod the Photon to work with the back cover of the HP / Palm Pre and the Touchstone Inductive charging base (see Palm.jpg).

    The Motorola Photon 4G MB855 is easy to tear down. It uses Torx 5 screws. I did not know what size Torx the screws were so I picked up a Torx combo screwdriver at Lowes (model 239384 pictured Torx4.jpg). There are 10 screws to remove the interior plastic shell (see PHOTON.jpg). Screw #5 is located under a rubber grommet and screws #9 and #10 require you to peel small round stickers off to get to the screws. I just used a safety pin to pry the stickers off.

    Once the screws are out, lift off the plastic shell and take the rubber spacer away from the micro USB and HDMI inputs (see PHOTON2.jpg). I labeled the positive terminal I found in that image.

    Take a voltmeter and look for the positive and negative contacts. This is the step where I can use some verification as I am not an expert. I found the positive contact to the left of the Micro USB and the negative contact close by (see PHOTON3.jpg and PHOTON4.jpg).

    The Sim card and Micro SDHC card module comes off with one Torx 5 screw if you need more space to work (PHOTON6.jpg). There is some adhesive under this module to the left of the Sim (opposite side of the screw) so lift slowly with constant pressure.

    I ordered some 26 AWG enameled coated wire and a Weller WP25 soldering iron and a Weller ST7 Conical Tip for the project. Hopefully between now and when it comes in, someone else can verify where I found the +/- contacts.

    Thanks in advance.
    mk3 likes this.
    08-28-2011 06:01 PM
  2. ccrooks's Avatar
    if you touch the + contact with the red lead and the - contact with the black lead and the voltmeter reads positive, then you've got it correct. It should read negative if you have the leads flipped...
    08-28-2011 09:19 PM
  3. Puzzlegal's Avatar
    Good luck! I am also a pre refuge, and I would live to see someone succeed at this mod, even if I it's too fussy for me to reproduce.
    08-29-2011 10:25 AM
  4. dullgeek's Avatar
    +1. I miss my touchstones, especially in my car. I don't want to buy that $60 car thingy for the MoPho.
    08-29-2011 10:37 AM
  5. PreAaronr's Avatar
    I did a little more work on this project and I hit a wall. I could use advice from those with more electrical knowledge than I have (which is probably just about anyone). I peeled off the back of the inductive case from the Pre back. I put it on some non-stick paper (from a sheet of labels) since there is adhesive residue that can be re-used (Palm1.jpg). I put the inductive coil in the Photon and the back closes without any issues. There is plenty of clearance and you do not even need to strip out the battery padding on the inside of the Photon case.

    I found which terminals on the Pre back were positive and negative with a voltmeter. The bottom one is positive on the one I have (Palm2.jpg). I soldered two enamel coated wires to the Pre back and I touched them to positive and negative contacts on the Photon that I found in an earlier step (Palm3.jpg). It did not charge the battery. I was watching the reflection in the granite counter to see the battery. The most the Photon would do is light the white (not green) LED with the battery out of the device. When the battery is in the device and it is turned on, I could not get the Photon to do anything. So, I'm stuck. I am not going to take a soldering gun to the Photon until I can get it to charge by touching the Pre wires to the Photon contacts with the Pre back on the Touchstone.

    Any thoughts?
    09-05-2011 03:08 PM
  6. PreAaronr's Avatar
    The voltage is different. This could be an issue. I get 5.61 volts coming from the Palm Touchstone. The Photon reads 4.48 volts when charging.
    09-05-2011 03:33 PM
  7. chasen's Avatar
    any more info?
    i bought all the stuff, just haven't torn down yet, now i'm glad after seeing this...
    09-29-2011 03:29 PM
  8. liggy's Avatar
    I'm also interested in this. Someone did a mod on a Evo4g last summer, think I read it in the AC Evo forums back then,. Might be able to find some info there!!
    09-29-2011 04:29 PM
  9. chasen's Avatar
    i have this done to my wife's evo 4g, and i want to do it to mine..

    i wonder if i can just wire it to the prongs on the battery terminal.. hmm
    09-29-2011 07:46 PM
  10. PreAaronr's Avatar
    I thought about the battery terminal idea too. If the battery does not have some sort-of overcharging chip (and I am not sure if it does), this may precipitate badness with overcharging a lithium ion cell.

    The other thought I had was that the 26 AWG enameled coated wire simply did not make a good enough contact with me holding it to a very small + contact.

    As it turns out, the Pre Touchstone makes a nice holder for the phone without any modification and I am using it to plug in the cord to the side of the phone until I can get this charging mod to work.
    10-03-2011 07:10 PM
  11. Joshhouse82's Avatar
    Any updates?

    Sent from my MB855 using Tapatalk
    10-26-2011 07:10 PM
  12. hirenpathak's Avatar
    any update on this?? I would really like to have this working.
    10-27-2011 04:19 PM
  13. PreAaronr's Avatar
    No luck. I tried wiring in a resistor to bring the voltage down to the exact voltage observed when charging with a USB cable. The contacts that I found earlier in the thread will not charge the battery even when the voltage is the same.

    The voltage on the actual battery contacts is 2.73 volts. I didn't try to find a resistor to bring the voltage down that low since I didn't want to directly charge a lithium cell.

    The only thing I did not try is the two USB contacts under the mainboard. You can see them at the 2min 40sec mark in the teardown video below:

    01-14-2012 05:01 PM
  14. kruglovus's Avatar
    Are there are any updates on this attempt to TouchStonify the Photon?

    @androidaaronr, did you try to connect TouchStone positive cable to Pin #1 of the microUSB port? On your picture above ...Touchtstone Mod-photon3.jpg I can clearly see 5 pins going from microUSB port to motherboard. If I understand Wikipedia pinout correctly, +5V should be the 1st pin from the right. Negative/Ground is 1st from the left or the whole big metal plate around the microUSB port.

    I personally don't have a Photon. Can anyone try this and report back?
    05-03-2012 01:27 PM
  15. PreAaronr's Avatar
    I tried + lead to 1st pin from the right with - lead on first pin to the left and the metal USB housing. It still does not charge the device.
    05-09-2012 03:44 AM
  16. kruglovus's Avatar
    I tried + lead to 1st pin from the right with - lead on first pin to the left and the metal USB housing. It still does not charge the device.
    This is bizarre. I mean it's all USB 2.0 standard specification. It has to work. I can think of only one explanation - the phone needs to be re-assembled, i.e. all boards and contacts needs to be put together. No, that's not it. You have pictures with the phone half-disassembled and running. Well, verify that in this half-disassembled state the phone can charge from a regular microUSB cable.

    For testing purpose, you can also try connecting Touchstone plate contacts to a microUSB plug. Sacrifice a USB cable by cutting it in the middle and connecting Touchstone plate + and - to respective wires in the USB cable. Then put the microUSB plug into the phone. Also test this setup on other phones (or any microUSB devices that can charge from a PC USB port).

    P.S. When I did this Touchstone-to-microUSB-plug on my EVO, I wasted many hours because of the no-charging bug in a kernel of a custom ROM (CM6-WiMAX-alpha1). If your Photon is not stock, just test it with both phone off and on.
    05-09-2012 10:10 AM
  17. EmC350's Avatar
    I tried this mod myself with no luck so far. I'm trying the usb plug method cause I don't want to void my warranty. I have the plug and back all set up correctly. I tested it with my pre2 and it charges it fine. When I plug in the Photon, it goes ape . It cycles through charging and not charging. I also get the notification that the battery is fully charged and to unplug the charger. Also I can hear a humming noise coming from the phone when I try to use the touchstone. It might be some kind of "surge protector" to keep the phone from charging if too much voltage is applied.

    androidaaronr: What resistor did you use to bring down the voltage?
    05-22-2012 07:16 PM
  18. fubka's Avatar
    Any updates or progress?
    06-26-2012 02:51 PM