1. vertexoflife's Avatar
    Hello,

    I had a rooted stock Photon Q LTE and I went to update to jelly bean. When I go to do so, it boots into CWM and asks if I want to install an unerified ZIP. I do so and get "assert failed" error.

    I found this thread http://forums.androidcentral.com/opt...rt-failed.html

    That recommends opening /META-INF/com/google/android/updater-script
    And deleting the first line of text.

    How do I go about finding and opening this file to delete the text?

    Thanks!
    05-08-2013 10:36 AM
  2. vertexoflife's Avatar
    Well, I found the update, copied it, and followed the directions in the above thread about deleting the "assert" part, but unfortunately that did not work. I think I need to try to figure out how to restore to stock, unrooted.
    05-08-2013 11:38 AM
  3. burro loco's Avatar
    I was having the exact same problem but I solved it this way.
    I flashed the recovery.img that I got from here: https://www.box.com/s/owfhujolsj4bz0odmx27
    If you rooted your phone it means you know how to flash with fastboot like:
    You need to enter the following command lines in the Command Prompt:
    > fastboot devices - this will show the serial number of your device. If it is the correct one, get to the next step.
    Install the recovery file using the command below:
    > fastboot flash recovery recovery.img - this will push the custom recovery to your device.

    Then download voodoo OTA RootKeeper and protect root and temp unroot. From here https://play.google.com/store/apps/d...9vdGtlZXBlciJd
    Or here
    Redirecting

    I got this tip from XDA at Jelly Bean SOAK TEST Over! Official Rollout Begins Soon... - Page 15 - xda-developers

    I hope this helps. BTW how and where did you find the update file cuz i couldn't?
    05-08-2013 12:44 PM
  4. cheynems's Avatar
    I attempted to apply this fix in order to download the OTA updates. The custom recovery installed correctly and everything booted up fine. The update also made more progress than previously but now when my Q restarts the install gets about a quarter of the way then fails. I don't get any error message, it just boots up and says the update failed. Any idea why this might be happening? My phone is unrooted already, but I tried this using OTA RootKeeper and again without using it, with the same results. I searched through that forum but couldn't find anything either.
    05-08-2013 02:43 PM
  5. marcog22's Avatar
    Sprint just released Jellybean 4.1.2 for Photon Q this morning. Sorry I know I have been trying to get this OS for some time and it has finally been released.
    05-08-2013 05:08 PM

Similar Threads

  1. Problems post jellybean update for htc evo lte
    By bigrey81 in forum HTC EVO 4G LTE
    Replies: 3
    Last Post: 12-13-2012, 01:18 PM
  2. Replies: 1
    Last Post: 11-16-2012, 06:02 AM
  3. Newbie, just updated to Jellybean, what's the easiest way to root my phone?
    By Defcon One in forum Verizon Galaxy S III Rooting, ROM's, and Hack's
    Replies: 6
    Last Post: 09-18-2012, 09:27 AM
  4. what happen to the speech to text on froyo update(Rooted oxeded ROM)
    By smprfi1999 in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 14
    Last Post: 08-16-2010, 08:24 PM
  5. to wipe+update+root+froyo or not to root? that is the question
    By mudpud in forum Verizon Droid Incredible
    Replies: 8
    Last Post: 07-29-2010, 10:23 AM
LINK TO POST COPIED TO CLIPBOARD