1. lancehart's Avatar
    Anyone else having issues with their GPS not locking on a Sprint GS4?

    I just used Google Map / Nav daily for several days while on a trip in Tennessee and while driving home on July 31st with no problem...
    Thursday morning (Aug 1st) my GPS refuses to lock... can't get accurate map location, can't play Ingress at all, etc... checking it daily since then
    and it still wont lock. (This is in the greater Charlotte area of North Carolina by the way...)

    I went to a Sprint store to show them, unfortunately the store was full of iPhone employees not as familiar with Android, but we pulled a demo GS4 out and it wouldn't lock either.
    Pulled the latest Sprint LG unit out, it wouldn't lock either.
    Left frustrated...

    Went home, pulled out my WIFI only model Galaxy Tab 2 7" and it locked no problem...
    BUT... I powered up my old Sprint GS2 (Epic Touch) which no longer has Sprint service, but connected with WIFI and it also refused to lock GPS. (Blinking icon, not solid)

    So anyone else having GPS problems with Sprint anywhere else in the country, or even better... in North Carolina?

    The only other item I noticed is that my phone downloaded a new update to Google Map on the night of July 31st before the problem began,
    but my GS2 did not have this new update and still had the problem.

    Any advice? Already tried reboots, reset/clear cache of Google Maps app, pulled battery for over a minute and reset... no change
    and mystified why it didn't work not only on my GS4 but a brand new GS4 and LG unit at the sprint store. Oh... I made them take all
    three phones out to the parking lot so we had a clear view of the sky... so no building interference issues.
    08-03-2013 08:49 PM
  2. Darnell0216's Avatar
    My wife and I got our S4's last week and got GPS lock right out of the box, both before and after all our updates were installed. We're in NJ. It may have been an area specific problem. Did you ever get it resolved?
    08-11-2013 11:16 AM
  3. mikepolinske's Avatar
    I also have been having trouble with the GPS on my phone. I'm not sure if it is because my signal is so poor at work or what, but at home where I have a good signal I don't have the problem.
    08-14-2013 04:52 PM
  4. TomD's Avatar
    If you toggle GPS off and back on, that works for me when GPS gets stuck.
    08-17-2013 06:00 AM
  5. lancehart's Avatar
    UPDATE - GPS will still not lock when I'm in the greater Charlotte, NC area. Since then I have talked to Sprint who reported that towers all over the entire area are being upgraded. Each tower is down for 7-10 days on average, and then they move on to the next tower, so the problem wont resolve itself until they are nearly finished, which apparently isn't going to happen until about the end of September. However, as soon as I leave the area (went down to South Carolina last weekend) and GPS locked in almost immediately again during the entire trip, only to come back and have it broken again in Charlotte.

    Tested it on co-workers and friends phones with the same result no matter what model they had, as long as they were on Sprint, there was no GPS lock.

    On the bright side, I'm picking up 4G LTE in more areas that never had it before...
    08-19-2013 01:52 PM
  6. bwolfe90's Avatar
    I was having a similar problem last week and the week before, but it seems to have gone away. Not sure, but it seems to have gotten better after a complete reboot, including shutdown, battery removal and restart.
    08-20-2013 10:44 AM
  7. TomD's Avatar
    I'm confused by your linking cell towers with GPS. They are not related. Perhaps you are talking about one of the navigation apps. Nav apps need a data connection, GPS only uses satellites.

    Posted via Android Central App
    08-25-2013 12:00 PM

Similar Threads

  1. External speaker suddenly not working
    By RichardClark in forum Samsung Galaxy Note 2
    Replies: 18
    Last Post: 07-18-2018, 06:47 AM
  2. Not able to connect to 4G LTE! ?
    By STARGATE in forum Sprint Samsung Galaxy S4
    Replies: 73
    Last Post: 03-18-2014, 07:36 PM
  3. When will the AT&T Galaxy S3 get the 4.1.2 update via Kies???
    By iOS Gravity in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 5
    Last Post: 08-11-2013, 10:00 PM
  4. Keypad not responding to incoming calls on Samsung S3.
    By jobron35 in forum Samsung Galaxy SIII I9300
    Replies: 1
    Last Post: 08-03-2013, 11:24 PM
  5. App Data and Notifications not syncing.
    By Trickmott in forum General Help and How To
    Replies: 1
    Last Post: 08-03-2013, 02:03 PM
LINK TO POST COPIED TO CLIPBOARD