1. A Username's Avatar
    So I woke up this morning and saw that the MK2 update wanted to install on my phone. I accepted and soon had to leave my house to attend an event. When I got back, I realized that my phone couldn't connect to WI-FI. When I go into my notification panel and click on the WI-FI toggle, it immediately dims and refuses to turn on and light green. When I go into the setting itself I get the message "To see available networks, turn on WI-FI" (again the button switches back to OFF the moment I try to turn it ON).

    I was rooted before. This my current device info :MK2 update broke my WI-FI how do I fix?-2013-12-14_16.20.27-1-.jpg

    I also tried to re-flash the MJA modem with odin, but I still got the same problem.

    Please help. Im regretting updating to 4.3 in the first place with all these stupid problems

    Would KIES help this issue (Im updating it now to try)
    12-14-2013 05:25 PM
  2. EviI's Avatar
    Nevermind, below post has got it.
    12-14-2013 05:49 PM
  3. unixpsycho's Avatar
    No. dont do that.

    If you have MK2 build number, simply flash the MK2 modem and baseband. You already have the MJA modem, hence why WiFi doesn't work.

    FYI: There are like 3-4 threads in this forum stating the same problem and how to fix.
    12-14-2013 05:54 PM
  4. A Username's Avatar
    No. dont do that.

    If you have MK2 build number, simply flash the MK2 modem and baseband. You already have the MJA modem, hence why WiFi doesn't work.

    FYI: There are like 3-4 threads in this forum stating the same problem and how to fix.
    Thank you. The flash worked like a charm. I'll try to be more observant when asking for help/looking for threads but I didn't see any for my question.
    12-14-2013 06:16 PM

Similar Threads

  1. Please Help!!! It seems I've hard bricked my phone!
    By ermahgerderndrerd in forum Sprint Galaxy S III
    Replies: 6
    Last Post: 02-06-2014, 08:35 PM
  2. MJA Update Help Please...
    By DASHZNT in forum Sprint Samsung Galaxy S4
    Replies: 3
    Last Post: 12-16-2013, 01:49 PM
  3. Do I have a virus?
    By stepaul8 in forum Android Security Talk
    Replies: 5
    Last Post: 12-16-2013, 10:04 AM
  4. Will this mess up my phone service ?
    By Anino4 in forum General Help and How To
    Replies: 6
    Last Post: 12-15-2013, 09:41 PM
  5. How do i use TWRP Manager Note 3
    By MasterxGamer in forum Samsung Galaxy Note 3
    Replies: 5
    Last Post: 12-15-2013, 08:51 AM
LINK TO POST COPIED TO CLIPBOARD