1. VSAM1's Avatar
    ok guys, here I am once again I have found out that the problem is the update VPUFNAE or the NAE like we call it doesn't change
    our Baseband version. if you go to SETTINGS and About device you will notice that the baseband its still MK2 if you previously had
    the MK2. but if you go down a little bit you will find out that the build Number its the new NAE., if you have this problem, this is the reason why the
    wifi doesn't turn on. in order they have to match, am writing this in simple words. so I came out with the same problem wifi wont work after updating
    to the new kitkat version 4.4 also known as NAE this might be because I had rooted my phone.

    I have had previously explained how to fix this on the MK2 version when we had the MJA. and the MK2 update came out.you can check it out on this
    link so you have an idea what we talked http://forums.androidcentral.com/spr...lled-wifi.html

    so but how we fix the NAE wifi problem ? well I will explain it to you below it is really simple.
    I am not an expert but I have the ability to figure things out. and this helps me a lot. and saves me a lot.
    NOTICE! this method wont make you lose any data, like pictures apps etc.
    the steps are easy here we go....

    First- you will need odin3-v1.85 note! ( you might already have it when you downloaded it to root your phone )
    if you don't have it just Google it and type odin3 v1.85 click on the Odin 1.85 - XDA-Developers link
    Second- get the firmware xda-developers - View Single Post - [FIRMWARE][ODIN] All Sprint Firmwares {2/13/14}
    we will need NAE MODEM FIRMWARE so download the one that says NAE mirror 1.
    once downloaded unzip it on your desktop or anywhere as long as you know where it is.
    Third step- open odin3-v.185 run it as administrator (you can see it by doing a right click )
    Fourth step- get your phone onto download mode( by powering off then hold vol down and power) hit continue on your phone!
    then plug your phone to your computer and Odin will detect the phone. (make sure you have the Samsung USB Driver for Mobile Phones you
    don't have it this might be a reason why wont work.
    Fifth step- check Odin once the phone is detected, click on PDA and find NAE-modemonly file where you unzipped and select it. make sure auto reboot is
    checked on odin nothing else some Odin versions has this already checked so you cant mess with it. but some don't.
    Sixth step- click start and let it work. after its done it will reboot.
    and now you will have your phone working as it used to. I got this method to work on my sprint Galaxy S4
    hope this post will help understand.
    02-17-2014 12:26 AM
  2. sambo57u's Avatar
    Someone at XDA suggested an easier approach; download the firmware zip file (available at XDA) to your external SD card.
    Boot the phone into recovery mode by holding the volume down and power buttons simultaneously until it boots into the
    recovery mode. Select update system from external storage (or something similar), select the zip file and redo the update
    this way manually. Apparently, this does it. I just updated mine manually Saturday and everythign is at the same version with
    no problems.
    02-17-2014 09:05 AM
  3. isuftin's Avatar
    VSAM1, this method worked. sambo57u, I also tried your method first but it did not work. During the update through the recovery mode method, it hit two errors and tried to finish the update. Afterwards, I rebooted and still had no access to wifi.

    Side-loading through ODIN works though.
    02-25-2014 04:54 PM
  4. diamondwhitt's Avatar
    Dude it's NAE not NEA goofy ***.
    02-26-2014 02:34 AM
  5. VSAM1's Avatar
    Glad it worked for you isuftin.
    03-01-2014 01:04 AM
  6. scottsdale_34's Avatar
    got my kitkat update via Samsung Kies.. it killed my Wifi too... I kept getting a security warning.. I went to the Sprint store and they wanted to wipe my phone and do a factory reset and reload the kitkat software.. I grabbed my phone and ran out of the store. I knew there had to be an easier way and I found this.. this was perfect.. what a lifesaver.. thank you!! Was so fast and easy to install using Odin and downloading the file marked "Latest NAE firmware".
    03-01-2014 11:15 PM
  7. rlwark's Avatar
    Dude you rock thanks I am back working.
    03-06-2014 09:45 PM
  8. jd11023's Avatar
    Words cannot describe the appreciation I have for you, VSAM1. Ever since I installed KitKat, WiFi wouldn't work and I spent hours upon hours fiddling with it. You saved me heartache, headache, and a dreaded trip to Sprint. Thank you, sir. You're a good one.
    03-07-2014 01:01 AM
  9. equisch3x's Avatar
    Wow thank you. Saved my friends phone. Awesome thread.
    03-20-2014 09:51 PM
  10. rahulf2's Avatar
    EDIT: Nevermind. I flashed the stock ROM (AFTER) updating the modem and it seems to work. Thank you!

    I have tried this + many other attempts (flashing stock, using wipe data/factory reset) etc. but I have not fixed my wi-fi problem.

    The problem, specifically, is that my Wi-Fi will not turn on! I can press/hold the on switch for as long as I want and nothing will happen! The same thing happens if I try to turn on the "hotspot" option in my settings (although I never use it).

    My mobile data works, but if anyone has a solution to this wifi problem I would be greatly appreciative!
    03-27-2014 03:02 AM
  11. bond17_007's Avatar
    Same issue.. flashed to NAE modem but still no wifi.
    04-21-2014 02:41 PM
  12. j4gz's Avatar
    Hi guys I have a similar issue I am still on 4.2.2 rooted and mdc , mf9 I keep losing my wifi never get a signal unless siting next to the router so what would you guys advise that I just Odin the nae modem and everything should be fine and back to normal ?
    05-08-2014 05:10 PM
  13. Michael Rockin's Avatar
    bro i just wanna kiss you so bad man thx
    05-16-2014 03:21 AM
  14. Elpoep's Avatar
    Hi-- I received a phone in boot loop.

    I used the newest Odin, 3.10.0, and flashed a stock rom for my SPH-L720 (Sprint Gal S4). This cleared my boot loop. -- I have updated Samsung USB drivers -- v1.5.45.0(1)

    Wifi has not worked and I had a pretty lengthy thread over at xdna for help.

    I tried two different stock roms... and nothing. I tried Odin 3.7... and nothing.

    I'm back on a stock rom and the phone is on Android 4.4.2

    Baseband is L720VPUFNG2

    will this method fix my wifi? If so, do I have to root the phone again or can I simply just flash the modem?

    Do I need the NAE version with the bootloader or the one without?
    UPDATE: I tried flashing the NAE mirror version and Odin gave me a pass BUT my phone gave me a security warning "...an unauthorized action was blocked..." BUT my baseband now says: L720VPUFNAE with build Number:

    Still no Wifi

    I'm on a stock rom -- phone is NOT currently rooted.

    Thanks for posting this thread and double-triple thanks if you reply!... so, uh THANKS!!!
    07-27-2015 07:10 PM

Similar Threads

  1. Will S4 mini get 4.4
    By Hvacmanjc in forum Samsung Galaxy S4 Mini
    Replies: 6
    Last Post: 02-20-2014, 10:29 AM
  2. AT&T 4.3 OTA Update
    By Jeb Bruce in forum AT&T Galaxy S III
    Replies: 2
    Last Post: 02-18-2014, 08:55 AM
  3. How do i know if my tablet is rooted?
    By Ziggy925 in forum General Help and How To
    Replies: 2
    Last Post: 02-17-2014, 12:49 AM
  4. s4 battery
    By armin80 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 4
    Last Post: 02-17-2014, 12:41 AM