1. xatt15's Avatar
    I rooted my Samsung Galaxy S4 today with a fresh CM 10.2.1 ROM, and I cleared all the data and caches via CWM recovery before doing so. I also flashed the appropriate Gapps ZIP (20130813) for that version. I was able to login to Google at startup. However, the Google Play Store would refuse to connect, giving me the dreaded "No Connection" error. I tried EVERYTHING, including adding the IP for the Android Google Play servers into the hosts file, which just changed the error message to "Connection timed out." I even tried wiping my phone and re-flashing both of them.
    05-29-2014 08:38 PM
  2. Tdub08's Avatar
    Remove the google account and then re-add the account. This was how I fixed this issue.
    06-06-2014 02:49 PM
  3. stew99969's Avatar
    Go to /system/etc/ and open hosts, delete or comment out anything connecting to google.
    08-28-2014 02:00 AM

Similar Threads

  1. Replies: 2
    Last Post: 02-03-2015, 04:05 AM
  2. Any awesome apps to customize s5
    By Neuer27 in forum Samsung Galaxy S5
    Replies: 15
    Last Post: 05-31-2014, 01:14 PM
  3. Replies: 1
    Last Post: 05-30-2014, 12:21 AM
  4. Moving Saved Wi-FI Connections With Passkeys to S5
    By walterwood44 in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 05-29-2014, 09:00 PM
  5. Possible to load new android version
    By Andrew Borys in forum Virgin Mobile Optimus Slider
    Replies: 0
    Last Post: 05-29-2014, 08:22 PM