1. grabb0r's Avatar
    I tried asking this on XDA but I didn't get much help; hopefully here will be more productive. Anyway, onto the meat and potatoes...

    I bought an S4 (specifically, the L720T) via Swappa to use with FreedomPop's BYOD program. With their "unlimited everything" service I get 1GB of 4G and then unlimited unthrottled 3G after that. After getting the phone I picked up a SIM card from a local Sprint store as instructed and I was off to the races. Long story short, my LTE is fantastic (30mb/s... I have a tower right on top of my apartment) but once the gig is used and I'm on 3G I only get a trickle of data at less than 50kbps. FreedomPop's offshore ESL tech support is scripted and pretty much useless as far as actual tech support goes, so I've been trying to figure things out myself for the past month and a half; I think I might have identified the issue, but I don't know how to fix it. One of FreedomPop's setup steps is to dial ##786# (to enter the RTN menu) and enter the MSL to do a reset. Obviously, none of the RTN info (like the phone number) is actually mine since I'm not the original owner of the phone.

    The problem is that when I try the RTN reset the phone just does a factory reset and none of the RTN info is changed. ##72786# doesn't change it either. Every single wipe-and-reset procedure, from the settings menu to the recovery, won't touch it. I even Odin'd the correct stock firmware properly and tried various resets. Still nothing. My theory is that this is what's causing the issue with FreedomPop's service; my speedtests when connected via LTE - which relies on the SIM card - correctly connect to servers less than 100 miles away, while my 3G connection seems to be "confused" and wants to connect to places like Houston, Tampa, Washington D.C., etc... I'm in the midwest. I think that because the phone number listed in the RTN is a (566) number and it's not in service it's causing some kind of conflict.

    I was wondering if you kind folks could help me actually reset the RTN info so that I can properly setup my phone.

    Also, not sure if this is related but it might be since it's a "phone not TOTALLY resetting" issue... Prior to reflashing the stock firmware last week, the phone was rooted (stock). I had installed xposed framework and some mods which did things like changing loading bar gfx and removing the "high volume" notification. Even after all of the resets and reflashing the stock firmware, these two changes seem to be persisting. Possibly others, but these are the only two I can identify without re-rooting and reinstalling xposed and Galaxy Tools. Not that I mind; I like the mods, but it's indicative that something's not resetting for some reason.
    05-22-2015 07:55 AM

Similar Threads

  1. Replies: 4
    Last Post: 05-13-2016, 03:36 PM
  2. Replies: 3
    Last Post: 05-26-2015, 02:45 PM
  3. Will all wireless chargers work with an LG G3?
    By AC Question in forum LG G3
    Replies: 4
    Last Post: 05-22-2015, 01:55 PM
  4. Unlocking my Galaxy S5
    By Hasan Gungormez in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 05-22-2015, 11:39 AM
  5. Replies: 1
    Last Post: 05-22-2015, 11:38 AM
LINK TO POST COPIED TO CLIPBOARD